source: projects/specs/trunk/r/rocs/rocs-vl.spec @ 8430

Revision 8430, 4.2 KB checked in by Takemikaduchi, 10 years ago (diff)

KDE-4.12.5

RevLine 
[4743]1Name: rocs
2Summary: Graph theory IDE
3Summary(ja): グラフ理論向け IDE
[8430]4Version: 4.12.5
[4743]5Release: 1%{?_dist_release}
6
7License: GPLv2+
8Group: Applications/Edutainment
9URL: http://edu.kde.org/rocs/
10
[6725]11Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
[4743]12
13## upstream patches
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: desktop-file-utils
17BuildRequires: kdelibs4-devel >= %{version}
18BuildRequires: libboost-devel
[6725]19BuildRequires: libboost-graph
[4743]20BuildRequires: soprano-devel
[7801]21BuildRequires: grantlee-devel
[4743]22
23Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
24Requires: kwrite
25
26Conflicts: kdeedu4 < 4.6.50
27
[8252]28Vendor: Project Vine
29Distribution: Vine Linux
30
[4743]31%description
32Rocs aims to be a Graph Theory IDE for helping professors to show
33the results of a graph algorithm and also helping students to do
34the algorithms.
35
36Rocs has a scripting module, done in Qt Script, that interacts with
37the drawn graph and every change in the graph with the script is
38reflected on the drawn one.
39
40This package is part of the KDE education module.
41
42%package libs
43Summary: Runtime libraries for %{name}
44Summary(ja): %{name} のランタイムライブラリ
45Group:   System Environment/Libraries
46Conflicts: kdeedu4-math-libs < 4.6.50
47
48%description libs
49%{summary}.
50
51%package devel
52Summary: Development files for %{name}
53Summary(ja): %{name} の開発用ファイル
54Group: Development/Libraries
55Requires: %{name}-libs = %{version}-%{release}
56Conflicts: kdeedu4-devel < 4.6.50
57
58%description devel
59Header files for developing applications using %{name}.
60
61%prep
62%setup -q
63
64%build
[7801]65# uniform_int_distribution error
66sed -i "s|add_subdirectory(GenerateGraph)|#add_subdirectory(GenerateGraph)|" VisualEditor/Tools/CMakeLists.txt
67
[4743]68mkdir -p %{_target_platform}
69pushd %{_target_platform}
70%cmake \
71    -DCMAKE_BUILD_TYPE=release \
72    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
73    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
74    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
75    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
76    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
77    ..
78popd
79
80make %{?_smp_mflags} -C %{_target_platform}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%check
90for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
91    desktop-file-validate $f
92done
93
94
95%posttrans
96update-desktop-database -q &> /dev/null ||:
97
98%postun
99if [ $1 -eq 0 ] ; then
100    update-desktop-database -q &> /dev/null ||:
101fi
102
103%post libs -p /sbin/ldconfig
104
105%postun libs -p /sbin/ldconfig
106
107
108%files
109%defattr(-,root,root)
110%doc COPYING COPYING.DOC
111%{_bindir}/rocs
112%{_libdir}/kde4/rocs_*.so
113%{_datadir}/applications/kde4/rocs.desktop
114%{_datadir}/config/rocs.knsrc
115%{_datadir}/config.kcfg/rocs.kcfg
[7801]116%{_datadir}/icons/hicolor/*/*/*
[4743]117%{_datadir}/kde4/apps/rocs
[6725]118%{_datadir}/kde4/apps/rocs_rootedtree
[4743]119%{_datadir}/kde4/services/rocs_*.desktop
120%{_datadir}/kde4/servicetypes/Rocs*.desktop
121%doc %{_docdir}/HTML/en/rocs/
122
123%files libs
124%defattr(-,root,root)
[7728]125%{_libdir}/librocscore.so.*
126%{_libdir}/librocsvisualeditor.so.*
[4743]127
128%files devel
129%defattr(-,root,root)
130%{_includedir}/kde4/rocs
[7728]131%{_libdir}/librocscore.so
132%{_libdir}/librocsvisualeditor.so
[4743]133
134
135%changelog
[8430]136* Wed May 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
137- new upstream release
138
[8252]139* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
140- new upstream release
141
[8056]142* Wed Dec 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
143- new upstream release
144
[7801]145* Mon Sep 16 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
146- new upstream release
147- add BuildRequires: grantlee-devel
148
[7728]149* Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
150- new upstream release
151
[7294]152* Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
153- new upstream release
154
[7105]155* Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
156- new upstream release
157
[6899]158* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
159- new upstream release
160
[6797]161* Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
162- new upstream release
163
[6725]164* Mon Aug 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
165- new upstream release
166- add BuildRequires: libboost-graph
167
[4743]168* Sat Sep  3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
169- split from kdeedu
170
Note: See TracBrowser for help on using the repository browser.