source: projects/specs/trunk/r/ristretto/ristretto-vl.spec @ 9401

Revision 9401, 8.7 KB checked in by inagaki, 9 years ago (diff)

2015-03-01 Ryoichi INAGAKI <ryo1@…>

  • ristretto: fixed spec


Line 
1# Review at https://bugzilla.redhat.com/show_bug.cgi?id=351531
2
3%global majorversion 0.8
4%global xfceversion 4.12.0
5
6Name:           ristretto
7Version:        0.8.0
8Release:        2%{?_dist_release}
9Summary:        Image-viewer for the Xfce desktop environment
10Summary(ja):    Xfce デスクトップ環境向けの画像ビューア
11Summary(de):    Bildbetrachter für die Xfce Desktop-Umgebung
12
13Group:          Applications/Graphics
14License:        GPLv2+
15URL:            http://goodies.xfce.org/projects/applications/ristretto/
16Source0:        http://archive.xfce.org/src/apps/%{name}/%{majorversion}/%{name}-%{version}.tar.bz2
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires:  dbus-glib-devel >= 0.34
20BuildRequires:  gtk2-devel >= 2.20.0
21BuildRequires:  libexo-devel >= 0.4.0
22BuildRequires:  libexif-devel >= 0.6.0
23BuildRequires:  libxfce4ui-devel >= %{xfceversion}
24BuildRequires:  xfconf-devel >= %{xfceversion}
25BuildRequires:  desktop-file-utils, gettext, intltool
26Requires:       tumbler
27
28%description
29Ristretto is a fast and lightweight image-viewer for the Xfce desktop
30environment.
31
32%description -l ja
33Xfce デスクチップ環境向けの高速で軽量な画像ビューアです。
34
35%description -l de
36Ristretto ist ein schneller und leichtgewichtiger Bildbetrachter für die Xfce
37Desktop-Umgebung.
38
39
40%prep
41%setup -q
42
43
44%build
45%configure
46make %{?_smp_mflags}
47
48
49%install
50rm -rf %{buildroot}
51make install DESTDIR=%{buildroot} INSTALL='install -p'
52%find_lang %{name}
53desktop-file-install \
54        --dir %{buildroot}%{_datadir}/applications \
55        --add-mime-type=image/x-bmp \
56        --add-mime-type=image/x-png \
57        --add-mime-type=image/x-pcx \
58        --add-mime-type=image/x-tga \
59        --add-mime-type=image/xpm \
60        --delete-original \
61        %{buildroot}%{_datadir}/applications/%{name}.desktop
62
63%clean
64rm -rf %{buildroot}
65
66%post
67touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
68update-desktop-database &> /dev/null || :
69
70
71%postun
72if [ $1 -eq 0 ] ; then
73    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
74    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
75fi
76update-desktop-database &> /dev/null || :
77
78
79%posttrans
80gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
81
82
83%files -f %{name}.lang
84%defattr(-,root,root,-)
85%doc AUTHORS COPYING ChangeLog README
86%{_bindir}/%{name}
87%{_datadir}/appdata/%{name}.appdata.xml
88%{_datadir}/applications/*%{name}.desktop
89%{_datadir}/icons/hicolor/*/*/*
90
91
92%changelog
93* Sun Mar  1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-2
94- fixed Group typo
95- added Japanese description
96
97* Sun Mar  1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-1
98- Initial build for Vine Linux
99
100* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.6.3-7
101- Rebuilt for Fedora 23 Change
102  https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
103
104* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-6
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
106
107* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
109
110* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
112
113* Wed May 01 2013 Jon Ciesla <limburgher@gmail.com> - 0.6.3-3
114- Drop desktop vendor tag.
115
116* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-2
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
118
119* Tue Jan 01 2013 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.3-1
120- Update to 0.6.3 (#891037)
121
122* Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.0-2
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
124
125* Sun Apr 29 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.0
126- Update to 0.6.0
127
128* Fri Apr 27 2012 Kevin Fenzi <kevin@scrye.com> - 0.3.7-1
129- Update to 0.3.7
130
131* Wed Apr 04 2012 Kevin Fenzi <kevin@scrye.com> - 0.3.6-2
132- Rebuild for Xfce 4.10
133
134* Tue Apr 03 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.6-1
135- Update to 0.3.6
136- Add VCS key
137
138* Sat Mar 03 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.5-1
139- Update to 0.3.5
140
141* Sat Jan 28 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.4-1
142- Update to 0.3.4
143
144* Sat Jan 14 2012 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.2-1
145- Update to 0.3.2
146
147* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
149
150* Tue Nov 08 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.0-2
151- Require tumbler for thumbnail generation
152
153* Sun Nov 06 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.0-1
154- Update to 0.3.0
155
156* Sun Nov 06 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.3-1
157- Update to 0.2.3 (fixes #750657)
158
159* Sat Oct 29 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.2-1
160- Update to 0.2.2
161
162* Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.1-2
163- Rebuilt for glibc bug#747377
164
165* Sun Oct 23 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.1-1
166- Update to 0.2.1
167
168* Tue Oct 18 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.2.0-1
169- Update to 0.2.0
170
171* Sun Oct 09 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.1-1
172- Update to 0.1.1
173- Drop DSO patch, fixed upstream
174
175* Thu Oct 06 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.0-1
176- Update to 0.1.0
177
178* Wed Aug 16 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.93-2
179- Fix two major memory leaks (bugzilla.xfce.org #7882)
180
181* Thu Mar 03 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.93-1
182- Update to 0.0.93 (fixes #542141 and #679808)
183- No longer require xfce4-doc
184- Run update-desktop-database in %%post and %%postun
185
186* Wed Feb 09 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.91-2
187- BR xfconf-devel to fix build after Xfce 4.8 update
188
189* Tue Jul 13 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.91-1
190- Update to 0.0.91 (Development release for next major version)
191- Require xfce4-doc for directory ownership of the nex docs
192
193* Wed Feb 17 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.22-3
194- Add patch to fix DSO linking (#565114)
195
196* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.22-2
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
198
199* Fri May 15 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.22-1
200- Update to 0.0.22
201
202* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.21-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
204
205* Thu Nov 27 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.21-1
206- Update to 0.0.21
207- Remove marshaller fix, included upstream now
208
209* Tue Jul 01 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.20-2
210- Add patch to fix x86_64 bit bug caused by a wrong marshaller (#351531)
211
212* Sat May 24 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.20-1
213- Update to 0.0.20
214
215* Sat May 10 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.19-1
216- Update to 0.0.19
217
218* Sat Apr 05 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.18-1
219- Update to 0.0.18
220
221* Wed Feb 17 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.17-1
222- Update to 0.0.17
223
224* Wed Jan 30 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.16-1
225- Update to 0.0.16
226
227* Mon Dec 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.15-1
228- Update to 0.0.15
229
230* Mon Dec 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.14-1
231- Update to 0.0.14
232
233* Mon Nov 26 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.13-1
234- Update to 0.0.13
235
236* Wed Nov 21 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.12-2
237- Try manual_adjustments.patch
238
239* Tue Nov 20 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.12-1
240- Update to 0.0.12
241
242* Wed Nov 07 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.11-1
243- Update to 0.0.11
244- BuildRequire dbus-glib-devel
245
246* Sat Nov 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.10-1
247- Update to 0.0.10
248- Add more mimetypes: tiff, x-bmp, x-png, x-pcx, x-tga and xpm
249- Correct build requirements
250
251* Fri Oct 19 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.9-1
252- Update to 0.0.9
253
254* Sun Oct 14 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.8-1
255- Update to 0.0.8
256
257* Sun Sep 30 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.7-1
258- Update to 0.0.7
259
260* Sun Sep 09 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.4-1
261- Update to 0.0.4
262
263* Wed Sep 05 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.0.3-1
264- Initial RPM package
Note: See TracBrowser for help on using the repository browser.