source: projects/specs/trunk/r/riece/riece-vl.spec @ 2285

Revision 2285, 5.4 KB checked in by munepi, 14 years ago (diff)

updated riece-vl.spec

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define       origver       7.0.0
5%define       origname      riece
6
7Summary:      Riece is emacs based irc client
8Summary(ja):  Riece は Emacsen 上で動作する IRC のクライアント
9Name:         %{origname}
10Version:      %{origver}
11Release:      2%{?_dist_release}
12
13Source0:      http://dl.sv.gnu.org/releases/riece/%{name}-%{version}.tar.gz
14Source1:      %{name}-install.sh
15Source2:      %{name}-remove.sh
16Source3:      %{name}-init.el
17Patch0:       riece-7.0.0-check-make-local-hook.patch
18
19License:      GPL
20Group:        Applications/Editors/Emacs
21BuildRoot:    %{_tmppath}/%{name}-%{version}-root
22BuildArch:    noarch
23
24Requires(post): emacsen
25Requires(post): /sbin/install-info
26Requires(preun): emacsen
27Requires(preun): /sbin/install-info
28
29%prereq_ge emacsen-common
30%prereq_ge flim
31
32%description
33Riece is a user interface for IRC (Internet Relay Chat). You should spell it
34with the first letter capitalized and pronounce it as /ri:s/.
35
36The features of Riece are as follows:
37 * Several IRC servers may be used at the same time.
38 * Many features built upon the extension mechanism called add-on.
39   Currently 30 such add-ons are available.
40 * Installation is easy. Riece doesn't depend on other packages.
41 * Setup is easy. Automatically save/restore the configuration.
42 * Step-by-step instructions are included.
43 * Mostly compliant with the latest IRC client protocol (RFC2812).
44
45#'
46
47%description -l ja
48Riece は IRC (Internet Relay Chat) の世界でチャットを楽しむためのユーザインタ
49ーフェースです。Riece は「りーす」と読みます。
50
51Riece の主な特長は以下の通りです。
52 * 複数の IRC サーバに同時に接続可能
53 * アドオンにより機能の追加や取り外しが容易
54 * 他の elisp パッケージに依存しないため、インストールが簡単
55 * 設定が簡単で、前回起動時の設定を記録・復元する仕組みを提供
56 * 段階的な操作説明書が附属
57 * 最新の IRC のクライアントプロトコル (RFC2812) に準拠
58
59%prep
60%setup -q
61%patch0 -p1 -b .orig
62
63
64%build
65%configure
66
67%install
68[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
69[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
70
71mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
72mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
73mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
74mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
75
76
77#
78# install el files
79#
80
81cp -a lisp/* ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
82
83#
84#  build & install info
85#
86
87make DESTDIR=${RPM_BUILD_ROOT} install-info
88
89
90#
91# install  script( bytecompile el and install elc , remove )   
92#
93
94%_installemacsenscript %{origname} %{SOURCE1}
95
96%_removeemacsenscript  %{origname} %{SOURCE2}
97
98
99#
100# install info file
101#
102
103mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
104
105
106#
107# install site-start script
108#
109
110install %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
111
112
113## remove unpackaged files
114%__rm ${RPM_BUILD_ROOT}%{_infodir}/dir
115
116
117%pre
118if (grep -q "Riece: (liece)" /usr/share/info/dir) ; then
119  cp /usr/share/info/dir /usr/share/info/dir.rpmsave
120  grep -v "Riece: (liece)" /usr/share/info/dir.rpmsave > /usr/share/info/dir
121  rm -f /usr/share/info/dir.rpmsave
122fi
123
124%post
125#
126# bytecompile and install
127#
128
129if [ "$1" = 2 ]; then
130
131%_emacsenPackageRemove %{origname}
132
133fi
134
135
136%_addemacsenlist %{origname}
137
138%_emacsenPackageInstall %{origname}
139
140
141/sbin/install-info %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
142    --entry="* Riece: (riece-ja).  IRC Client On Emacsen" --section="Emacs" ||:
143
144%preun
145
146if [ "$1" = 0 ]; then
147
148%_emacsenPackageRemove %{origname}
149
150%_removeemacsenlist %{origname}
151
152/sbin/install-info --delete %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
153    --entry="* Riece: (riece-ja).  IRC Client On Emacsen" --section="Emacs" ||:
154
155fi
156
157
158%clean
159[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
160
161
162%files
163%defattr(-,root,root)
164%doc AUTHORS COPYING ChangeLog* INSTALL NEWS* README*
165
166%{_datadir}/emacs/site-lisp/%{origname}
167%{emacsen_pkgdir}/install/%{origname}
168%{emacsen_pkgdir}/remove/%{origname}
169%{_infodir}/%{origname}-*.info*
170 
171
172%changelog
173* Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-2
174- applied riece-7.0.0-check-make-local-hook.patch
175
176* Wed Nov 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.0-1
177- new upstream release
178
179* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.1.0-1
180- new upstream release
181
182* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-2
183- updated riece-install.sh
184  - *-init.el: changed from hard copy to symbolic link
185    on /etc/emacs-XX.YY/site-start.d
186
187* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-1
188- new upstream release
189
190* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.0-1
191- applied new versioning policy
192- spec in UTF-8
193
194* Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.0-0vl1
195- new upstream release
196
197* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl4
198- fixed %post script <BTS:VineLinux:177>
199
200* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl3
201- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
202- s/Copyright/License/
203
204* Sat Sep 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl2
205- change BuildArch to noarch
206
207* Fri Sep  9 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl1
208- initial build
209
Note: See TracBrowser for help on using the repository browser.