source: projects/specs/trunk/r/riece/riece-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define       origver       6.1.0
5%define       origname      riece
6
7Summary:      Riece is emacs based irc client
8Summary(ja):  Riece は Emacsen 上で動作する IRC のクライアント
9Name:         %{origname}
10Version:      %{origver}
11Release:      1%{?_dist_release}
12
13Source0:      http://dl.sv.gnu.org/releases/riece/%{name}-%{version}.tar.gz
14Source1:      %{name}-install.sh
15Source2:      %{name}-remove.sh
16Source3:      %{name}-init.el
17
18License:      GPL
19Group:        Applications/Editors/Emacs
20BuildRoot:    %{_tmppath}/%{name}-%{version}-root
21BuildArch:    noarch
22
23Requires(post): emacsen
24Requires(post): /sbin/install-info
25Requires(preun): emacsen
26Requires(preun): /sbin/install-info
27
28%prereq_ge emacsen-common
29%prereq_ge flim
30
31%description
32Riece is a user interface for IRC (Internet Relay Chat). You should spell it
33with the first letter capitalized and pronounce it as /ri:s/.
34
35The features of Riece are as follows:
36 * Several IRC servers may be used at the same time.
37 * Many features built upon the extension mechanism called add-on.
38   Currently 30 such add-ons are available.
39 * Installation is easy. Riece doesn't depend on other packages.
40 * Setup is easy. Automatically save/restore the configuration.
41 * Step-by-step instructions are included.
42 * Mostly compliant with the latest IRC client protocol (RFC2812).
43
44#'
45
46%description -l ja
47Riece は IRC (Internet Relay Chat) の世界でチャットを楽しむためのユーザインタ
48ーフェースです。Riece は「りーす」と読みます。
49
50Riece の主な特長は以下の通りです。
51 * 複数の IRC サーバに同時に接続可能
52 * アドオンにより機能の追加や取り外しが容易
53 * 他の elisp パッケージに依存しないため、インストールが簡単
54 * 設定が簡単で、前回起動時の設定を記録・復元する仕組みを提供
55 * 段階的な操作説明書が附属
56 * 最新の IRC のクライアントプロトコル (RFC2812) に準拠
57
58%prep
59%setup -q
60
61%build
62%configure
63
64%install
65[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
66[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
67
68mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
69mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
70mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
71mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
72
73
74#
75# install el files
76#
77
78cp -a lisp/* ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
79
80#
81#  build & install info
82#
83
84make DESTDIR=${RPM_BUILD_ROOT} install-info
85
86
87#
88# install  script( bytecompile el and install elc , remove )   
89#
90
91%_installemacsenscript %{origname} %{SOURCE1}
92
93%_removeemacsenscript  %{origname} %{SOURCE2}
94
95
96#
97# install info file
98#
99
100mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
101
102
103#
104# install site-start script
105#
106
107install %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
108
109
110## remove unpackaged files
111%__rm ${RPM_BUILD_ROOT}%{_infodir}/dir
112
113
114%pre
115if (grep -q "Riece: (liece)" /usr/share/info/dir) ; then
116  cp /usr/share/info/dir /usr/share/info/dir.rpmsave
117  grep -v "Riece: (liece)" /usr/share/info/dir.rpmsave > /usr/share/info/dir
118  rm -f /usr/share/info/dir.rpmsave
119fi
120
121%post
122#
123# bytecompile and install
124#
125
126if [ "$1" = 2 ]; then
127
128%_emacsenPackageRemove %{origname}
129
130fi
131
132
133%_addemacsenlist %{origname}
134
135%_emacsenPackageInstall %{origname}
136
137
138/sbin/install-info %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
139    --entry="* Riece: (riece-ja).  IRC Client On Emacsen" --section="Emacs" ||:
140
141%preun
142
143if [ "$1" = 0 ]; then
144
145%_emacsenPackageRemove %{origname}
146
147%_removeemacsenlist %{origname}
148
149/sbin/install-info --delete %{_infodir}/riece-ja.info.gz %{_infodir}/dir \
150    --entry="* Riece: (riece-ja).  IRC Client On Emacsen" --section="Emacs" ||:
151
152fi
153
154
155%clean
156[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
157
158
159%files
160%defattr(-,root,root)
161%doc AUTHORS COPYING ChangeLog* INSTALL NEWS* README*
162
163%{_datadir}/emacs/site-lisp/%{origname}
164%{emacsen_pkgdir}/install/%{origname}
165%{emacsen_pkgdir}/remove/%{origname}
166%{_infodir}/%{origname}-*.info*
167 
168
169%changelog
170* Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.1.0-1
171- new upstream release
172
173* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-2
174- updated riece-install.sh
175  - *-init.el: changed from hard copy to symbolic link
176    on /etc/emacs-XX.YY/site-start.d
177
178* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 5.0.0-1
179- new upstream release
180
181* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.0-1
182- applied new versioning policy
183- spec in UTF-8
184
185* Thu Sep 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1.0-0vl1
186- new upstream release
187
188* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl4
189- fixed %post script <BTS:VineLinux:177>
190
191* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-0vl3
192- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
193- s/Copyright/License/
194
195* Sat Sep 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl2
196- change BuildArch to noarch
197
198* Fri Sep  9 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl1
199- initial build
200
Note: See TracBrowser for help on using the repository browser.