source: projects/specs/trunk/r/rest/rest-vl.spec @ 5168

Revision 5168, 2.7 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define         package_version 0.7.12
2%define         package_release 1%{?_dist_release}
3
4Name:           rest
5Version:        %{package_version}
6Release:        %{package_release}
7Summary:        RESTful web api query library
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  glib2-devel
17BuildRequires:  gobject-introspection-devel
18BuildRequires:  libsoup-devel
19BuildRequires:  openssl-devel
20BuildRequires:  gtk-doc
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Takemikaduchi
25
26%description
27This library has been designed to make it easier to access web services that
28claim to be "RESTful". A reasonable definition of what this means can be found
29on Wikipedia [1]. However a reasonable description is that a RESTful service
30should have urls that represent remote objects which methods can then be
31called on.
32
33
34%package        devel
35Summary:        Development tools for rest
36Summary(ja):    rest の開発環境
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       pkgconfig
40Requires:       glib2-devel
41Requires:       libsoup-devel
42Requires:       libxml2-devel
43
44%description    devel
45Header files and libraries for building a extension library for the
46rest.
47
48
49%package        doc
50Summary:        Documentation for rest
51Summary(ja):    rest 用のドキュメント
52Group:          Documentation
53Requires:       %{name} = %{version}-%{release}
54BuildArch:      noarch
55
56
57%description    doc
58This package contains documentation for rest.
59
60
61%prep
62%setup -q
63
64%build
65%configure \
66        --enable-gtk-doc \
67        --disable-static \
68        --enable-introspection=yes \
69        --with-ca-certificates=%{_datadir}/ssl/certs
70
71make %{?_smp_mflags}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76make DESTDIR=$RPM_BUILD_ROOT install
77
78rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87%files
88%defattr(-,root,root,-)
89%doc ChangeLog AUTHORS COPYING NEWS README
90%{_libdir}/*.so.*
91%{_libdir}/girepository-1.0/*.typelib
92
93%files devel
94%defattr(-, root, root)
95%{_includedir}/%{name}-0.7
96%{_libdir}/*.so
97%{_libdir}/pkgconfig/*.pc
98%{_datadir}/gir-1.0/*.gir
99
100%files doc
101%defattr(-, root, root)
102%{_datadir}/gtk-doc/html/%{name}-0.7
103
104
105%changelog
106* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-1
107- new upstream release
108- add BuildRequires: openssl
109
110* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.11-1
111- new upstream release
112
113* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
114- initial build for Vine Linux
115
Note: See TracBrowser for help on using the repository browser.