source: projects/specs/trunk/r/rest/rest-vl.spec @ 4616

Revision 4616, 2.4 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define         package_version 0.7.10
2%define         package_release 1%{?_dist_release}
3
4Name:           rest
5Version:        %{package_version}
6Release:        %{package_release}
7Summary:        RESTful web api query library
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.bz2
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  glib2-devel
17BuildRequires:  gobject-introspection-devel
18BuildRequires:  libsoup-devel
19BuildRequires:  gtk-doc
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: Takemikaduchi
24
25%description
26This library has been designed to make it easier to access web services that
27claim to be "RESTful". A reasonable definition of what this means can be found
28on Wikipedia [1]. However a reasonable description is that a RESTful service
29should have urls that represent remote objects which methods can then be
30called on.
31
32
33%package        devel
34Summary:        Development tools for rest
35Summary(ja):    rest の開発環境
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38Requires:       pkgconfig
39Requires:       glib2-devel
40Requires:       libsoup-devel
41Requires:       libxml2-devel
42
43%description    devel
44Header files and libraries for building a extension library for the
45rest.
46
47
48%package        doc
49Summary:        Documentation for rest
50Summary(ja):    rest 用のドキュメント
51Group:          Documentation
52Requires:       %{name} = %{version}-%{release}
53BuildArch:      noarch
54
55
56%description    doc
57This package contains documentation for rest.
58
59
60%prep
61%setup -q
62
63%build
64%configure \
65        --enable-gtk-doc \
66        --disable-static \
67        --enable-introspection=yes
68
69make %{?_smp_mflags}
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74make DESTDIR=$RPM_BUILD_ROOT install
75
76rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%post -p /sbin/ldconfig
82
83%postun -p /sbin/ldconfig
84
85%files
86%defattr(-,root,root,-)
87%doc ChangeLog AUTHORS COPYING NEWS README
88%{_libdir}/*.so.*
89%{_libdir}/girepository-1.0/*.typelib
90
91%files devel
92%defattr(-, root, root)
93%{_includedir}/%{name}-0.7
94%{_libdir}/*.so
95%{_libdir}/pkgconfig/*.pc
96%{_datadir}/gir-1.0/*.gir
97
98%files doc
99%defattr(-, root, root)
100%{_datadir}/gtk-doc/html/%{name}-0.7
101
102
103%changelog
104* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
105- initial build for Vine Linux
106
Note: See TracBrowser for help on using the repository browser.