source: projects/specs/trunk/r/rest/rest-vl.spec @ 10025

Revision 10025, 4.1 KB checked in by Takemikaduchi, 8 years ago (diff)

python,python3,thunderbird,wine: new upstream release
mesa: create compat32-mesa-dri-drivers subpackage
others: create compat32 subpackage

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define         package_version 0.7.93
4%define         package_release 2%{?_dist_release}
5
6Name:           rest
7Version:        %{package_version}
8Release:        %{package_release}
9Summary:        RESTful web api query library
10
11Group:          System Environment/Libraries
12License:        LGPLv2+
13URL:            http://git.gnome.org/browse/librest
14Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.xz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  glib2-devel
19BuildRequires:  gobject-introspection-devel
20BuildRequires:  libsoup-devel
21BuildRequires:  ca-certificates
22BuildRequires:  gtk-doc
23
24Requires:       ca-certificates
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Takemikaduchi
29
30%description
31This library has been designed to make it easier to access web services that
32claim to be "RESTful". A reasonable definition of what this means can be found
33on Wikipedia [1]. However a reasonable description is that a RESTful service
34should have urls that represent remote objects which methods can then be
35called on.
36
37
38%package        devel
39Summary:        Development tools for rest
40Summary(ja):    rest の開発環境
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       pkgconfig
44Requires:       glib2-devel
45Requires:       libsoup-devel
46Requires:       libxml2-devel
47
48%description    devel
49Header files and libraries for building a extension library for the
50rest.
51
52
53%package        doc
54Summary:        Documentation for rest
55Summary(ja):    rest 用のドキュメント
56Group:          Documentation
57Requires:       %{name} = %{version}-%{release}
58BuildArch:      noarch
59
60
61%description    doc
62This package contains documentation for rest.
63
64
65# compat32
66%package -n compat32-%{name}
67Summary:        RESTful web api query library
68Group:          System Environment/Libraries
69
70%description -n compat32-%{name}
71This library has been designed to make it easier to access web services that
72claim to be "RESTful". A reasonable definition of what this means can be found
73on Wikipedia [1]. However a reasonable description is that a RESTful service
74should have urls that represent remote objects which methods can then be
75called on.
76
77
78%prep
79%setup -q
80
81%build
82%configure \
83        --enable-gtk-doc \
84        --disable-static \
85        --enable-introspection=yes
86
87make %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92make DESTDIR=$RPM_BUILD_ROOT install
93
94rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100
101%postun -p /sbin/ldconfig
102
103%post -n compat32-%{name} -p /sbin/ldconfig
104
105%postun -n compat32-%{name} -p /sbin/ldconfig
106
107%files
108%defattr(-,root,root,-)
109%doc ChangeLog AUTHORS COPYING NEWS README
110%{_libdir}/*.so.*
111%{_libdir}/girepository-1.0/*.typelib
112
113%files devel
114%defattr(-, root, root)
115%{_includedir}/%{name}-0.7
116%{_libdir}/*.so
117%{_libdir}/pkgconfig/*.pc
118%{_datadir}/gir-1.0/*.gir
119
120%files doc
121%defattr(-, root, root)
122%{_datadir}/gtk-doc/html/%{name}-0.7
123
124%if %{build_compat32}
125%files -n compat32-%{name}
126%defattr(-,root,root,-)
127%{_libdir}/*.so.*
128%endif
129
130%changelog
131* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-2
132- create compat32-rest subpakcage
133
134* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-1
135- new upstream release
136
137* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.92-1
138- new upstream release
139
140* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.91-1
141- new upstream release
142
143* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-2
144- rebuild with VineSeed environment
145
146* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-1
147- new upstream release
148- change BuildRequires: ca-certificates instead of openssl-devel
149
150* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-2
151- fix URL
152
153* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-1
154- new upstream release
155- add BuildRequires: openssl
156
157* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.11-1
158- new upstream release
159
160* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
161- initial build for Vine Linux
162
Note: See TracBrowser for help on using the repository browser.