source: projects/specs/trunk/r/rest/rest-vl.spec @ 11334

Revision 11334, 4.2 KB checked in by tomop, 6 years ago (diff)

rest-0.8.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4%define         package_version 0.8.1
5%define         package_release 1%{?_dist_release}
6
7Name:           rest
8Version:        %{package_version}
9Release:        %{package_release}
10Summary:        RESTful web api query library
11
12Group:          System Environment/Libraries
13License:        LGPLv2+
14URL:            http://git.gnome.org/browse/librest
15Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.7/%{name}-%{version}.tar.xz
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  glib2-devel
20BuildRequires:  gobject-introspection-devel
21BuildRequires:  libsoup-devel
22BuildRequires:  ca-certificates
23BuildRequires:  gtk-doc
24
25Requires:       ca-certificates
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31%description
32This library has been designed to make it easier to access web services that
33claim to be "RESTful". A reasonable definition of what this means can be found
34on Wikipedia [1]. However a reasonable description is that a RESTful service
35should have urls that represent remote objects which methods can then be
36called on.
37
38
39%package        devel
40Summary:        Development tools for rest
41Summary(ja):    rest の開発環境
42Group:          Development/Libraries
43Requires:       %{name} = %{version}-%{release}
44Requires:       pkgconfig
45Requires:       glib2-devel
46Requires:       libsoup-devel
47Requires:       libxml2-devel
48
49%description    devel
50Header files and libraries for building a extension library for the
51rest.
52
53
54%package        doc
55Summary:        Documentation for rest
56Summary(ja):    rest 用のドキュメント
57Group:          Documentation
58Requires:       %{name} = %{version}-%{release}
59BuildArch:      noarch
60
61
62%description    doc
63This package contains documentation for rest.
64
65
66# compat32
67%package -n compat32-%{name}
68Summary:        RESTful web api query library
69Group:          System Environment/Libraries
70
71%description -n compat32-%{name}
72This library has been designed to make it easier to access web services that
73claim to be "RESTful". A reasonable definition of what this means can be found
74on Wikipedia [1]. However a reasonable description is that a RESTful service
75should have urls that represent remote objects which methods can then be
76called on.
77
78
79%prep
80%setup -q
81
82%build
83%configure \
84        --enable-gtk-doc \
85        --disable-static \
86        --enable-introspection=yes
87
88make %{?_smp_mflags}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make DESTDIR=$RPM_BUILD_ROOT install
94
95rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p /sbin/ldconfig
103
104%post -n compat32-%{name} -p /sbin/ldconfig
105
106%postun -n compat32-%{name} -p /sbin/ldconfig
107
108%files
109%defattr(-,root,root,-)
110%doc ChangeLog AUTHORS COPYING README
111%{_libdir}/*.so.*
112%{_libdir}/girepository-1.0/*.typelib
113
114%files devel
115%defattr(-, root, root)
116%{_includedir}/%{name}-0.7
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/*.pc
119%{_datadir}/gir-1.0/*.gir
120
121%files doc
122%defattr(-, root, root)
123%{_datadir}/gtk-doc/html/%{name}-0.7
124
125%if %{build_compat32}
126%files -n compat32-%{name}
127%defattr(-,root,root,-)
128%{_libdir}/*.so.*
129%endif
130
131%changelog
132* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.1-1
133- new upstream release.
134
135* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-2
136- create compat32-rest subpakcage
137
138* Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.93-1
139- new upstream release
140
141* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.92-1
142- new upstream release
143
144* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.91-1
145- new upstream release
146
147* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-2
148- rebuild with VineSeed environment
149
150* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.90-1
151- new upstream release
152- change BuildRequires: ca-certificates instead of openssl-devel
153
154* Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-2
155- fix URL
156
157* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.12-1
158- new upstream release
159- add BuildRequires: openssl
160
161* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.11-1
162- new upstream release
163
164* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.10-1
165- initial build for Vine Linux
166
Note: See TracBrowser for help on using the repository browser.