source: projects/specs/trunk/r/rep-gtk/rep-gtk-vl.spec @ 521

Revision 521, 5.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: rep-gtk
2Version:     0.18
3Release:     1%{?_dist_release}
4Summary:     GTK+ binding for librep Lisp environment
5Summary(ja): librep Lisp 環境用 GTK+ バインディング
6Requires:    librep >= 0.13, gtk+ >= 1.2
7License:   GPL
8Group:       Development/Languages
9URL:         http://rep-gtk.sourceforge.net/
10Source:      http://download.sourceforge.net/rep-gtk/rep-gtk-%{version}.tar.gz
11Patch0:      rep-gtk-0.18-compat.patch
12Buildroot:   %{_tmppath}/%{name}-%{version}-root
13BuildPrereq: librep-devel libglade-devel gnome-libs-devel gdk-pixbuf-devel
14BuildRequires: db4-devel alsa-lib-devel
15
16
17%description
18This is a binding of GTK+ for the librep Lisp interpreter. It is based
19on Marius Vollmer's guile-gtk package (initially version 0.15, updated
20to 0.17), with a new glue-code generator.
21
22%description -l ja
23rep-gtk は librep Lisp インタプリタ向け GTK+ バインディングです.
24Marius Vollmer さんの guile-gtk パッケージ (当初 0.15 で,現在バージョンは
250.17) をベースとして,新しく glue-code ジェネレータを追加しています.
26
27
28%package libglade
29Summary:     librep binding for the libglade library for loading user interfaces.
30Summary(ja): librep 用 libglade バインディング
31Group:       Development/Languages
32Requires:    %{name} = %{version}, libglade
33
34
35%description libglade
36This is a binding of libglade for the librep Lisp interpreter. libglade
37allows applications to dynamically load XML descriptions of GTK+ widget
38hierarchies. These hierarchies may be created by the GLADE GUI builder.
39
40%description libglade -l ja
41rep-gtk-libglade は librep Lisp インタプリタ向け libglade バインディングです.
42libglade を使うと,アプリケーションから GTK+ ウィジェット階層を記述した
43XML を直接読みこむことが出来ます.その XML ファイルは GLADE GUI ビルダによって
44作成することが出来ます.
45
46
47%package gnome
48Summary:     GNOME binding for librep
49Summary(ja): librep 用 GNOME バインディング
50Group:       Development/Languages
51Requires:    %{name} = %{version}, gnome-libs, libglade
52
53
54%description gnome
55This is a binding of the various GNOME libraries for the librep Lisp
56interpreter. It include support for the basic GNOME functions, the
57GNOME user interface widgets, the GNOME Canvas architecture, and the
58GNOME version of libglade.
59
60%description gnome -l ja
61rep-gtk-gnome は librep Lisp インタプリタから様々な GNOME ライブラリに
62アクセスする為のバインディングです.基本的な GNOME の機能から,GNOME
63ユーザインタフェースウィジェット,GNOME Canvas アーキテクチャ,更には
64GNOME 版 libglade 迄様々な種類をサポートしています.
65
66
67%prep
68%setup
69%patch0 -p0 -b .compat
70
71%build
72LC_ALL=""
73LINGUAS=""
74LANG=""
75export LC_ALL LINGUAS LANG
76
77%configure --with-libglade --with-gnome
78make host_type=%{_target_platform}
79
80
81%install
82[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
83make install \
84    host_type=%{_target_platform} \
85    installdir=$RPM_BUILD_ROOT%{_libexecdir}/rep/%{_target_platform}
86
87## remove unuse files
88rm -f $RPM_BUILD_ROOT%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/*.la
89
90
91%clean
92[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
93
94
95%files
96%defattr(-,root,root)
97%doc README README.guile-gtk BUGS ChangeLog gtk.defs gdk.defs
98%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gtk.so
99%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/types.so
100#%{_libexecdir}/rep/%{_target_platform}/gui/gtk
101#%{_libexecdir}/rep/%{_target_platform}/gui/gtk.so
102#%{_libexecdir}/rep/%{_target_platform}/sgtk-types.so
103#%{_libexecdir}/rep/%{_target_platform}/gtk.so
104
105
106%files libglade
107%defattr(-,root,root)
108%doc libglade.defs examples/test-libglade examples/simple.glade
109%doc examples/rep-ui examples/rep-ui.glade
110%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/libglade.so
111#%{_libexecdir}/rep/%{_target_platform}/libglade.so*
112
113
114%files gnome
115%defattr(-,root,root)
116%doc gnome*.defs gdk-pixbuf.defs libglade.defs
117%doc examples/gnome-test examples/canvas-test
118%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gnome-canvas.so
119%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gnome-lib.so
120%{_libexecdir}/rep/%{_target_platform}/gui/gtk-2/gnome-ui.so
121#%{_libexecdir}/rep/%{_target_platform}/gui/gnome
122#%{_libexecdir}/rep/%{_target_platform}/gui/gnome.so
123#%{_libexecdir}/rep/%{_target_platform}/gnome*.so
124#%{_libexecdir}/rep/%{_target_platform}/libglade-gnome.so
125#%{_libexecdir}/rep/%{_target_platform}/gdk-pixbuf.so
126
127
128%changelog
129* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.18-1vl5
130- applied new versioning policy, spec in utf-8
131- new upstream release
132- added rep-gtk-0.18-compat.patch
133- removed *.la
134
135* Thu Nov 29 2007 Shu KONNO <owa@bg.wakwak.com> 0.15-1vl7
136- s/Copyright/License/
137
138* Sun Jul 17 2005 KANEKO Seiji <giragge@m2.pbc.ne.jp> 0.15-1vl6
139- rebuilt with db4-4.2.52 again (db4-devel)
140- add BuildRequires: db4-devel, alsa-lib-devel
141- commented Packager
142
143* Sat Nov  6 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.15-1vl5
144- rebuilt with db4-4.2.52
145
146* Mon Jan 20 2003 Satoshi MACHINO <machino@vinelinux.org> 0.15-1vl4
147- rebuild to remove old librep depandancy, it depended on gmp-2
148
149* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15-1vl3
150- rebuild to remove rpmlib dependancy
151
152* Sun May 20 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
153- 0.15-1vl2
154- rebuilt with librep = 0.13.6
155- added Japanese summary and description
156
157* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
158- 0.15-1vl1
159- rebuilt under rpm-3.0.6-0vl8
160
161* Tue Jun 13 2000 John Harper <john@dcs.warwick.ac.uk>
162- use better macros
163
164* Fri Sep 17 1999 John Harper <john@dcs.warwick.ac.uk>
165- specify installdir when installing
166
167* Tue Sep 14 1999 Aron Griffis <agriffis@bigfoot.com>
168- 0.4 spec file update: added buildroot
Note: See TracBrowser for help on using the repository browser.