source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        0.9.3
5Release:        1%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://digitaldump.wordpress.com/projects/rednotebook/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root 
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18BuildRequires:  desktop-file-utils
19
20Requires:       PyYAML
21Requires:       pygtk2
22Requires:       gnome-python-extras
23Requires:       hicolor-icon-theme
24
25%description
26RedNotebook is a desktop journal that makes it very easy for you
27to keep track of the stuff you do and the thoughts you have. This
28journal software helps you to write whole passages or just facts,
29and does so in style.
30
31%description-l ja
32RedNotebook はあなたの行動、及び考えているアイデアの推移の
33追跡を非常に簡単にするデスクトップ・ジャーナルです。
34このジャーナル・ソフトウェアは、あなたが全体の推移、
35あるいは事実の記載をスタイリッシュに行えるよう手助けします。
36
37%prep
38%setup -q
39
40
41%build
42python setup.py build
43
44
45%install
46rm -rf %{buildroot}
47python setup.py install --skip-build --root %{buildroot}
48
49
50%clean
51rm -rf %{buildroot}
52
53
54%post
55touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
56
57
58%postun
59if [ $1 -eq 0 ] ; then
60    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
61    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
62fi
63
64
65%posttrans
66gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
67
68
69%files
70%defattr(-,root,root,-)
71%doc AUTHORS CHANGELOG LICENSE README
72%{_bindir}/%{name}
73%{_datadir}/applications/%{name}.desktop
74%{_datadir}/pixmaps/%{name}.png
75%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
76%{python_sitelib}/%{name}/
77%{python_sitelib}/%{name}*.egg-info
78
79%changelog
80* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
81- new upstream release
82
83* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
84- rebuilt with python-2.6.4-3
85
86* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
87- initial build for VineSeed
88
89* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
90- Update to 0.8.6.1, fixes #523880
91
92* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
93- Fix libglade error with GTK 2.16.6 (#523880)
94
95* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
96- Updated to new upstream version 0.8.6
97
98* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
99- Updated to new upstream version 0.8.5 (fixes #518778)
100
101* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
102- Updated to new upstream version 0.8.4
103
104* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
105- Updated to new upstream version 0.8.3
106
107* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
108- Updated to new upstream version 0.8.2
109
110* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
111- Updated to new upstream version 0.8.1
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
113
114* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
115- Updated BR python
116- Icon cache update added
117- Updated to new upstream version 0.8.0
118
119* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
120- Updated to new upstream version 0.7.6
121
122* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
123- Removed the shebang stuff, upstream changed this
124- Updated to new upstream version 0.7.5
125
126* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
127- Moved the removing of the shebang to prep section
128- Updated to new upstream version 0.7.4
129
130* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
131- Updated to new upstream version 0.7.2
132
133* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
134- Updated to new upstream version 0.7.1
135
136* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
137- Updated to new upstream version 0.6.9
138
139* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
140- Updated to new upstream version 0.6.8
141
142* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
143- Updated to new upstream version 0.6.7
144
145* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
146- Updated to new upstream version 0.6.6
147
148* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
149- Updated to new upstream version 0.6.5
150
151* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
152- Added hicolor-icon-theme as a requirement
153- Added icons directory
154- Updated to new upstream version 0.6.2
155
156* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
157- Updated to new upstream version 0.6.1
158- Renamed docs, added License file
159
160* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
161- Updated to new upstream version 0.5.5
162
163* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
164- Updated to new upstream version 0.5.2
165
166* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
167- Initial package for Fedora
168
Note: See TracBrowser for help on using the repository browser.