source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 7144

Revision 7144, 7.3 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        1.6.2
5Release:        1%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://rednotebook.sourceforge.net/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13#Patch0:         fix_install_data.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16
17BuildRequires:  python-devel
18BuildRequires:  python-setuptools
19BuildRequires:  desktop-file-utils
20
21Requires:       PyYAML
22Requires:       pygtk2
23Requires:       gnome-python-extras
24Requires:       hicolor-icon-theme
25Requires:       pywebkitgtk
26Requires:       python-chardet
27
28%description
29RedNotebook is a desktop journal that makes it very easy for you
30to keep track of the stuff you do and the thoughts you have. This
31journal software helps you to write whole passages or just facts,
32and does so in style.
33
34%description-l ja
35RedNotebook はあなたの行動、及び考えているアイデアの推移の
36追跡を非常に簡単にするデスクトップ・ジャーナルです。
37このジャーナル・ソフトウェアは、あなたが全体の推移、
38あるいは事実の記載をスタイリッシュに行えるよう手助けします。
39
40%prep
41%setup -q
42#%patch0 -p1
43
44
45%build
46python setup.py build
47
48
49%install
50rm -rf %{buildroot}
51python setup.py install --skip-build --root %{buildroot}
52
53%find_lang %{name}
54
55%clean
56rm -rf %{buildroot}
57
58
59%post
60touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
61
62
63%postun
64if [ $1 -eq 0 ] ; then
65    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
66    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
67fi
68
69
70%posttrans
71gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
72
73
74%files -f %{name}.lang
75%defattr(-,root,root,-)
76%doc AUTHORS CHANGELOG LICENSE README
77%{_bindir}/%{name}
78%{_datadir}/applications/%{name}.desktop
79%{_datadir}/icons/hicolor/*/*/%{name}.*
80%{python_sitelib}/%{name}/
81%{python_sitelib}/%{name}*.egg-info
82
83%changelog
84* Fri Nov 23 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.2-1
85- new upstream release
86
87* Tue Nov 13 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.1-1
88- new upstream release
89
90* Thu Nov 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.0-1
91- new upstream release
92
93* Sat Jul 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
94- replaced source
95  - fixed install data (merged patch)
96
97* Fri Jul 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
98- new upstream release
99- added Patch0 to fix install data
100
101* Tue Jun 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.0-1
102- new upstream release
103
104* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
105- new upstream release
106
107* Sat Oct 08 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
108- new upstream release
109
110* Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.8-1
111- new upstream release
112- changed URL
113
114* Thu Jul 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.7-1
115- new upstream release
116
117* Fri May 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.6-1
118- new upstream release
119
120* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.5-1
121- new upstream release
122
123* Fri Apr 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.4-1
124- new upstream release
125
126* Tue Dec 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.2-1
127- new upstream release
128
129* Mon Aug 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.1-1
130- new upstream release
131
132* Wed Aug 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.0-1
133- new upstream release
134
135* Wed Jun 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
136- new upstream release
137
138* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.5-1
139- new upstream release
140- added Requires: pywebkitgtk, python-chardet
141
142* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.4-1
143- new upstream release
144
145* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
146- new upstream release
147
148* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
149- rebuilt with python-2.6.4-3
150
151* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
152- initial build for VineSeed
153
154* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
155- Update to 0.8.6.1, fixes #523880
156
157* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
158- Fix libglade error with GTK 2.16.6 (#523880)
159
160* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
161- Updated to new upstream version 0.8.6
162
163* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
164- Updated to new upstream version 0.8.5 (fixes #518778)
165
166* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
167- Updated to new upstream version 0.8.4
168
169* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
170- Updated to new upstream version 0.8.3
171
172* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
173- Updated to new upstream version 0.8.2
174
175* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
176- Updated to new upstream version 0.8.1
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
178
179* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
180- Updated BR python
181- Icon cache update added
182- Updated to new upstream version 0.8.0
183
184* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
185- Updated to new upstream version 0.7.6
186
187* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
188- Removed the shebang stuff, upstream changed this
189- Updated to new upstream version 0.7.5
190
191* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
192- Moved the removing of the shebang to prep section
193- Updated to new upstream version 0.7.4
194
195* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
196- Updated to new upstream version 0.7.2
197
198* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
199- Updated to new upstream version 0.7.1
200
201* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
202- Updated to new upstream version 0.6.9
203
204* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
205- Updated to new upstream version 0.6.8
206
207* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
208- Updated to new upstream version 0.6.7
209
210* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
211- Updated to new upstream version 0.6.6
212
213* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
214- Updated to new upstream version 0.6.5
215
216* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
217- Added hicolor-icon-theme as a requirement
218- Added icons directory
219- Updated to new upstream version 0.6.2
220
221* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
222- Updated to new upstream version 0.6.1
223- Renamed docs, added License file
224
225* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
226- Updated to new upstream version 0.5.5
227
228* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
229- Updated to new upstream version 0.5.2
230
231* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
232- Initial package for Fedora
233
Note: See TracBrowser for help on using the repository browser.