source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 4624

Revision 4624, 6.4 KB checked in by kudoh, 13 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        1.1.8
5Release:        1%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://rednotebook.sourceforge.net/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18BuildRequires:  desktop-file-utils
19
20Requires:       PyYAML
21Requires:       pygtk2
22Requires:       gnome-python-extras
23Requires:       hicolor-icon-theme
24Requires:       pywebkitgtk
25Requires:       python-chardet
26
27%description
28RedNotebook is a desktop journal that makes it very easy for you
29to keep track of the stuff you do and the thoughts you have. This
30journal software helps you to write whole passages or just facts,
31and does so in style.
32
33%description-l ja
34RedNotebook はあなたの行動、及び考えているアイデアの推移の
35追跡を非常に簡単にするデスクトップ・ジャーナルです。
36このジャーナル・ソフトウェアは、あなたが全体の推移、
37あるいは事実の記載をスタイリッシュに行えるよう手助けします。
38
39%prep
40%setup -q
41
42
43%build
44python setup.py build
45
46
47%install
48rm -rf %{buildroot}
49python setup.py install --skip-build --root %{buildroot}
50
51
52%clean
53rm -rf %{buildroot}
54
55
56%post
57touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
58
59
60%postun
61if [ $1 -eq 0 ] ; then
62    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
63    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
64fi
65
66
67%posttrans
68gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
69
70
71%files
72%defattr(-,root,root,-)
73%doc AUTHORS CHANGELOG LICENSE README
74%{_bindir}/%{name}
75%{_datadir}/applications/%{name}.desktop
76%{_datadir}/pixmaps/%{name}.png
77%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
78%{python_sitelib}/%{name}/
79%{python_sitelib}/%{name}*.egg-info
80
81%changelog
82* Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.8-1
83- new upstream release
84- changed URL
85
86* Thu Jul 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.7-1
87- new upstream release
88
89* Fri May 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.6-1
90- new upstream release
91
92* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.5-1
93- new upstream release
94
95* Fri Apr 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.4-1
96- new upstream release
97
98* Tue Dec 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.2-1
99- new upstream release
100
101* Mon Aug 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.1-1
102- new upstream release
103
104* Wed Aug 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.0-1
105- new upstream release
106
107* Wed Jun 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
108- new upstream release
109
110* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.5-1
111- new upstream release
112- added Requires: pywebkitgtk, python-chardet
113
114* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.4-1
115- new upstream release
116
117* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
118- new upstream release
119
120* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
121- rebuilt with python-2.6.4-3
122
123* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
124- initial build for VineSeed
125
126* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
127- Update to 0.8.6.1, fixes #523880
128
129* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
130- Fix libglade error with GTK 2.16.6 (#523880)
131
132* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
133- Updated to new upstream version 0.8.6
134
135* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
136- Updated to new upstream version 0.8.5 (fixes #518778)
137
138* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
139- Updated to new upstream version 0.8.4
140
141* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
142- Updated to new upstream version 0.8.3
143
144* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
145- Updated to new upstream version 0.8.2
146
147* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
148- Updated to new upstream version 0.8.1
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
150
151* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
152- Updated BR python
153- Icon cache update added
154- Updated to new upstream version 0.8.0
155
156* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
157- Updated to new upstream version 0.7.6
158
159* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
160- Removed the shebang stuff, upstream changed this
161- Updated to new upstream version 0.7.5
162
163* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
164- Moved the removing of the shebang to prep section
165- Updated to new upstream version 0.7.4
166
167* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
168- Updated to new upstream version 0.7.2
169
170* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
171- Updated to new upstream version 0.7.1
172
173* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
174- Updated to new upstream version 0.6.9
175
176* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
177- Updated to new upstream version 0.6.8
178
179* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
180- Updated to new upstream version 0.6.7
181
182* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
183- Updated to new upstream version 0.6.6
184
185* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
186- Updated to new upstream version 0.6.5
187
188* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
189- Added hicolor-icon-theme as a requirement
190- Added icons directory
191- Updated to new upstream version 0.6.2
192
193* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
194- Updated to new upstream version 0.6.1
195- Renamed docs, added License file
196
197* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
198- Updated to new upstream version 0.5.5
199
200* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
201- Updated to new upstream version 0.5.2
202
203* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
204- Initial package for Fedora
205
Note: See TracBrowser for help on using the repository browser.