source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 3865

Revision 3865, 6.3 KB checked in by kudoh, 13 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        1.1.6
5Release:        1%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://digitaldump.wordpress.com/projects/rednotebook/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18BuildRequires:  desktop-file-utils
19
20Requires:       PyYAML
21Requires:       pygtk2
22Requires:       gnome-python-extras
23Requires:       hicolor-icon-theme
24Requires:       pywebkitgtk
25Requires:       python-chardet
26
27%description
28RedNotebook is a desktop journal that makes it very easy for you
29to keep track of the stuff you do and the thoughts you have. This
30journal software helps you to write whole passages or just facts,
31and does so in style.
32
33%description-l ja
34RedNotebook はあなたの行動、及び考えているアイデアの推移の
35追跡を非常に簡単にするデスクトップ・ジャーナルです。
36このジャーナル・ソフトウェアは、あなたが全体の推移、
37あるいは事実の記載をスタイリッシュに行えるよう手助けします。
38
39%prep
40%setup -q
41
42
43%build
44python setup.py build
45
46
47%install
48rm -rf %{buildroot}
49python setup.py install --skip-build --root %{buildroot}
50
51
52%clean
53rm -rf %{buildroot}
54
55
56%post
57touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
58
59
60%postun
61if [ $1 -eq 0 ] ; then
62    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
63    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
64fi
65
66
67%posttrans
68gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
69
70
71%files
72%defattr(-,root,root,-)
73%doc AUTHORS CHANGELOG LICENSE README
74%{_bindir}/%{name}
75%{_datadir}/applications/%{name}.desktop
76%{_datadir}/pixmaps/%{name}.png
77%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
78%{python_sitelib}/%{name}/
79%{python_sitelib}/%{name}*.egg-info
80
81%changelog
82* Fri May 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.6-1
83- new upstream release
84
85* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.5-1
86- new upstream release
87
88* Fri Apr 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.4-1
89- new upstream release
90
91* Tue Dec 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.2-1
92- new upstream release
93
94* Mon Aug 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.1-1
95- new upstream release
96
97* Wed Aug 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.0-1
98- new upstream release
99
100* Wed Jun 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
101- new upstream release
102
103* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.5-1
104- new upstream release
105- added Requires: pywebkitgtk, python-chardet
106
107* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.4-1
108- new upstream release
109
110* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
111- new upstream release
112
113* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
114- rebuilt with python-2.6.4-3
115
116* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
117- initial build for VineSeed
118
119* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
120- Update to 0.8.6.1, fixes #523880
121
122* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
123- Fix libglade error with GTK 2.16.6 (#523880)
124
125* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
126- Updated to new upstream version 0.8.6
127
128* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
129- Updated to new upstream version 0.8.5 (fixes #518778)
130
131* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
132- Updated to new upstream version 0.8.4
133
134* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
135- Updated to new upstream version 0.8.3
136
137* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
138- Updated to new upstream version 0.8.2
139
140* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
141- Updated to new upstream version 0.8.1
142- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
143
144* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
145- Updated BR python
146- Icon cache update added
147- Updated to new upstream version 0.8.0
148
149* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
150- Updated to new upstream version 0.7.6
151
152* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
153- Removed the shebang stuff, upstream changed this
154- Updated to new upstream version 0.7.5
155
156* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
157- Moved the removing of the shebang to prep section
158- Updated to new upstream version 0.7.4
159
160* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
161- Updated to new upstream version 0.7.2
162
163* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
164- Updated to new upstream version 0.7.1
165
166* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
167- Updated to new upstream version 0.6.9
168
169* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
170- Updated to new upstream version 0.6.8
171
172* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
173- Updated to new upstream version 0.6.7
174
175* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
176- Updated to new upstream version 0.6.6
177
178* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
179- Updated to new upstream version 0.6.5
180
181* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
182- Added hicolor-icon-theme as a requirement
183- Added icons directory
184- Updated to new upstream version 0.6.2
185
186* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
187- Updated to new upstream version 0.6.1
188- Renamed docs, added License file
189
190* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
191- Updated to new upstream version 0.5.5
192
193* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
194- Updated to new upstream version 0.5.2
195
196* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
197- Initial package for Fedora
198
Note: See TracBrowser for help on using the repository browser.