source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 5518

Revision 5518, 6.6 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        1.3.0
5Release:        1%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://rednotebook.sourceforge.net/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18BuildRequires:  desktop-file-utils
19
20Requires:       PyYAML
21Requires:       pygtk2
22Requires:       gnome-python-extras
23Requires:       hicolor-icon-theme
24Requires:       pywebkitgtk
25Requires:       python-chardet
26
27%description
28RedNotebook is a desktop journal that makes it very easy for you
29to keep track of the stuff you do and the thoughts you have. This
30journal software helps you to write whole passages or just facts,
31and does so in style.
32
33%description-l ja
34RedNotebook はあなたの行動、及び考えているアイデアの推移の
35追跡を非常に簡単にするデスクトップ・ジャーナルです。
36このジャーナル・ソフトウェアは、あなたが全体の推移、
37あるいは事実の記載をスタイリッシュに行えるよう手助けします。
38
39%prep
40%setup -q
41
42
43%build
44python setup.py build
45
46
47%install
48rm -rf %{buildroot}
49python setup.py install --skip-build --root %{buildroot}
50
51
52%clean
53rm -rf %{buildroot}
54
55
56%post
57touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
58
59
60%postun
61if [ $1 -eq 0 ] ; then
62    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
63    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
64fi
65
66
67%posttrans
68gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
69
70
71%files
72%defattr(-,root,root,-)
73%doc AUTHORS CHANGELOG LICENSE README
74%{_bindir}/%{name}
75%{_datadir}/applications/%{name}.desktop
76%{_datadir}/pixmaps/%{name}.png
77%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
78%{python_sitelib}/%{name}/
79%{python_sitelib}/%{name}*.egg-info
80
81%changelog
82* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
83- new upstream release
84
85* Sat Oct 08 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
86- new upstream release
87
88* Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.8-1
89- new upstream release
90- changed URL
91
92* Thu Jul 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.7-1
93- new upstream release
94
95* Fri May 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.6-1
96- new upstream release
97
98* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.5-1
99- new upstream release
100
101* Fri Apr 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.4-1
102- new upstream release
103
104* Tue Dec 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.2-1
105- new upstream release
106
107* Mon Aug 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.1-1
108- new upstream release
109
110* Wed Aug 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.0-1
111- new upstream release
112
113* Wed Jun 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
114- new upstream release
115
116* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.5-1
117- new upstream release
118- added Requires: pywebkitgtk, python-chardet
119
120* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.4-1
121- new upstream release
122
123* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
124- new upstream release
125
126* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
127- rebuilt with python-2.6.4-3
128
129* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
130- initial build for VineSeed
131
132* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
133- Update to 0.8.6.1, fixes #523880
134
135* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
136- Fix libglade error with GTK 2.16.6 (#523880)
137
138* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
139- Updated to new upstream version 0.8.6
140
141* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
142- Updated to new upstream version 0.8.5 (fixes #518778)
143
144* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
145- Updated to new upstream version 0.8.4
146
147* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
148- Updated to new upstream version 0.8.3
149
150* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
151- Updated to new upstream version 0.8.2
152
153* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
154- Updated to new upstream version 0.8.1
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
156
157* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
158- Updated BR python
159- Icon cache update added
160- Updated to new upstream version 0.8.0
161
162* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
163- Updated to new upstream version 0.7.6
164
165* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
166- Removed the shebang stuff, upstream changed this
167- Updated to new upstream version 0.7.5
168
169* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
170- Moved the removing of the shebang to prep section
171- Updated to new upstream version 0.7.4
172
173* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
174- Updated to new upstream version 0.7.2
175
176* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
177- Updated to new upstream version 0.7.1
178
179* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
180- Updated to new upstream version 0.6.9
181
182* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
183- Updated to new upstream version 0.6.8
184
185* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
186- Updated to new upstream version 0.6.7
187
188* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
189- Updated to new upstream version 0.6.6
190
191* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
192- Updated to new upstream version 0.6.5
193
194* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
195- Added hicolor-icon-theme as a requirement
196- Added icons directory
197- Updated to new upstream version 0.6.2
198
199* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
200- Updated to new upstream version 0.6.1
201- Renamed docs, added License file
202
203* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
204- Updated to new upstream version 0.5.5
205
206* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
207- Updated to new upstream version 0.5.2
208
209* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
210- Initial package for Fedora
211
Note: See TracBrowser for help on using the repository browser.