source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 999

Revision 999, 5.7 KB checked in by kudoh, 14 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        0.9.5
5Release:        1%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://digitaldump.wordpress.com/projects/rednotebook/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root 
14BuildArch:      noarch
15
16BuildRequires:  python-devel
17BuildRequires:  python-setuptools
18BuildRequires:  desktop-file-utils
19
20Requires:       PyYAML
21Requires:       pygtk2
22Requires:       gnome-python-extras
23Requires:       hicolor-icon-theme
24Requires:       pywebkitgtk
25Requires:       python-chardet
26
27%description
28RedNotebook is a desktop journal that makes it very easy for you
29to keep track of the stuff you do and the thoughts you have. This
30journal software helps you to write whole passages or just facts,
31and does so in style.
32
33%description-l ja
34RedNotebook はあなたの行動、及び考えているアイデアの推移の
35追跡を非常に簡単にするデスクトップ・ジャーナルです。
36このジャーナル・ソフトウェアは、あなたが全体の推移、
37あるいは事実の記載をスタイリッシュに行えるよう手助けします。
38
39%prep
40%setup -q
41
42
43%build
44python setup.py build
45
46
47%install
48rm -rf %{buildroot}
49python setup.py install --skip-build --root %{buildroot}
50
51
52%clean
53rm -rf %{buildroot}
54
55
56%post
57touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
58
59
60%postun
61if [ $1 -eq 0 ] ; then
62    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
63    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
64fi
65
66
67%posttrans
68gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
69
70
71%files
72%defattr(-,root,root,-)
73%doc AUTHORS CHANGELOG LICENSE README
74%{_bindir}/%{name}
75%{_datadir}/applications/%{name}.desktop
76%{_datadir}/pixmaps/%{name}.png
77%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
78%{python_sitelib}/%{name}/
79%{python_sitelib}/%{name}*.egg-info
80
81%changelog
82* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.5-1
83- new upstream release
84- added Requires: pywebkitgtk, python-chardet
85
86* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.4-1
87- new upstream release
88
89* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
90- new upstream release
91
92* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
93- rebuilt with python-2.6.4-3
94
95* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
96- initial build for VineSeed
97
98* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
99- Update to 0.8.6.1, fixes #523880
100
101* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
102- Fix libglade error with GTK 2.16.6 (#523880)
103
104* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
105- Updated to new upstream version 0.8.6
106
107* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
108- Updated to new upstream version 0.8.5 (fixes #518778)
109
110* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
111- Updated to new upstream version 0.8.4
112
113* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
114- Updated to new upstream version 0.8.3
115
116* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
117- Updated to new upstream version 0.8.2
118
119* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
120- Updated to new upstream version 0.8.1
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
122
123* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
124- Updated BR python
125- Icon cache update added
126- Updated to new upstream version 0.8.0
127
128* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
129- Updated to new upstream version 0.7.6
130
131* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
132- Removed the shebang stuff, upstream changed this
133- Updated to new upstream version 0.7.5
134
135* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
136- Moved the removing of the shebang to prep section
137- Updated to new upstream version 0.7.4
138
139* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
140- Updated to new upstream version 0.7.2
141
142* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
143- Updated to new upstream version 0.7.1
144
145* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
146- Updated to new upstream version 0.6.9
147
148* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
149- Updated to new upstream version 0.6.8
150
151* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
152- Updated to new upstream version 0.6.7
153
154* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
155- Updated to new upstream version 0.6.6
156
157* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
158- Updated to new upstream version 0.6.5
159
160* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
161- Added hicolor-icon-theme as a requirement
162- Added icons directory
163- Updated to new upstream version 0.6.2
164
165* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
166- Updated to new upstream version 0.6.1
167- Renamed docs, added License file
168
169* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
170- Updated to new upstream version 0.5.5
171
172* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
173- Updated to new upstream version 0.5.2
174
175* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
176- Initial package for Fedora
177
Note: See TracBrowser for help on using the repository browser.