source: projects/specs/trunk/r/redis/redis-vl.spec @ 7545

Revision 7545, 5.9 KB checked in by daisuke, 11 years ago (diff)

redis: update to 2.6.10

Line 
1# Check for status of man pages
2# http://code.google.com/p/redis/issues/detail?id=202
3
4%ifarch %{ix86} x86_64 ppc
5# available only on selected architectures
6%global with_perftools 1
7%endif
8
9Name:             redis
10Version:          2.6.10
11Release:          1%{?_dist_release}
12Summary:          A persistent in-memory key-value database
13Summary(ja):      永続化可能なキー・バリュー型インメモリデータベース
14
15Group:            Applications/Databases
16License:          BSD
17URL:              http://redis.io
18Source0:          http://redis.googlecode.com/files/%{name}-%{version}.tar.gz
19Source1:          %{name}.logrotate
20Source2:          %{name}.init
21Patch0:           %{name}-2.6.10-vine.patch
22
23BuildRoot:        %{_tmppath}/%{name}-%{version}-root
24%if %{?with_perftools}
25BuildRequires:    gperftools-devel
26%endif
27
28Requires:         logrotate
29Requires(post):   chkconfig
30Requires(postun): initscripts
31Requires(pre):    shadow-utils
32Requires(preun):  chkconfig
33Requires(preun):  initscripts
34
35Distribution: Vine Linux
36Vendor: Project Vine
37Packager: daisuke
38
39
40%description
41Redis is an advanced key-value store. It is similar to memcached but the data
42set is not volatile, and values can be strings, exactly like in memcached, but
43also lists, sets, and ordered sets. All this data types can be manipulated with
44atomic operations to push/pop elements, add/remove elements, perform server side
45union, intersection, difference between sets, and so forth. Redis supports
46different kind of sorting abilities.
47
48
49%prep
50%setup -q
51%patch0 -p1 -b .vine
52
53%build
54make %{?_smp_mflags} \
55  DEBUG="" \
56  CFLAGS='%{optflags}' \
57%if %{?with_perftools}
58  USE_TCMALLOC=yes \
59%endif
60  all
61
62%check
63# make test
64
65%install
66make install PREFIX=%{buildroot}%{_prefix}
67# Install misc other
68install -p -D -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
69install -p -D -m 755 %{SOURCE2} %{buildroot}%{_initrddir}/%{name}
70install -p -D -m 644 %{name}.conf %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
71install -d -m 755 %{buildroot}%{_localstatedir}/lib/%{name}
72install -d -m 755 %{buildroot}%{_localstatedir}/log/%{name}
73install -d -m 755 %{buildroot}%{_localstatedir}/run/%{name}
74
75# Fix non-standard-executable-perm error
76chmod 755 %{buildroot}%{_bindir}/%{name}-*
77
78# Ensure redis-server location doesn't change
79mkdir -p %{buildroot}%{_sbindir}
80mv %{buildroot}%{_bindir}/%{name}-server %{buildroot}%{_sbindir}/%{name}-server
81
82%post
83/sbin/chkconfig --add redis
84
85%pre
86getent group redis &> /dev/null || groupadd -r redis &> /dev/null
87getent passwd redis &> /dev/null || \
88useradd -r -g redis -d %{_localstatedir}/lib/%{name} -s /sbin/nologin \
89-c 'Redis Server' redis &> /dev/null
90exit 0
91
92%preun
93if [ $1 = 0 ]; then
94  /sbin/service redis stop &> /dev/null
95  /sbin/chkconfig --del redis &> /dev/null
96fi
97
98%files
99%defattr(-,root,root,-)
100%doc 00-RELEASENOTES BUGS CONTRIBUTING COPYING README
101%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
102%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
103%dir %attr(0755, redis, redis) %{_localstatedir}/lib/%{name}
104%dir %attr(0755, redis, redis) %{_localstatedir}/log/%{name}
105%dir %attr(0755, redis, redis) %{_localstatedir}/run/%{name}
106%{_bindir}/%{name}-*
107%{_sbindir}/%{name}-*
108%{_initrddir}/%{name}
109#%{_unitdir}/%{name}.service
110
111%changelog
112* Mon Mar 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.10-1
113- update to 2.6.10
114
115* Sat Oct 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.15-1
116- initial build for Vine Linux
117
118* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.15-3
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
120
121* Sun Jul 08 2012 Silas Sewell <silas@sewell.org> - 2.4.15-2
122- Remove TODO from docs
123
124* Sun Jul 08 2012 Silas Sewell <silas@sewell.org> - 2.4.15-1
125- Update to redis 2.4.15
126
127* Sat May 19 2012 Silas Sewell <silas@sewell.org> - 2.4.13-1
128- Update to redis 2.4.13
129
130* Sat Mar 31 2012 Silas Sewell <silas@sewell.org> - 2.4.10-1
131- Update to redis 2.4.10
132
133* Fri Feb 24 2012 Silas Sewell <silas@sewell.org> - 2.4.8-1
134- Update to redis 2.4.8
135
136* Sat Feb 04 2012 Silas Sewell <silas@sewell.org> - 2.4.7-1
137- Update to redis 2.4.7
138
139* Wed Feb 01 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-4
140- Fixed a typo in the spec
141
142* Tue Jan 31 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-3
143- Fix .service file, to match config (Type=simple).
144
145* Tue Jan 31 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-2
146- Fix .service file, credits go to Timon.
147
148* Thu Jan 12 2012 Fabian Deutsch <fabiand@fedoraproject.org> - 2.4.6-1
149- Update to 2.4.6
150- systemd unit file added
151- Compiler flags changed to compile 2.4.6
152- Remove doc/ and Changelog
153
154* Sun Jul 24 2011 Silas Sewell <silas@sewell.org> - 2.2.12-1
155- Update to redis 2.2.12
156
157* Fri May 06 2011 Dan Horák <dan[at]danny.cz> - 2.2.5-2
158- google-perftools exists only on selected architectures
159
160* Sat Apr 23 2011 Silas Sewell <silas@sewell.ch> - 2.2.5-1
161- Update to redis 2.2.5
162
163* Sat Mar 26 2011 Silas Sewell <silas@sewell.ch> - 2.2.2-1
164- Update to redis 2.2.2
165
166* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.4-2
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
168
169* Sun Dec 19 2010 Silas Sewell <silas@sewell.ch> - 2.0.4-1
170- Update to redis 2.0.4
171
172* Tue Oct 19 2010 Silas Sewell <silas@sewell.ch> - 2.0.3-1
173- Update to redis 2.0.3
174
175* Fri Oct 08 2010 Silas Sewell <silas@sewell.ch> - 2.0.2-1
176- Update to redis 2.0.2
177- Disable checks section for el5
178
179* Sat Sep 11 2010 Silas Sewell <silas@sewell.ch> - 2.0.1-1
180- Update to redis 2.0.1
181
182* Sat Sep 04 2010 Silas Sewell <silas@sewell.ch> - 2.0.0-1
183- Update to redis 2.0.0
184
185* Thu Sep 02 2010 Silas Sewell <silas@sewell.ch> - 1.2.6-3
186- Add Fedora build flags
187- Send all scriplet output to /dev/null
188- Remove debugging flags
189- Add redis.conf check to init script
190
191* Mon Aug 16 2010 Silas Sewell <silas@sewell.ch> - 1.2.6-2
192- Don't compress man pages
193- Use patch to fix redis.conf
194
195* Tue Jul 06 2010 Silas Sewell <silas@sewell.ch> - 1.2.6-1
196- Initial package
Note: See TracBrowser for help on using the repository browser.