source: projects/specs/trunk/r/readline6/readline6-vl.spec @ 12131

Revision 12131, 12.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1Summary: A library for editing typed in command lines.
2Summary(ja): Readline ライブラリ
3
4Name: readline6
5Version: 6.3
6Release: 2%{?_dist_release}
7License: GPLv3+
8Group: System Environment/Libraries
9URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
10Source: ftp://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
11
12# upstream patches
13Patch1: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-001
14Patch2: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-002
15Patch3: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-003
16Patch4: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-004
17Patch5: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-005
18Patch6: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-006
19Patch7: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-007
20Patch8: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-008
21
22# add workaround for problem in gdb
23# in new version of readline needs to be deleted
24# bz701131
25Patch9: readline-6.2-gdb.patch
26# fix file permissions, remove RPATH, use CFLAGS
27Patch10: readline-6.2-shlib.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
30BuildRequires: sed
31BuildRequires: ncurses-devel
32Requires(post): /sbin/install-info, /sbin/ldconfig
33Requires(preun): /sbin/install-info
34Requires(postun): /sbin/ldconfig
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
40
41%description
42The Readline library provides a set of functions that allow users to
43edit command lines. Both Emacs and vi editing modes are available. The
44Readline library includes additional functions for maintaining a list
45of previously-entered command lines for recalling or editing those
46lines, and for performing csh-like history expansion on previous
47commands.
48
49%description -l ja
50Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
51Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
52これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
53
54%package devel
55Summary: Files needed to develop programs which use the readline library.
56Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
57Group: Development/Libraries
58Requires: readline = %{version}
59Requires: ncurses-devel
60
61%description devel
62The Readline library provides a set of functions that allow users to
63edit typed command lines. If you want to develop programs that will
64use the readline library, you need to have the readline-devel package
65installed. You also need to have the readline package installed.
66
67
68%package -n compat32-%{name}
69Summary: A library for editing typed in command lines.
70Summary(ja): Readline ライブラリ
71Group: System Environment/Libraries
72Requires: %{name} = %{version}-%{release}
73
74%description -n compat32-%{name}
75The Readline library provides a set of functions that allow users to
76edit command lines. Both Emacs and vi editing modes are available. The
77Readline library includes additional functions for maintaining a list
78of previously-entered command lines for recalling or editing those
79lines, and for performing csh-like history expansion on previous
80commands.
81
82%description -n compat32-%{name} -l ja
83Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
84Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
85これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
86
87%package -n compat32-%{name}-devel
88Summary: Files needed to develop programs which use the readline library.
89Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: %{name}-devel = %{version}-%{release}
93Requires: compat32-ncurses-devel
94
95%description -n compat32-%{name}-devel
96The Readline library provides a set of functions that allow users to
97edit typed command lines. If you want to develop programs that will
98use the readline library, you need to have the readline-devel package
99installed. You also need to have the readline package installed.
100
101%prep
102%setup -q -n readline-%{version}
103
104# upstream patches
105%patch1 -p0 -b .001
106%patch2 -p0 -b .002
107%patch3 -p0 -b .003
108%patch4 -p0 -b .004
109%patch5 -p0 -b .005
110%patch6 -p0 -b .006
111%patch7 -p0 -b .007
112%patch8 -p0 -b .008
113
114%patch9 -p1 -b .gdb
115%patch10 -p1 -b .shlib
116
117%build
118export CPPFLAGS="-I%{_includedir}/ncurses"
119%configure
120make %{?_smp_mflags}
121
122
123%install
124[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
125mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
126
127make DESTDIR=$RPM_BUILD_ROOT install
128
129mkdir $RPM_BUILD_ROOT/%{_lib}
130mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
131for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
132    ln -sf $(echo %{_libdir} | \
133     sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
134done
135
136rm -rf $RPM_BUILD_ROOT%{_datadir}
137rm -rf $RPM_BUILD_ROOT%{_includedir}
138rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,so}
139
140
141%clean
142[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
143
144%post
145/sbin/ldconfig
146%if 0
147/sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
148/sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
149:
150%endif
151
152%postun -p /sbin/ldconfig
153
154%post -n compat32-%{name} -p /sbin/ldconfig
155
156%postun -n compat32-%{name} -p /sbin/ldconfig
157
158%if 0
159%preun
160if [ $1 = 0 ]; then
161   /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
162   /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
163fi
164:
165
166%post devel
167/sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
168:
169
170%preun devel
171if [ $1 = 0 ]; then
172   /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
173fi
174:
175%endif
176
177%files
178%defattr(-,root,root)
179%license COPYING
180%doc CHANGES NEWS README USAGE
181/%{_lib}/libreadline*.so.*
182%{_libdir}/libhistory*.so.*
183
184%if 0
185%files devel
186%defattr(-,root,root)
187%doc examples/*.c examples/*.h examples/rlfe
188%{_includedir}/readline
189%{_libdir}/lib*.a
190%{_libdir}/lib*.so
191%{_infodir}/readline.info*
192%{_mandir}/man*/*
193%endif
194
195%if %{build_compat32}
196%files -n compat32-%{name}
197%defattr(-,root,root)
198/%{_lib}/libreadline*.so.*
199%{_libdir}/libhistory*.so.*
200
201%if 0
202%files -n compat32-%{name}-devel
203%defattr(-,root,root)
204%{_libdir}/lib*.a
205%{_libdir}/lib*.so
206%endif
207%endif
208
209%changelog
210* Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.3-2
211- changed %%name for compatibility.
212
213* Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
214- new upstream release
215- update upstream patches (patch1-8)
216
217* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
218- rebuild with VineSeed environment
219
220* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
221- add upstream patches 13,14 (Patch13,14)
222
223* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
224- rebuilt with new toolchain
225- add Requires(post,pre): /sbin/ldconfig
226
227* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
228- build with ncurses-devel
229- spec in utf8
230- move libncurses.so.* to %%_lib from %%_libdir
231
232* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
233- added upstream patches (patch8-12)
234
235* Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
236- new upstream release
237- update upstream patches (patch1-7)
238
239* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
240- new upstream release
241- update upstream patches (patch1-4)
242- add doc/*.{html,pdf} instead of doc/
243
244* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
245- s/Copyright/License/
246- add URL
247- update source URL
248- add PreReq: ldconfig
249- move outdated.patch (patch1) to patch10
250- add upstream patches (patch1-5)
251- add no_rpath.patch (patch11)
252
253* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
254- added compat32- packages for x86_64 architecture support
255- fixed %files section (TODO* has been removed)
256
257* Sat Mar  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
258- new upstream release 4.3
259- merged with rawhide package.
260  * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
261  - rebuild in current collinst
262  - BuildRequires autoconf only
263  * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
264  - Fixed Esc-O-M stack overflow bug.
265  * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
266  - Updated to latest readline release 4.3
267  * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
268  - Fixed problem with alpha build.
269  * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
270  - Fixed utf8 problem (originally observed in bash).
271  * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
272  - automated rebuild
273  * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
274  - automated rebuild
275  * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
276  - Use autoconf 2.53, not 2.52
277  * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
278  - Rebuild
279  * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
280  - removed the manual symlinking of .so, readline handles this by itself
281  - call only %%makeinstall, not %%makeinstall install install-shared as
282    this makes bogus .old files in the buildroot
283  * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
284  - 4.2a
285  * Tue Oct  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
286  - Work around autoconf bug
287  * Mon Oct  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
288  - Don't use readline's internal re-implementation of strpbrk on systems
289    that have strpbrk - the system implementation is faster and better maintained.
290  * Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
291  - Make sure headers can be included from C++ applications (#51131)
292    (Patch based on Debian's with the bugs removed ;) )
293  * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
294  - update to 4.2 and adapt patches
295  * Fri Apr  6 2001 Nalin Dahyabhai <nalin@redhat.com>
296  - change the paths listed for the header files in the man page to reflect
297    the location changes from previous versions (#35073)
298  - note that "on" is acceptable instead of "On" in the man page (#21327)
299  * Thu Mar  8 2001 Preston Brown <pbrown@redhat.com>
300  - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
301  * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
302  - mark the man page as currently out-of-date (#25294)
303
304* Tue Sep  4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
305- remove texi2dvi and texi2html from doc/
306
307* Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
308- added doc and examples
309
310* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
311- 4.1-6vl3
312- rebuilt for VineSeed
313
314* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
315- 4.1-6vl2
316- Oops, spec was written in SJIS...
317
318* Sat Dec  9 2000 Jun Nishii <jun@vinelinux.org>
319- 4.1-6vl1
320- got i18n patch from Kondara
321
322* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
323- FHS packaging (64bit systems need to use libdir).
324
325* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
326- summaries from specspo.
327
328* Wed Aug  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
329- use "rm -f" in specfile
330
331* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
332- automatic rebuild
333
334* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
335- FHS packaging.
336
337* Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
338- 4.1
339
340* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
341- update to 4.0
342
343* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
344- added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
345
346* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
347- auto rebuild in the new build environment (release 4)
348
349* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
350- updated to 2.2.1
351
352* Wed May 06 1998 Prospector System <bugs@redhat.com>
353- translations modified for de, fr, tr
354
355* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
356- don't package /usr/info/dir
357
358* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
359- devel package moved to Development/Libraries
360
361* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
362- updated to 2.2
363
364* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
365- spec file cleanups
366
367* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
368- added proper sonames
369
370* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
371- updated to readline 2.1
372
373* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
374- built against glibc
Note: See TracBrowser for help on using the repository browser.