source: projects/specs/trunk/r/rdtool/rdtool-vl.spec @ 671

Revision 671, 5.5 KB checked in by iwaim, 14 years ago (diff)

update: rdtool 0.6.22-1

RevLine 
[521]1%define emacsen_pkg     1
2%{?without_emacsen: %define emacsen_pkg 0}
3
4%if %{emacsen_pkg}
5%undefine without_emacsen
6%else
7%define without_emacsen 1
8%endif
9%define rdmode          rd-mode
10%define rdmode_el       rd-mode
11
12Summary: RD document formatter
13Name: rdtool
14Version: 0.6.22
[671]15Release: 2%{?_dist_release}
[521]16License: distributable
17Group: Development/Tools
18Source0: http://www.moonwolf.com/ruby/archive/rdtool-%{version}.tar.gz
19Source1: %{rdmode_el}-install.sh
20Source2: %{rdmode_el}-remove.sh
[671]21Source3: vine-default-%{rdmode_el}.el
22Source4: %{rdmode_el}-init.el
23URL: http://rubyforge.org/projects/rdtool/
[521]24BuildArch: noarch
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: ruby, ruby-devel >= 1.8.0
27Requires: libruby >= 1.8.0, ruby, sh-utils
28Summary(ja): RDドキュメントのフォーマッタ
29
30%description
31RD is Ruby's POD. RDtool is formatter for RD.
32
33%description -l ja
34RD は Ruby においての POD です.RDtool は RD ドキュメントを
35様々な形式に変換するためのツールです.
36
[671]37Vendor: Project Vine
38Distribution: Vine Linux
39Packager: iwaim
40
[521]41%if %{emacsen_pkg}
42%package -n %{rdmode_el}
[671]43Summary: Emacsen major-mode for RD documents
44Summary: RDドキュメントのためのEmacsen用メジャーモード
[521]45Group: Applications/Editors/Emacs
46PreReq: emacsen, emacsen-common >= 0.1
47
48%description -n %{rdmode_el}
[671]49Emacsen major mode rd-mode for the RD documents
[521]50
51%description -n %{rdmode_el} -l ja
[671]52RDドキュメントのためのEmacsen用メジャーモード: rd-mode
53
[521]54%endif
55
56%prep
57%setup -q
58
59%build
60
61%install
62rm -rf $RPM_BUILD_ROOT
[671]63%{__ruby} setup.rb all --bindir=%{buildroot}%{rbindir} \
[521]64                     --rbdir=%{buildroot}%{rlibdir}
65# fix missing rd/dot.rd2rc
66install -m 0644 lib/rd/dot.rd2rc %{buildroot}%{rlibdir}/rd
67
68%if %{emacsen_pkg}
69mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{rdmode}
70mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
71mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
72%endif
73
74# fixing `#!' paths
75for f in `find . -type f`
76do
77  sed -e 's,^#![        ]*\([^  ]*\)/\(ruby\|with\|perl\|env\),#!/usr/bin/\2,' < $f > $f.n
78  mv -f $f.n $f
79done
80
81# installing rd-mode
82%if %{emacsen_pkg}
[671]83cp utils/*.el %{SOURCE3} %{SOURCE4} $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{rdmode}
[521]84
[671]85%_installemacsenscript %{rdmode} %{SOURCE1}
[521]86
[671]87%_removeemacsenscript  %{rdmode} %{SOURCE2}
[521]88
89%endif
90
91%if %{emacsen_pkg}
92%post -n %{rdmode_el}
93if [ "$1" = 2 ]; then
[671]94  %_emacsenPackageRemove %{rdmode}
[521]95
96fi
97
[671]98%_addemacsenlist %{rdmode}
[521]99
[671]100%_emacsenPackageInstall %{rdmode}
[521]101
102
103%preun -n %{rdmode_el}
104if [ "$1" = 0 ]; then
[671]105%_emacsenPackageRemove %{rdmode}
[521]106
[671]107%_removeemacsenlist %{rdmode}
[521]108
109fi
110%endif
111
112%clean
113rm -rf ${RPM_BUILD_ROOT}
114
115%files
116%defattr(-, root, root)
117%{_bindir}/*
118%{rlibdir}/rd
119%doc HISTORY
120%doc README.rd
121%doc README.rd.ja
122%doc README.html
123%doc README.ja.html
124%doc doc/rd-draft.rd
125%doc doc/rd-draft.rd.ja
126%doc utils
127
128%if %{emacsen_pkg}
129%files -n %{rdmode_el}
130%defattr(-, root, root)
131%{_datadir}/emacs/site-lisp/%{rdmode}
[671]132%{emacsen_pkgdir}/install/%{rdmode}
133%{emacsen_pkgdir}/remove/%{rdmode}
[521]134%endif
135
136%changelog
[671]137* Fri Mar 19 2010 IWAI, Masaharu <iwai@alib.jp> 0.6.22-2
138- apply vine-default
139  - update rd-mode-{install,remove}.sh
140  - add vine-default-rd-mode.el (Source3)
141  - add rd-mode-init.el (Source4)
142- using emacsen_pkgdir macro
143- update Summary and description for rd-mode package
144- update URL
145- add Tags: Vendor, Distribution and Packager
146- drop unnecessary defined variable: ruby, rbindir
147- drop unnecessary if routine: Source1,2
148- drop unnecessary Prefix tag
149
[521]150* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.22-1
151- new upstream release
152- applied new versioning policy, spec in UTF-8
153
154* Sat Sep 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.20-0vl2
155- fixed Group typo
156
157* Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.20-0vl1
158- new upstream release
159- changed rd-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
160- s/Copyright/License/
161
162* Mon Nov 15 2004 IWAI, Masaharu <iwai@alib.jp> 0.6.17-0vl1
163- new upstream release
164- drop unnecessary packages in BuildRequires: racc and ruby-amstd
165- update Source0 URL
166- drop obsolete patch: rdtoolconf.rb.patch ( Patch0 )
167- drop obsolete patch: rd-mode patch ( Patch2 )
168- update setup and intall sections: new upstream package using setup.rb
169- add README.ja.html in %%doc
170- fix missing rd/dot.rd2rc
171
172* Mon Oct 06 2003 akira yamada <akira@vinelinux.org> rdtool-0.6.13-0vl3
173- build with ruby-1.8.0.  it requires libruby >= 1.8.0.
174
175* Fri May 23 2003 IWAI Masaharu <iwai@alib.jp> 0.6.13-0vl2
176- fix typo in %%description -l ja for rdtool package
177- generate rd-mode package
178
179* Thu May 22 2003 IWAI Masaharu <iwai@alib.jp> 0.6.13-0vl1
180- new upstream version
181- update rdtoolconf.rb.patch (Patch0)
182- drop close-dt.patch (Pathc1): upstream merged
183- drop test in %%docdir
184
185* Sun Jun 16 2002 akira yamada <akira@vinelinux.org> 0.6.11-0vl2
186- added rdtool-0.6.11-close-dt.patch: ruby-ext#02080: missing </dt>
187- added rdtool-0.6.11-rd-mode.patch: ruby-list#35281: rd-mode.el - a bit fix
188
189* Mon Feb 04 2002 akira yamada <akira@vinelinux.org> 0.6.11-0vl1
190- new upstream version.
191- added ruby-optparse to BuildRequires.
192
193* Thu Jul 26 2001 akira yamada <akira@vinelinux.org> 0.6.10-0vl4
194- fixed bug in rd/rd2html-lib.rb (prepare_footnotes)
195- fixed bug in rd/rdblockparser.ry (desclistitem)
196
197* Thu Jul 26 2001 akira yamada <akira@vinelinux.org>
198- Rebuild with ruby-devel-1.6.4-0vl3.
199
200* Thu Jun 28 2001 akira yamada <akira@vinelinux.org>
201- Applied bugfix patch for rdvisitor.rb.
202
203* Tue Jun 12 2001 akira yamada <akira@vinelinux.org>
204- New upstream version 0.6.10.
205
206* Tue Mar 27 2001 akira yamada <akira@vinelinux.org>
207- Initial packaging.
Note: See TracBrowser for help on using the repository browser.