source: projects/specs/trunk/r/rdist/rdist-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Maintains identical copies of files on multiple machines.
2Summary(ja): 複数のマシン上で同一ファイルのコピーを保持するプログラム
3Name: rdist
4Version: 6.1.5
5Release: 45%{?_dist_release}
6Epoch: 1
7License: BSD
8Group: Applications/System
9Source0: http://www.MagniComp.com/download/rdist/rdist-%{version}.tar.gz
10Source1: http://www.magnicomp.com/rdist/rdist-eu-license.txt
11Source2: http://people.redhat.com/pknirsch/src/rdist-v1.1.tar.bz2
12Patch0: rdist-6.1.5-linux.patch
13Patch1: rdist-6.1.5-links.patch
14Patch2: rdist-6.1.5-oldpath.patch
15Patch3: rdist-6.1.5-hardlink.patch
16Patch4: rdist-6.1.5-bison.patch
17Patch5: rdist-6.1.5-varargs.patch
18Patch6: rdist-6.1.5-maxargs.patch
19Patch7: rdist-6.1.5-lfs.patch
20Patch8: rdist-6.1.5-cleanup.patch
21Patch9: rdist-6.1.5-svr4.patch
22Patch10: rdist-6.1.5-ssh.patch
23Patch11: rdist-6.1.5-mkstemp.patch
24Patch12: rdist-6.1.5-stat64.patch
25Patch13: rdist-6.1.5-re_args.patch
26Patch14: rdist-6.1.5-fix-msgsndnotify-loop.patch
27URL: http://www.MagniComp.comA/rdist
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: byacc bison
30
31%description
32The RDist program maintains identical copies of files on multiple
33hosts.  If possible, RDist will preserve the owner, group, mode and
34mtime of files and it can update programs that are executing.
35
36Install rdist if you need to maintain identical copies of files on
37multiple hosts.
38
39%description -l ja
40rdist プログラムは複数のホスト上に同一ファイルのコピーを保持します.
41可能であれば rdist はファイルのオーナー,グループ,モードや mtime も
42オリジナルのままにしようとします.現在実行中のプログラムの
43アップデートも可能です.
44
45複数のホスト上で同一ファイルのコピーを保持したい場合は
46rdist をインストールして下さい.
47
48
49%prep
50%setup -q
51%setup -q -T -D -a 2
52
53cp %{SOURCE1} .
54
55%patch0 -p1 -b .linux
56%patch1 -p1 -b .links
57%patch2 -p1 -b .oldpath
58%patch3 -p1 -b .hardlink
59%patch4 -p1 -b .bison
60%patch5 -p1 -b .varargs
61%patch6 -p1 -b .maxargs
62%patch7 -p1 -b .lfs
63%patch8 -p1 -b .cleanup
64%patch9 -p1 -b .svr4
65%patch10 -p1 -b .ssh
66%patch11 -p1 -b .mkstemp
67%patch12 -p1 -b .stat64
68%patch13 -p1 -b .re_args
69%patch14 -p1 -b .fix-msgsndnotify-loop
70
71%build
72make
73make -C rdist
74
75%install
76rm -rf ${RPM_BUILD_ROOT}
77mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
78mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
79mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man{1,8}
80
81install -m755 src/rdist ${RPM_BUILD_ROOT}%{_bindir}
82install -m755 rdist/rdist ${RPM_BUILD_ROOT}%{_bindir}/oldrdist
83install -m755 src/rdistd ${RPM_BUILD_ROOT}%{_sbindir}
84ln -sf ../sbin/rdistd ${RPM_BUILD_ROOT}%{_bindir}/rdistd
85
86install -m644 doc/rdist.man ${RPM_BUILD_ROOT}%{_mandir}/man1/rdist.1
87install -m644 doc/rdistd.man ${RPM_BUILD_ROOT}%{_mandir}/man8/rdist.8
88
89
90%clean
91rm -rf ${RPM_BUILD_ROOT}
92
93
94%files
95%defattr(-,root,root)
96%doc README rdist-eu-license.txt
97%{_bindir}/rdist
98%{_bindir}/oldrdist
99%{_bindir}/rdistd
100%{_sbindir}/rdistd
101%{_mandir}/man1/rdist.1*
102%{_mandir}/man8/rdist.8*
103
104
105%changelog
106* Sat Nov 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.1.5-45vl5
107- applied new versioning policy
108- spec in UTF-8
109- based on 6.1.5-45 from Fedora
110  * Wed Aug 02 2006 Phil Knirsch <pknirsch@redhat.com> 1:6.1.5-44
111  - Fixed problem with memory leak (#192229)
112  * Wed May 04 2005 Phil Knirsch <pknirsch@redhat.com> 6.1.5-41
113  - Fixed incorrect use of statfs return values (#147481)
114
115* Sun Oct  3 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.1.5-38vl1
116- based on 6.1.5-38 from Fedora
117  * Fri Jul 02 2004 Phil Knirsch <pknirsch@redhat.com> 6.1.5-38
118  - Added byacc to BuildPreReq (#124939)
119  * Tue May 25 2004 Phil Knirsch <pknirsch@redhat.com> 6.1.5-35.21.1
120  - Fixed missing unlink() for mkstemp() created file (#123833).
121  * Mon Jan 12 2004 Phil Knirsch <pknirsch@redhat.com> 6.1.5-32
122  - Included missing dir patch for mkstemp change (#106728).
123  * Wed Dec 17 2003 Phil Knirsch <pknirsch@redhat.com> 6.1.5-31
124  - Fixed wrong SvR4 system detection on Linux (#110426).
125  - Fixed unitialized use of struct (#111189).
126  - Make rsh work correctly with password authentification and ssh (#111778).
127  * Tue Dec 16 2003 Phil Knirsch <pknirsch@redhat.com>
128  - Finished LFS support for rdist on 32bit archs (#79580).
129  - Lots of code cleanup.
130  - Switched from mktemp to mkstemp usage.
131  * Thu Sep 04 2003 Phil Knirsch <pknirsch@redhat.com> 6.1.5-30
132  - Fixed max. # of args (#85634).
133
134* Sun Jul 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.1.5-29.1vl1
135- rebuilt with new toolchains
136- based on 6.1.5-29.1 from Rawhide
137  - Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com> 1:6.1.5-29
138  - use stdarg.h instead of varargs.h.
139
140  - Wed Jun 04 2003 Phil Knirsch <pknirsch@redhat.com> 1:6.1.5-27
141  - Fixed new bison build problems.
142  - Changed Copyright to License.
143
144  - Thu Jun 20 2002 Phil Knirsch <pknirsch@redhat.com> 6.1.5-21
145  - Include ia64 again.
146
147  - Thu Jan 31 2002 Phil Knirsch <pknirsch@redhat.com>
148  - Added my 4.3BSD port of the v1 protocol rdist code and provide a oldrdist
149    binary (#55761 and several others).
150  - Fixed a small manpage problem (#55489)
151
152* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
153- 6.1.5-14vl1
154- based on 6.1.5-14 from Rawhide
155- added Japanese summary and description
156
157* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
158- automatic rebuild
159
160* Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
161- FHS packaging.
162- exclude ia64 for now.
163
164* Sat Feb 05 2000 Cristian Gafton <gafton@redhat.com>
165- include new license package
166- man pages are compressed
167- fix description
168
169* Tue Jul 20 1999 Jeff Johnson <jbj@redhat.com>
170- re-release latest rdist package.
171
172* Thu Jun  3 1999 Jeff Johnson <jbj@redhat.com>
173- permit rdist to distribute hard links (#3228)
174
175* Tue Apr 13 1999 Jeff Johnson <jbj@redhat.com>
176- add /usr/bin/rdistd symlink (#2154)
177- update docs to reflect /usr/bin/oldrdist change.
178
179* Mon Apr 12 1999 Jeff Johnson <jbj@redhat.com>
180- use /usr/bin/oldrdist for old rdist compatibility path (#2044).
181
182* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
183- auto rebuild in the new build environment (release 5)
184
185* Wed Feb 17 1999 Jeff Johnson <jbj@redhat.com>
186- dynamic allocation for link info (#1046)
187
188* Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
189- update to 6.1.5
190
191* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
192- build root
193
194* Tue May 05 1998 Prospector System <bugs@redhat.com>
195- translations modified for de, fr, tr
196
197* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
198- fixed the url to the source
199- fixed the copyright field
200
201* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
202- built against glibc
Note: See TracBrowser for help on using the repository browser.