source: projects/specs/trunk/r/rcairo/rcairo-vl.spec @ 8029

Revision 8029, 3.6 KB checked in by Takemikaduchi, 10 years ago (diff)

ruby: fix macros.ruby
others: rebuild with ruby-2.0.0

Line 
1%define rlibdir  %(%{ruby} -r rbconfig -e 'print RbConfig::CONFIG["rubylibdir"]')
2%define rarchdir %(%{ruby} -r rbconfig -e 'print RbConfig::CONFIG["archdir"]')
3
4Summary:     Ruby binding for cairo
5Summary(ja): cairo の Ruby バインディング
6Name:        rcairo
7Version:     1.12.6
8Release:     2%{?_dist_release}
9Source0:     http://cairographics.org/releases/%{name}-%{version}.tar.gz
10License:     The same conditions as ruby
11Group:       System Environment/Libraries
12URL:         http://cairographics.org/
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ruby-devel >= 1.8.0
16BuildRequires: cairo-devel >= 1.2.0
17BuildRequires: ruby-pkg-config
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23Cairo is a 2D graphics library with support for multiple output devices.
24Currently supported output targets include the X Window System, win32, and
25image buffers. Experimental backends include OpenGL (through glitz), Quartz,
26XCB, PostScript and PDF file output.
27
28rcairo provides Ruby binding for cairo.
29
30%description -l ja
31cairo は 2D グラフィックスライブラリで,さまざまな出力デバイスをサポートして
32います.現在は,X Window System,Win32,イメージバッファをサポートしています.
33実験的に OpenGL(glitz経由),Quartz,XCB,PostScript/PDF ファイルへの出力も
34サポートしています.
35
36rcairo は cairo の Ruby バインディングを供給します。
37
38%package devel
39Summary:     The header file for rcairo
40Summary(ja): rcairo を用いた開発用のヘッダーファイル
41Group:       Development/Libraries
42Requires:    %{name} = %{version}
43
44%description devel
45The header file for rcairo
46
47%description devel -l ja
48rcairo を用いた開発用のヘッダーファイル
49
50%prep
51%setup -q
52
53%build
54%ruby extconf.rb
55%{__make}
56
57%install
58rm -rf ${RPM_BUILD_ROOT}
59%makeinstall sitelibdir=${RPM_BUILD_ROOT}%{rlibdir} sitearchdir=${RPM_BUILD_ROOT}%{rarchdir}
60
61%clean
62rm -rf ${RPM_BUILD_ROOT}
63
64%files
65%defattr(-,root,root)
66%doc AUTHORS COPYING ChangeLog GPL NEWS README samples
67%{rlibdir}/*.rb
68%{rlibdir}/cairo
69%{rarchdir}/*.so
70
71%files devel
72%defattr(-,root,root)
73%{rarchdir}/*.h
74
75%changelog
76* Sat Dec 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-2
77- rebuild with ruby-2.0.0.353
78
79* Sat Sep 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
80- new upstream release
81
82* Sun Jan 13 2013 IWAI, Masaharu <iwai@alib.jp> 1.12.2-1
83- new upstream release
84- add BuildRequires: ruby-pkg-config
85- build with ruby 1.9.3.362-6
86 - Use RbConfig instead of obsolete and deprecated Config.
87
88* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-2
89- rebuilt with new toolchains
90
91* Mon Oct 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-1
92- new upstream release
93
94* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.0-1
95- new upstream release
96- applied new versioning policy
97- removed BuildRequires: ruby-gnome2 (included pkg-config.rb)
98- spec in UTF-8
99
100* Sat Jun 30 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.5.0-0vl1
101- upstream release
102
103* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.0-0vl2
104- upstream release
105- add BuildRequires: rugy-gnome2 (extconf.rb requires "pkg-config")
106  CAUTION: circulated build dependency exists between ruby-gnome2 and rcairo
107- modify %%build and %%install scriptlet to cope with extconf.rb
108- add "%%{rlibdir}/cairo" subdirectory in %%files section
109
110* Sun Sep 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-0vl3
111- changed devel Group to Development/Libraries
112
113* Sat Feb 18 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.0-0vl2
114- rebuild
115
116* Sun Oct 30 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.0-0vl1
117- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.