source: projects/specs/trunk/r/rcairo/rcairo-vl.spec @ 521

Revision 521, 3.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define rlibdir  %(%{ruby} -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
2%define rarchdir %(%{ruby} -r rbconfig -e 'print Config::CONFIG["archdir"]')
3
4Summary:     Ruby binding for cairo
5Summary(ja): cairo の Ruby バインディング
6Name:        rcairo
7Version:     1.8.0
8Release:     1%{?_dist_release}
9Source0:     http://cairographics.org/releases/%{name}-%{version}.tar.gz
10License:     The same conditions as ruby
11Group:       System Environment/Libraries
12URL:         http://cairographics.org/
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ruby-devel >= 1.8.0
16BuildRequires: cairo-devel >= 1.2.0
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22Cairo is a 2D graphics library with support for multiple output devices.
23Currently supported output targets include the X Window System, win32, and
24image buffers. Experimental backends include OpenGL (through glitz), Quartz,
25XCB, PostScript and PDF file output.
26
27rcairo provides Ruby binding for cairo.
28
29%description -l ja
30cairo は 2D グラフィックスライブラリで,さまざまな出力デバイスをサポートして
31います.現在は,X Window System,Win32,イメージバッファをサポートしています.
32実験的に OpenGL(glitz経由),Quartz,XCB,PostScript/PDF ファイルへの出力も
33サポートしています.
34
35rcairo は cairo の Ruby バインディングを供給します。
36
37%package devel
38Summary:     The header file for rcairo
39Summary(ja): rcairo を用いた開発用のヘッダーファイル
40Group:       Development/Libraries
41Requires:    %{name} = %{version}
42
43%description devel
44The header file for rcairo
45
46%description devel -l ja
47rcairo を用いた開発用のヘッダーファイル
48
49%prep
50%setup -q
51
52%build
53%ruby ./extconf.rb
54%{__make}
55
56%install
57rm -rf ${RPM_BUILD_ROOT}
58%makeinstall sitelibdir=${RPM_BUILD_ROOT}%{rlibdir} sitearchdir=${RPM_BUILD_ROOT}%{rarchdir}
59
60%clean
61rm -rf ${RPM_BUILD_ROOT}
62
63%files
64%defattr(-,root,root)
65%doc AUTHORS COPYING ChangeLog GPL NEWS README samples
66%{rlibdir}/*.rb
67%{rlibdir}/cairo
68%{rarchdir}/*.so
69
70%files devel
71%defattr(-,root,root)
72%{rarchdir}/*.h
73
74%changelog
75* Mon Oct 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.0-1
76- new upstream release
77
78* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.0-1
79- new upstream release
80- applied new versioning policy
81- removed BuildRequires: ruby-gnome2 (included pkg-config.rb)
82- spec in UTF-8
83
84* Sat Jun 30 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.5.0-0vl1
85- upstream release
86
87* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.0-0vl2
88- upstream release
89- add BuildRequires: rugy-gnome2 (extconf.rb requires "pkg-config")
90  CAUTION: circulated build dependency exists between ruby-gnome2 and rcairo
91- modify %%build and %%install scriptlet to cope with extconf.rb
92- add "%%{rlibdir}/cairo" subdirectory in %%files section
93
94* Sun Sep 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-0vl3
95- changed devel Group to Development/Libraries
96
97* Sat Feb 18 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.0-0vl2
98- rebuild
99
100* Sun Oct 30 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.0.0-0vl1
101- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.