source: projects/specs/trunk/r/rbenv/rbenv-vl.spec @ 6457

Revision 6457, 1.3 KB checked in by daisuke, 12 years ago (diff)

new package

Line 
1%global gitdate 20120423
2
3Summary: Simple Ruby version management
4Summary(ja): シンプルなRubyバージョン管理システム
5Name: rbenv
6Version: 0.3.0.%{gitdate}
7Release: 1%{?_dist_release}
8License: MIT
9Group: Development/Tools
10URL: https://github.com/sstephenson/rbenv
11Source0: %{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildArch: noarch
15
16Distribution: Vine Linux
17Vendor: Project Vine
18Packager: daisuke
19
20%description
21rbenv lets you easily switch between multiple versions of Ruby. It's
22simple, unobtrusive, and follows the UNIX tradition of single-purpose
23tools that do one thing well.
24
25%prep
26%setup -q
27
28%build
29
30%install
31rm -rf %{buildroot}
32
33mkdir -p %{buildroot}%{_datadir}/rbenv
34cp -a libexec completions %{buildroot}%{_datadir}/rbenv/
35
36mkdir -p %{buildroot}%{_bindir}
37ln -s %{_datadir}/rbenv/libexec/rbenv %{buildroot}%{_bindir}/rbenv
38install -p bin/ruby-local-exec %{buildroot}%{_bindir}/ruby-local-exec
39
40%post
41echo You probably want to execute the following line to add rbenv to your shell
42echo echo "'eval \"\$(rbenv init -)\"'" \>\> ~/.bash_profile
43
44%clean
45rm -rf %{buildroot}
46
47%files
48%defattr(-,root,root,-)
49%doc LICENSE README.md
50%{_bindir}/rbenv
51%{_bindir}/ruby-local-exec
52%{_datadir}/rbenv
53
54%changelog
55* Fri Jun 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0.20120423-1
56- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.