source: projects/specs/trunk/r/rbenv/rbenv-vl.spec @ 9174

Revision 9174, 2.1 KB checked in by iwaim, 9 years ago (diff)

rbenv 0.4.0.20141020-1

Line 
1%global gitdate 20141020
2
3Summary: Simple Ruby version management
4Summary(ja): シンプルなRubyバージョン管理システム
5Name: rbenv
6Version: 0.4.0.%{gitdate}
7Release: 1%{?_dist_release}
8License: MIT
9Group: Development/Tools
10URL: https://github.com/sstephenson/rbenv
11Source0: %{name}-%{version}.tar.xz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildArch: noarch
15
16Distribution: Vine Linux
17Vendor: Project Vine
18Packager: daisuke
19
20%description
21rbenv lets you easily switch between multiple versions of Ruby. It's
22simple, unobtrusive, and follows the UNIX tradition of single-purpose
23tools that do one thing well.
24
25%prep
26%setup -q
27
28%build
29
30%install
31rm -rf %{buildroot}
32
33mkdir -p %{buildroot}%{_datadir}/rbenv
34cp -a libexec completions %{buildroot}%{_datadir}/rbenv/
35
36mkdir -p %{buildroot}%{_bindir}
37ln -s %{_datadir}/rbenv/libexec/rbenv %{buildroot}%{_bindir}/rbenv
38install -p bin/ruby-local-exec %{buildroot}%{_bindir}/ruby-local-exec
39
40%post
41echo You probably want to execute the following line to add rbenv to your shell
42echo echo "'eval \"\$(rbenv init -)\"'" \>\> ~/.bash_profile
43
44%clean
45rm -rf %{buildroot}
46
47%files
48%defattr(-,root,root,-)
49%doc LICENSE README.md
50%{_bindir}/rbenv
51%{_bindir}/ruby-local-exec
52%{_datadir}/rbenv
53
54%changelog
55* Sun Nov 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.4.0.20141020-1
56- update to upstream git master
57
58* Thu Apr 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0.20140410-1
59- update to upstream git master
60
61* Tue Dec 03 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0.20131203-1
62- update to upstream git master
63
64* Mon Feb 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0.20130225-1
65- update to upstream git master
66
67* Mon Jan 21 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.0.20130121-1
68- update to upstream git master
69
70* Sat Dec 15 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0.20121215-1
71- update to upstream git master
72
73* Thu Dec 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0.20121213-1
74- update to upstream git master
75
76* Fri Jun 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0.20120423-1
77- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.