source: projects/specs/trunk/r/rail/rail-vl.spec @ 9511

Revision 9511, 6.0 KB checked in by inagaki, 9 years ago (diff)

2015-04-15 Ryoichi INAGAKI <ryo1@…>

  • flim, semi: rebuilt
  • rail, xsp: updated


Line 
1%define _noVersionedDependencies        1
2
3%define origver         1.2.11
4%define origname        rail
5%define emacsen_pkgdir /usr/lib/emacsen-common/packages
6
7Name:         %{origname}
8Version:      %{origver}
9Release:      1%{?_dist_release}
10Summary:      rail - Replace Agent-string Internal Library for emacsen
11Summary(ja):  rail - emacsen 用 Agent 名変換ライブラリ
12
13License:      GPLv2+
14Group:        Applications/Editors/Emacs
15URL:          http://uwabami.github.io/rail/
16
17Source0:      https://github.com/uwabami/rail/archive/%{version}.tar.gz
18Source1:      semi-1.14.6-VERSION
19Source2:      flim-1.14.9-VERSION
20Source10:     %{origname}-install.sh
21Source11:     %{origname}-remove.sh
22Source12:     %{origname}-init.el
23
24BuildRoot:    %{_tmppath}/%{name}-%{version}-root
25BuildArch:    noarch
26
27Requires:     emacsen semi
28Requires(post): emacsen emacsen-common semi
29Obsoletes:    rail-xemacs
30Conflicts:    %{origname}-el
31
32Vendor:       Project Vine
33Distribution: Vine Linux
34Packager:     shaolin
35
36
37%description
38rail is a nifty elisp, that translates codenames with latin chars
39of flim/semi/XEmacs/UTF-2000-Mule/Meadow to Japanese characters.
40It also provides a function compatible with genjis.el (a part
41of tm, that converts mule-version to Japanese characters).
42
43
44%description -l ja
45rail は,flim/semi/XEmacs/UTF-2000-Mule/Meadow のコードネームを
46日本語化し,User-Agent: フィールドに適用するための elsp です.
47tm の genjis.el 互換機能 (mule-version の日本語化) も備えています.
48
49
50%prep
51%setup -q -n %{origname}-%{version}
52
53## install newer codename file for semi
54cp %{SOURCE1} contrib/SEMI_VERSION
55cp %{SOURCE2} contrib/FLIM_VERSION
56
57
58%install
59[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
60[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
61
62mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
63#mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
64#mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
65mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/install
66mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/remove
67
68
69## install el files
70
71cp -a Makefile contrib *.el \
72      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
73
74# 2004.12.13 add Irokawa
75cp -a %{SOURCE12} \
76      ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
77
78
79## install script (bytecompile el and install elc, remove elc)
80
81%_installemacsenscript %{origname} %{SOURCE10}
82
83%_removeemacsenscript  %{origname} %{SOURCE11}
84
85
86%clean
87[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
88
89
90%post
91
92## bytecompile el and install elc
93
94if [ "$1" = 2 ] ; then
95
96%_emacsenPackageRemove %{origname}
97
98fi
99
100%_addemacsenlist %{origname}
101
102%_emacsenPackageInstall %{origname}
103
104
105%preun
106
107if [ "$1" = 0 ] ; then
108
109%_emacsenPackageRemove %{origname}
110
111%_removeemacsenlist %{origname}
112
113fi
114
115
116%files
117%defattr(-,root,root)
118%doc ChangeLog GPL-2 FAQ.rdoc README.rdoc contrib
119%{_datadir}/emacs/site-lisp/%{origname}
120#%{_libdir}/emacsen-common/packages/install/%{origname}
121#%{_libdir}/emacsen-common/packages/remove/%{origname}
122%{emacsen_pkgdir}/install/%{origname}
123%{emacsen_pkgdir}/remove/%{origname}
124
125
126%changelog
127* Wed Apr 15 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.11-1
128- updated to 1.2.11
129- built on current VineSeed
130- added URL tag
131
132* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 1.2.5-2
133- drop defining prereq_ge macro: using Requires(post) tag
134- add Requires: emacsen semi
135- update Packager syntax
136
137* Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1vl5
138- applied new versioning policy, spec in utf-8
139- added macro %%emacsen_pkgdir
140
141* Fri Dec  7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl12
142- added %%{SOURCE2} for flim-1.14.9
143
144* Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl11
145- added %%{SOURCE2} for flim-1.14.8
146
147* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl10
148- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
149
150* Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl9
151- added %%{SOURCE2} for flim-1.14.7
152- added %%{SOURCE12} for use /etc/$FLAVOR/site-start.d/
153
154* Wed Dec 24 2003 MATSUBAYASHI <shaolin@vinelinux.org> 1.2.5-0vl8
155- added %%{SOURCE1} and %%{SOURCE2} for flim-1.14.6 / semi-1.14.6
156
157* Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl7
158- Modded %%{SOURCE2} for flim-1.14.5
159
160* Sat Dec 07 2002 MATSUBAYASHI <shaolin@vinelinux.org> 1.2.5-0vl6
161- added %%{SOURCE1} for semi-1.14.5
162
163* Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl5
164- added Source2 (for flim-1.14.4)
165
166* Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl4
167- package name changed rail-el -> rail again
168
169* Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl3
170- rail is now rail-el, thus emacsen-common aware :)
171
172* Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
173- 1.2.5-0vl2
174- added %%{SOURCE1} for semi-1.14.3
175
176* Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
177- 1.2.5-0vl1
178- updated to 1.2.5 release
179- now rail-xemacs is a sub-package
180- use better macros (%%{_tmppath})
181
182* Tue Mar 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
183- 1.2.4-0vl1
184- updated in sync with 1.2.4 release
185
186* Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
187- 1.0.2-2
188- Requires: apel, flim removed
189
190* Tue Nov 16 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
191- 1.0.2-1
192- updated in sync wih 1.0.2 release
193
194* Tue Oct 26 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
195- 0.8-1
196- updated in sync wih 0.8 release
197- added newer FLIM_VERSION file for newest CLIME release
198
199* Wed Oct 13 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
200- 0.7-1
201- updated in sync wih 0.7 release
202
203* Mon Oct  4 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
204- 0.6-1
205- updated in sync wih 0.6 release
206
207* Fri Oct  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
208- 0.5-2
209- added newer FLIM_VERSION file for newest CLIME release
210
211* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
212- 0.5-1
213- first rpm release
Note: See TracBrowser for help on using the repository browser.