source: projects/specs/trunk/r/radvd/radvd-vl.spec @ 521

Revision 521, 6.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# $Id: radvd.spec,v 1.17 2006/11/01 14:54:28 psavola Exp $
2
3%define initdir /etc/rc.d/init.d
4#%(if test -d /etc/init.d/. ; then echo /etc/init.d ; else echo /etc/rc.d/init.d ; fi)
5
6%define RADVD_UID 75
7
8Summary: A Router Advertisement daemon
9Name: radvd
10Version: 1.1
11Release: 1%{?_dist_release}
12# The code includes the advertising clause, so it's GPL-incompatible
13License: BSD-style
14Group: System Environment/Daemons
15Source: http://www.litech.org/radvd/radvd-%{version}.tar.gz
16PreReq: chkconfig, /usr/sbin/useradd, /sbin/service, initscripts
17BuildRoot: %{_tmppath}/%{name}-root
18BuildRequires: flex, byacc
19
20%description
21radvd is the router advertisement daemon for IPv6.  It listens to router
22solicitations and sends router advertisements as described in "Neighbor
23Discovery for IP Version 6 (IPv6)" (RFC 2461).  With these advertisements
24hosts can automatically configure their addresses and some other
25parameters.  They also can choose a default router based on these
26advertisements.
27
28Install radvd if you are setting up IPv6 network and/or Mobile IPv6
29services.
30
31%prep
32%setup
33
34%build
35export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
36%configure --with-pidfile=/var/run/radvd/radvd.pid
37make
38# make %{?_smp_mflags}
39# Parallel builds still fail because seds that transform y.tab.x into
40# scanner/gram.x are not executed before compile of scanner/gram.x
41#
42
43%install
44[ $RPM_BUILD_ROOT != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46%makeinstall
47mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
48mkdir -p $RPM_BUILD_ROOT%{initdir}
49mkdir -p $RPM_BUILD_ROOT/var/run/radvd
50
51install -m 644 redhat/radvd.conf.empty $RPM_BUILD_ROOT%{_sysconfdir}/radvd.conf
52install -m 755 redhat/radvd.init $RPM_BUILD_ROOT%{initdir}/radvd
53install -m 644 redhat/radvd.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/radvd
54
55%clean
56[ $RPM_BUILD_ROOT != "/" ] && rm -rf $RPM_BUILD_ROOT
57
58%postun
59if [ "$1" -ge "1" ]; then
60    /sbin/service radvd condrestart >/dev/null 2>&1
61fi
62
63%post
64/sbin/chkconfig --add radvd
65
66%preun
67if [ $1 = 0 ]; then
68   /sbin/service radvd stop >/dev/null 2>&1
69   /sbin/chkconfig --del radvd
70fi
71
72%pre
73
74/usr/sbin/useradd -c "radvd user" -r -M -s /sbin/nologin -u %{RADVD_UID} -d / radvd 2>/dev/null || :
75
76%files
77%defattr(-,root,root)
78%doc COPYRIGHT README CHANGES INTRO.html TODO
79%config(noreplace) %{_sysconfdir}/radvd.conf
80%config(noreplace) /etc/sysconfig/radvd
81%config %{initdir}/radvd
82%dir %attr(-,radvd,radvd) /var/run/radvd/
83%doc radvd.conf.example
84%{_mandir}/*/*
85%{_sbindir}/radvd
86%{_sbindir}/radvdump
87
88%changelog
89* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
90- new upstream release (includes <BTS:686> fix)
91
92* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-2vl5
93- applied new versioning policy
94
95* Wed Jan 02 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl2
96- rebuilt for VineSeed
97
98* Fri Nov 10 2006 yamamoto <yamamoto@yu.vinelinux.org> 1.0-1vl1
99- rebuild for vine 4.0
100
101* Wed Nov  1 2006 Pekka Savola <pekkas@netcore.fi> 1.0-1
102- 1.0; add BuildRequires
103
104* Fri Jan 13 2006 Pekka Savola <pekkas@netcore.fi> 0.9.1-1
105- 0.9.1
106
107* Tue Oct 18 2005 Pekka Savola <pekkas@netcore.fi> 0.9-1
108- 0.9 (also minor spec file cleanup in %%configure).
109
110* Fri Jul  8 2005 Pekka Savola <pekkas@netcore.fi> 0.8-1
111- 0.8.
112- Ship the example config file as %%doc (Red Hat's #159005)
113
114* Mon Feb 21 2005 Pekka Savola <pekkas@netcore.fi> 0.7.3-1
115- 0.7.3.
116
117* Mon Oct 28 2002 Pekka Savola <pekkas@netcore.fi>
118- 0.7.2.
119
120* Tue May  7 2002 Pekka Savola <pekkas@netcore.fi>
121- remove '-g %%{RADVD_GID}' when creating the user, which may be problematic
122  if the user didn't exist before.
123
124* Wed Jan 14 2002 Pekka Savola <pekkas@netcore.fi>
125- 0.7.1.
126
127* Tue Jan  8 2002 Pekka Savola <pekkas@netcore.fi>
128- Change 'reload' to signal HUP to radvd instead or restarting.
129
130* Fri Dec 28 2001 Pekka Savola <pekkas@netcore.fi>
131- License unfortunately is BSD *with* advertising clause, so to be pedantic,
132  change License: to 'BSD-style'.
133
134* Wed Nov 14 2001 Pekka Savola <pekkas@netcore.fi>
135- spec file cleanups
136- update to 0.7.0.
137
138* Wed Jun 20 2001 Pekka Savola <pekkas@netcore.fi>
139- use /sbin/service.
140- update to 0.6.2pl4.
141
142* Sat Apr 28 2001 Pekka Savola <pekkas@netcore.fi>
143- update to 0.6.2pl3.
144
145* Wed Apr 11 2001 Pekka Savola <pekkas@netcore.fi>
146- update to 0.6.2pl2.
147
148* Wed Apr  4 2001 Pekka Savola <pekkas@netcore.fi>
149- update to 0.62pl1.  Bye bye patches!
150- Require: initscripts (should really be with a version providing IPv6)
151- clean up the init script, make condrestart work properly
152- Use a static /etc/rc.d/init.d; init.d/radvd required it anyway.
153
154* Sun Apr  1 2001 Pekka Savola <pekkas@netcore.fi>
155- add patch to chroot (doesn't work well yet, as /proc is used directly)
156- clean up droproot patch, drop the rights earlier; require user-writable
157pidfile directory
158- set up the pidfile directory at compile time.
159
160* Sat Mar 31 2001 Pekka Savola <pekkas@netcore.fi>
161- add select/kill signals patch from Nathan Lutchansky <lutchann@litech.org>.
162- add address syntax checked fix from Marko Myllynen <myllynen@lut.fi>.
163- add patch to check the pid file before fork.
164- add support for OPTIONS sourced from /etc/sysconfig/radvd, provide a nice
165default one.
166- add/delete radvd user, change the pidfile to /var/run/radvd/radvd.pid.
167- fix initscript NETWORKING_IPV6 check.
168
169* Sun Mar 18 2001 Pekka Savola <pekkas@netcore.fi>
170- add droproot patch, change to nobody by default (should use radvd:radvd or
171the like, really).
172
173* Mon Mar  5 2001 Tim Powers <timp@redhat.com>
174- applied patch supplied by Pekka Savola in #30508
175- made changes to initscript as per Pekka's suggestions
176
177* Thu Feb 15 2001 Tim Powers <timp@redhat.com>
178- needed -D_GNU_SOURCE to build properly
179
180* Tue Feb  6 2001 Tim Powers <timp@redhat.com>
181- use %%configure and %%makeinstall, just glob the manpages, cleans
182  things up
183- fixed initscript so that it can be internationalized in the future
184
185* Fri Feb 2 2001 Pekka Savola <pekkas@netcore.fi>
186- Create a single package(source) for glibc21 and glibc22 (automatic
187Requires can handle this just fine).
188- use %%{_mandir} and friends
189- add more flesh to %doc
190- streamline %config file %attrs
191- streamline init.d file a bit:
192   * add a default chkconfig: (default to disable for security etc. reasons;
193     also, the default config isn't generic enough..)
194   * add reload/condrestart
195   * minor tweaks
196   * missing: localization support (initscripts-5.60)
197- use %%initdir macro
198
199* Thu Feb 1 2001 Lars Fenneberg <lf@elemental.net>
200- updated to new release 0.6.2
201
202* Thu Feb 1 2001 Marko Myllynen <myllynen@lut.fi>
203- initial version, radvd version 0.6.1
Note: See TracBrowser for help on using the repository browser.