source: projects/specs/trunk/r/rabbitvcs/rabbitvcs-vl.spec @ 521

Revision 521, 3.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pyver           %(python -c 'import sys;print(sys.version[0:3])')
2
3Summary:        Core component for RabbitVCS
4Summary(ja):    RabbitVCS のコア・コンポーネント
5Name:           rabbitvcs
6Version:        0.13
7Release:        1%{?_dist_release}
8Source0:        %{name}-core-%{version}.tar.gz
9License:        GPL
10Group:          Development/Tools
11URL:            http://rabbitvcs.org/
12
13Requires:       nautilus, pygtk2,  python-configobj
14Requires:       pygobject, glade2, pygtk2-libglade
15Requires:       subversion, pysvn
16BuildRequires:  python-devel, gettext
17Requires(post): gtk2
18Requires(postun): gtk2
19BuildArch:      noarch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23Packager:       kazutaka
24
25%description
26RabbitVCS is a set of graphical tools written to provide simple
27and straightforward access to the version control systems you use.
28
29This package containg core part of RabbitVCS and not connected
30to to any file manager or text editor.
31
32Front-ends or clients is privided separetely as  a Nautilus
33extention, Thunar extention and Gedit plugin, and a command line
34utility.
35
36%description -l ja
37RabbitVCS はバージョン管理システムにシンプルかつ直感的にアクセス
38できるよう設計された GUI のツールです。
39
40このパッケージには RabbitVCS のコアとなる部分だけが含まれており、
41特定のファイルマネージャやテキストエディタに依存しないようになっ
42ています。
43
44フロントエンドやクライアントは Nautilus 及び Thunar 用の拡張と、
45Gedit 用のプラグイン、そしてコマンドラインのユーティリティが、
46別パッケージとして提供されています。
47
48
49%prep
50%setup -q -n %{name}-core-%{version}
51
52%build
53%{__python} setup.py build
54
55
56%install
57%{__rm} -rf ${RPM_BUILD_ROOT}
58%{__python} setup.py install --skip-build --root ${RPM_BUILD_ROOT}
59
60# install japanese message catalog
61#%{__mkdir} -p ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES
62#msgfmt %{SOURCE1} -o ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES/NautilusSvn.mo
63
64
65%clean
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68
69%post
70touch --no-create %{_datadir}/icons/hicolor
71if [ -x /usr/bin/gtk-update-icon-cache ]; then
72  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
73fi
74
75%postun
76touch --no-create %{_datadir}/icons/hicolor
77if [ -x /usr/bin/gtk-update-icon-cache ]; then
78  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
79fi
80
81%files
82%defattr(-,root,root)
83%doc %{_datadir}/doc/%{name}/
84#%{_bindir}/%{name}
85#%{_libdir}/nautilus/extensions-2.0/python/RabbitVCS.py
86%{_libdir}/python%{pyver}/site-packages/
87%{_datadir}/icons/hicolor/scalable/actions/
88%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
89%{_datadir}/icons/hicolor/scalable/apps/%{name}-small.svg
90%{_datadir}/icons/hicolor/scalable/emblems/
91%{_datadir}/locale/
92%{_datadir}/%{name}/configspec.ini
93# only usefull for ubuntu (and debian??)
94#%exclude %{_datadir}/%{name}/do-rabbitvcs-restart-nautilus
95#%exclude %{_datadir}/%{name}/rabbitvcs-restart-required.update-notifier
96
97
98%changelog
99* Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13-1
100- new upstream release
101- now front-end for nautilus is provided separetely
102  (as rabbitvcs-nautilus package)
103
104* Wed Oct 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1
105- new upstream release with new name
106- add Obsoletes: nautilussvn
107- drop source1 (japanese translation)
108- update description
109
110* Fri Jun 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-3.beta1.2
111- update japanese translation
112
113* Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-2.beta1.2
114- add japanese translation as Source1
115- add BuildRequires: gettext
116
117* Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1.beta1.2
118- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.