source: projects/specs/trunk/r/rabbitvcs/rabbitvcs-vl.spec @ 2567

Revision 2567, 5.4 KB checked in by kazutaka, 13 years ago (diff)

0.14.1.1 に更新

Line 
1%define pyver           %(python -c 'import sys;print(sys.version[0:3])')
2
3%define build_vine5 0
4
5%if "%{?_dist_release}" == "vl5"
6%define build_vine5 1
7%endif
8
9Summary:        Integrated Subversion support for Nautilus
10Summary(ja):    Subversion サポートを Nautilus に追加する拡張
11Name:           rabbitvcs
12Version:        0.14.1.1
13Release:        1%{?_dist_release}
14Source0:        http://rabbitvcs.googlecode.com/files/%{name}-%{version}.tar.gz
15Patch1:         rabbitvcs-0.14.1.1-gtk216.patch
16License:        GPL
17Group:          Development/Tools
18URL:            http://rabbitvcs.org/
19
20Requires:       nautilus, pygtk2,  python-configobj
21Requires:       pygobject, glade2, pygtk2-libglade
22Requires:       subversion, pysvn, python-simplejson
23BuildRequires:  python-devel, gettext
24Requires(post): gtk2
25Requires(postun): gtk2
26BuildArch:      noarch
27
28BuildRoot:      %{_tmppath}/%{name}-%{version}-root
29
30Packager:       kazutaka
31
32%description
33RabbitVCS is a set of graphical tools written to provide simple
34and straightforward access to the version control systems you use.
35
36This package containg core part of RabbitVCS and not connected
37to to any file manager or text editor.
38
39Front-ends or clients is privided separetely as  a Nautilus
40extention, Thunar extention and Gedit plugin, and a command line
41utility.
42
43%description -l ja
44RabbitVCS はバージョン管理システムにシンプルかつ直感的にアクセス
45できるよう設計された GUI のツールです。
46
47このパッケージには RabbitVCS のコアとなる部分だけが含まれており、
48特定のファイルマネージャやテキストエディタに依存しないようになっ
49ています。
50
51フロントエンドやクライアントは Nautilus 及び Thunar 用の拡張と、
52Gedit 用のプラグイン、そしてコマンドラインのユーティリティが、
53別パッケージとして提供されています。
54
55%package nautilus
56Summary:        Integrated Subversion support for Nautilus
57Summary(ja):    Subversion サポートを Nautilus に追加する拡張
58Group:          Development/Tools
59Requires:       nautilus >= 2.22.0
60Requires:       nautilus-python >= 0.7.0
61Requires:       dbus-python > 0.80
62Requires:       rabbitvcs >= %{version}-%{release}
63Obsoletes:      nautilussvn
64
65%description nautilus
66RabbitVCS is a set of graphical tools written to provide simple
67and straightforward access to the version control systems you use.
68
69With this package, You can acces to the version control systems
70by Nautilus file manager.
71
72%description nautilus -l ja
73RabbitVCS はバージョン管理システムにシンプルかつ直感的にアクセス
74できるよう設計された GUI のツールです。
75
76このパッケージを利用することで、Nautilus ファイルマネージャに
77統合された形でバージョン管理システムにアクセスできるようになり
78ます。
79
80
81%prep
82%setup -q
83%if %{build_vine5}
84%patch1 -p1 -b .gtk216
85%endif
86
87%build
88%{__python} setup.py build
89
90
91%install
92%{__rm} -rf ${RPM_BUILD_ROOT}
93%{__python} setup.py install --skip-build --root ${RPM_BUILD_ROOT}
94
95# install japanese message catalog
96#%{__mkdir} -p ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES
97#msgfmt %{SOURCE1} -o ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES/NautilusSvn.mo
98
99# install nautilus client
100%{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_datadir}/nautilus-python/extensions
101%{__install} -m644 clients/nautilus/RabbitVCS.py ${RPM_BUILD_ROOT}/%{_datadir}/nautilus-python/extensions
102
103
104%clean
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107
108%post
109touch --no-create %{_datadir}/icons/hicolor
110if [ -x /usr/bin/gtk-update-icon-cache ]; then
111  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
112fi
113
114%postun
115touch --no-create %{_datadir}/icons/hicolor
116if [ -x /usr/bin/gtk-update-icon-cache ]; then
117  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
118fi
119
120%files
121%defattr(-,root,root)
122%doc %{_datadir}/doc/%{name}/
123%{_libdir}/python%{pyver}/site-packages/
124%{_datadir}/icons/hicolor/scalable/actions/
125%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
126%{_datadir}/icons/hicolor/scalable/apps/%{name}-small.svg
127%{_datadir}/icons/hicolor/scalable/emblems/
128%{_datadir}/locale/
129%{_datadir}/%{name}/configspec.ini
130# only usefull for ubuntu (and debian??)
131#%exclude %{_datadir}/%{name}/do-rabbitvcs-restart-nautilus
132#%exclude %{_datadir}/%{name}/rabbitvcs-restart-required.update-notifier
133
134%files nautilus
135%defattr(-,root,root)
136%doc clients/nautilus/README
137%{_datadir}/nautilus-python/extensions/RabbitVCS.py
138
139
140%changelog
141* Sun Jan 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.14.1.1-1
142- new upstream release
143- add Requires: python-simplejson
144- add Patch1 to avoid error when gtk+ < 2.18 (only for Vine 5)
145
146* Fri Jul 23 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13.3-1
147- new upstream release
148- merge rabbitvcs-nautilus package again (upstream source change)
149- requires nautilus-python >= 0.7.0 for rabbitvcs-nautilus
150
151* Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13-1
152- new upstream release
153- now front-end for nautilus is provided separetely
154  (as rabbitvcs-nautilus package)
155
156* Wed Oct 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1
157- new upstream release with new name
158- add Obsoletes: nautilussvn
159- drop source1 (japanese translation)
160- update description
161
162* Fri Jun 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-3.beta1.2
163- update japanese translation
164
165* Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-2.beta1.2
166- add japanese translation as Source1
167- add BuildRequires: gettext
168
169* Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1.beta1.2
170- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.