source: projects/specs/trunk/q/qzion/qzion-vl.spec @ 521

Revision 521, 3.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           qzion
5Version:        0.4.0
6Release:        6%{?_dist_release}
7Summary:        A canvas abstraction
8
9Group:          System Environment/Libraries
10License:        GPLv3+
11URL:            http://code.openbossa.org/projects/qzion
12Source0:        http://code.openbossa.org/projects/%{name}/repos/mainline/archive/d32223eae1bba7f1b191c334668f3f7dd662f582.tar.gz
13
14Patch0:         qzion-0.4.0-fix_python_install.patch
15Patch1:         qzion-0.4.0-fix_char_conversion.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  qt4-devel
20BuildRequires:  PyQt4-devel
21BuildRequires:  cmake
22BuildRequires:  pkgconfig
23BuildRequires:  python-devel
24BuildRequires:  sip-devel
25
26%description
27QZion is an canvas abstraction used by and made for QEdje.
28
29%package devel
30Summary:   Development files for %{name}
31Group:     Development/Libraries
32Requires:  cmake
33Requires:  pkgconfig
34Requires:  %{name} = %{version}-%{release}
35
36%description devel
37The %{name}-devel package contains libraries and header files for
38developing applications that use %{name}.
39
40%package python
41Summary:  Python bindings for %{name}
42Group:    Development/Libraries
43Requires: PyQt4
44
45%description python
46The %{name}-python package contains python bindings for %{name}
47
48
49%package python-devel
50Summary:  Python bindings for %{name}
51Group:    Development/Libraries
52Requires: sip
53Requires: PyQt4-devel
54Requires: %{name}-python = %{version}-%{release}
55
56%description python-devel
57The %{name}-python-devel package contains the development files for
58the python bindings for %{name}
59
60%prep
61%setup -q -n %{name}-mainline
62%patch0 -p1
63%patch1 -p1
64
65%build
66
67mkdir -p %{_target_platform}
68pushd %{_target_platform}
69%cmake \
70    -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
71    ..
72popd
73
74make %{?_smp_mflags} -C %{_target_platform}
75
76%install
77rm -rf %{buildroot}
78make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
79
80%clean
81rm -rf %{buildroot}
82
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88
89%files
90%defattr(-,root,root,-)
91%doc README COPYING
92%{_libdir}/*.so.*
93
94%files devel
95%defattr(-,root,root,-)
96%{_libdir}/*.so
97%{_includedir}/*
98%{_libdir}/pkgconfig/%{name}.pc
99
100%files python
101%defattr(-,root,root,-)
102%{python_sitearch}/%{name}
103
104%files python-devel
105%defattr(-,root,root,-)
106%{_datadir}/sip/%{name}
107
108%changelog
109* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-6
110- rebuilt with python2.6
111
112* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.4.0-5
113- use %%cmake macro
114
115* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-4
116- Initial build for Vine Linux
117
118* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Thu Jul 16 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-2
122- Fix char* conversion (#511583)
123
124* Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
125- Updated to new upstream release (0.4.0)
126
127* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
129
130* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
131- Implemented package review suggestions
132- Remove BR: eet-devel
133
134* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
135- Initial package
Note: See TracBrowser for help on using the repository browser.