source: projects/specs/trunk/q/qzion/qzion-vl.spec @ 10570

Revision 10570, 3.8 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           qzion
5Summary:        A canvas abstraction
6Version:        0.4.0
7Release:        8%{?_dist_release}
8
9Group:          System Environment/Libraries
10License:        GPLv3+
11URL:            http://code.openbossa.org/projects/qzion
12
13Source0:        http://code.openbossa.org/projects/%{name}/repos/mainline/archive/d32223eae1bba7f1b191c334668f3f7dd662f582.tar.gz
14
15Patch0:         qzion-0.4.0-fix_python_install.patch
16Patch1:         qzion-0.4.0-fix_char_conversion.patch
17#Make configure_file use full path so that qzion.pc can be found correctly.
18Patch2:         qzion-0.4.0-fix_configure_paths.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  qt4-devel
23BuildRequires:  PyQt4-devel
24BuildRequires:  cmake
25BuildRequires:  pkgconfig
26BuildRequires:  python-devel
27BuildRequires:  sip-devel
28
29%description
30QZion is an canvas abstraction used by and made for QEdje.
31
32%package devel
33Summary:   Development files for %{name}
34Group:     Development/Libraries
35Requires:  cmake
36Requires:  pkgconfig
37Requires:  %{name} = %{version}-%{release}
38
39%description devel
40The %{name}-devel package contains libraries and header files for
41developing applications that use %{name}.
42
43%package python
44Summary:  Python bindings for %{name}
45Group:    Development/Libraries
46Requires: PyQt4
47
48%description python
49The %{name}-python package contains python bindings for %{name}
50
51
52%package python-devel
53Summary:  Python bindings for %{name}
54Group:    Development/Libraries
55Requires: sip
56Requires: PyQt4-devel
57Requires: %{name}-python = %{version}-%{release}
58
59%description python-devel
60The %{name}-python-devel package contains the development files for
61the python bindings for %{name}
62
63%prep
64%setup -q -n %{name}-mainline
65%patch0 -p1
66%patch1 -p1
67%patch2 -p1
68
69%build
70
71mkdir -p %{_target_platform}
72pushd %{_target_platform}
73%cmake \
74    -DPYTHON_SITE_PACKAGES_DIR=%{python_sitearch} \
75    ..
76popd
77
78make %{?_smp_mflags} -C %{_target_platform}
79
80%install
81rm -rf %{buildroot}
82make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
83
84%clean
85rm -rf %{buildroot}
86
87
88%post -p /sbin/ldconfig
89
90%postun -p /sbin/ldconfig
91
92
93%files
94%defattr(-,root,root,-)
95%doc README COPYING
96%{_libdir}/*.so.*
97
98%files devel
99%defattr(-,root,root,-)
100%{_libdir}/*.so
101%{_includedir}/*
102%{_libdir}/pkgconfig/%{name}.pc
103
104%files python
105%defattr(-,root,root,-)
106%{python_sitearch}/%{name}
107
108%files python-devel
109%defattr(-,root,root,-)
110%{_datadir}/sip/%{name}
111
112%changelog
113* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.0-8
114- rebuild with gcc-5.4.0
115
116* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-7
117- rebuilt with rpm-4.8.1 for pkg-config
118
119* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.0-6
120- rebuilt with python2.6
121
122* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.4.0-5
123- use %%cmake macro
124
125* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.0-4
126- Initial build for Vine Linux
127
128* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
130
131* Thu Jul 16 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-2
132- Fix char* conversion (#511583)
133
134* Fri Mar 06 2009 John5342 <john5342 at, fedoraproject.org> 0.4.0-1
135- Updated to new upstream release (0.4.0)
136
137* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
139
140* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-2
141- Implemented package review suggestions
142- Remove BR: eet-devel
143
144* Fri Dec 19 2008 John5342 <john5342 at, fedoraproject.org> 0.3.0-1
145- Initial package
Note: See TracBrowser for help on using the repository browser.