source: projects/specs/trunk/q/qwt/qwt-vl.spec @ 10570

Revision 10570, 6.1 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
3%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_libdir})
4%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_includedir})
5
6Name:    qwt
7Summary: Qt Widgets for Technical Applications
8Version: 5.2.2
9Release: 28%{?_dist_release}
10
11License: LGPLv2 with exceptions
12Group:   System Environment/Libraries
13URL:     http://qwt.sourceforge.net/
14
15Source:  http://downloads.sourceforge.net/qwt/qwt-%{version}.tar.bz2
16## upstreamable patches
17# use qt_install system paths
18Patch50: qwt-5.2.2-qt_install_paths.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: qt4-devel
22
23%description
24The Qwt library contains GUI Components and utility classes which are primarily
25useful for programs with a technical background.
26Besides a 2D plot widget it provides scales, sliders, dials, compasses,
27thermometers, wheels and knobs to control or display values, arrays
28or ranges of type double.
29
30%package qt4
31Summary: Qt Widgets for Technical Applications
32Group: System Environment/Libraries
33Requires: qt4 >= %{_qt4_version}
34
35%description qt4
36The Qwt library contains GUI Components and utility classes which are primarily
37useful for programs with a technical background.
38Besides a 2D plot widget it provides scales, sliders, dials, compasses,
39thermometers, wheels and knobs to control or display values, arrays
40or ranges of type double.
41
42%package qt4-devel
43Summary:  Development files for %{name}
44Group: Development/Libraries
45Requires: %{name}-qt4 = %{version}-%{release}
46
47%description qt4-devel
48%{summary}.
49
50%package doc
51Summary: Extra Developer documentation for %{name}
52Group: Documentation
53BuildArch: noarch
54
55%description doc
56%{summary}.
57
58%prep
59%setup -q -n qwt-%{version}
60%patch50 -p1 -b .qt_install_paths
61
62
63%build
64export QTDIR=%{_qt4_prefix}
65$QTDIR/bin/qmake CONFIG+=QwtSVGItem
66
67make %{?_smp_mflags}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install INSTALL_ROOT=%{buildroot}
72
73# fixup docs bogosity
74rm -rf _docs_to_include
75mkdir -p _docs_to_include
76mv %{buildroot}%{_qt4_docdir}/html \
77   _docs_to_include
78
79
80%post qt4 -p /sbin/ldconfig
81%postun qt4 -p /sbin/ldconfig
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files qt4
87%doc CHANGES COPYING README
88%{_qt4_libdir}/libqwt.so.5*
89%{_qt4_plugindir}/designer/libqwt5_designer_plugin.so
90
91%files qt4-devel
92%{_mandir}/man3/*
93%{_qt4_headerdir}/qwt5-qt4/
94%{_qt4_libdir}/libqwt.so
95%{_qt4_libdir}/pkgconfig/qwt.pc
96
97%files doc
98# own these to avoid needless dep on qt/qt-doc
99%doc _docs_to_include/html/*
100
101
102%changelog
103* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 5.2.2-28
104- rebuild with gcc-5.4.0
105
106* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.2.2-27
107- Initial build for Vine Linux
108
109* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-26
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
111
112* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-25
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
114
115* Tue Oct 29 2013 Rex Dieter <rdieter@fedoraproject.org> - 5.2.2-24
116- cleanup
117- rework to avoid CONFIG+=install-qt
118
119* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-23
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
121
122* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-22
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
124
125* Tue Aug 14 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-21
126- don't change soname, just libqwt.so symlink
127
128* Fri Aug 03 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-20
129- pkgconfig support
130- bump release to -20
131
132* Tue Jul 31 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-5
133- make parallel-installable with qwt6
134
135* Tue Jul 31 2012 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-4
136- Provides: qwt5-qt4(-devel)
137- pkgconfig-style deps
138
139* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-3
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
141
142* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.2-2
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
144
145* Sun Aug 07 2011 Rex Dieter <rdieter@fedoraproject.org> 5.2.2-1
146- 5.2.2
147
148* Thu Jul 14 2011 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-3
149- .spec cosmetics
150- use %%_qt4_ macros
151- -doc subpkg here (instead of separately built)
152
153* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.1-2
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
155
156* Fri Apr 16 2010 Frank Büttner <frank-buettner@gmx.net> - 5.2.1-1
157- update to 5.2.1
158
159* Fri Feb 05 2010 Frank Büttner <frank-buettner@gmx.net> - 5.2.0-1
160- fix wrong lib names
161
162* Fri Feb 05 2010 Frank Büttner <frank-buettner@gmx.net> - 5.2.0-0
163- update to 5.2.0
164
165* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-4
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
167
168* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-3
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
170
171* Sun Jan 04 2009 Frank Büttner <frank-buettner@gmx.net> - 5.1.1-2
172 - modify path patch
173
174* Sun Jan 04 2009 Frank Büttner <frank-buettner@gmx.net> - 5.1.1-1
175 -update to 5.1.1
176
177* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 5.0.2-6
178- Autorebuild for GCC 4.3
179
180* Sat Sep 29 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-5
181 - add EPEL support
182
183* Sat Sep 29 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-4
184- remove parallel build, because it will fail sometimes
185
186* Fri Sep 28 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-3
187- fix some errors in the spec file
188
189* Fri Jul 06 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-2
190- fix some errors in the spec file
191
192* Mon Jun 11 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.2-1
193- update to 5.0.2
194- split doc
195
196* Thu May 15 2007 Frank Büttner <frank-buettner@gmx.net> - 5.0.1-1
197 - start
198
Note: See TracBrowser for help on using the repository browser.