source: projects/specs/trunk/q/quota/quota-vl.spec @ 521

Revision 521, 8.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: quota
2Summary: System administration tools for monitoring users' disk usage.
3Summary(ja): ユーザのディスク使用量をモニタするシステム管理ツール
4Version: 3.15
5Release: 1%{?_dist_release}
6License: BSD
7Group: System Environment/Base
8URL: http://sourceforge.net/projects/linuxquota/
9#Source0: http://downloads.sourceforge.net/linuxquota/quota-%{version}.tar.gz
10Source0: quota-%{version}.tar.gz
11Patch0: quota-3.06-warnquota.patch
12Patch1: quota-3.06-no-stripping.patch
13Patch2: quota-3.06-man-page.patch
14
15BuildRoot: %{_tmppath}/%{name}-root
16Requires: kernel >= 2.4, initscripts >= 6.38
17Conflicts: nfs-utils < 1.0.1
18BuildPreReq: e2fsprogs-devel, gettext
19
20
21%description
22The quota package contains system administration tools for monitoring
23and limiting user and or group disk usage per filesystem.
24
25%description -l ja
26quota パッケージには,ユーザやグループのディスク使用量を監視したり
27制限したりできるシステム管理ツールが収録されています.これらの操作
28はファイルシステム単位で行うことが出来ます.
29ユーザやグループのディスク使用量を監視/制限した場合は quota をイン
30ストールして下さい.
31
32
33%prep
34%setup -q -n quota-tools
35#%patch0 -p1
36%patch1 -p1
37%patch2 -p1
38
39
40%build
41%configure \
42        --with-ext2direct=no --enable-rootsbin
43make
44
45
46%install
47rm -fr %{buildroot}
48mkdir -p %{buildroot}/sbin
49mkdir -p %{buildroot}%{_sysconfdir}
50mkdir -p %{buildroot}%{_sbindir}
51mkdir -p %{buildroot}%{_bindir}
52mkdir -p %{buildroot}%{_mandir}/{man1,man2,man3,man8}
53
54
55make install ROOTDIR=%{buildroot}
56
57
58install -m 644 warnquota.conf %{buildroot}%{_sysconfdir}
59
60
61# we don't support XFS yet
62#
63rm -f %{buildroot}%{_sbindir}/quot
64rm -f %{buildroot}%{_sbindir}/xqmstats
65rm -f %{buildroot}%{_mandir}/man8/quot.*
66
67
68%find_lang %{name}
69
70
71%clean
72rm -rf %{buildroot}
73
74
75%files -f %{name}.lang
76%defattr(-,root,root)
77%doc Changelog doc/ README*
78%config(noreplace) %{_sysconfdir}/warnquota.conf
79%attr(0755,root,root) /sbin/*
80%attr(0755,root,root) %{_bindir}/*
81%attr(0755,root,root) %{_sbindir}/*
82%{_includedir}/rpcsvc/*
83%attr(0644,root,root) %{_mandir}/man1/*
84%attr(0644,root,root) %{_mandir}/man2/*
85%attr(0644,root,root) %{_mandir}/man3/*
86%attr(0644,root,root) %{_mandir}/man8/*
87
88
89%changelog
90* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.15-1vl5
91- applied new versioning policy, spec in utf-8
92
93* Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 3.15-0vl1
94- updated quota to 3.15
95
96* Wed Apr 27 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl2
97- oops, removed unnecessary Patch3
98
99* Tue Apr 26 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl1
100- based on 3.12-5, being merged into 3.06-7vl1
101
102  - Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 3.12-5
103  - add URL (bz# 131862)
104
105  - Fri Sep 24 2004 Steve Dickson <SteveD@RedHat.com>
106  - Fixed typos in warnquota.conf patch
107    (bz# 82250 and bz# 83974)
108
109  - Mon Sep 13 2004 Steve Dickson <SteveD@RedHat.com>
110  - upgraded to 3.12
111
112  - Tue Jan 27 2004 Florian La Roche <Florian.LaRoche@redhat.de>
113  - add -pie support
114  - update to 3.10
115
116  - Sat Aug 16 2003  Steve Dickson <SteveD@RedHat.com>
117  - upgraded to 3.0.9
118  - added quota-3.09-root_sbindir.patch
119
120* Sun Feb  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.06-7vl1
121- merged with Vine Linux package (quota-2.00stable-0vl1)
122- based on rawhide release 3.06-7
123 * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
124 - 2.00stable-0vl1
125 - ver.up
126 * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
127 - 2.00pre3-8vl2
128 - added documents
129 * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
130 - 2.00pre3-8vl1
131 - based on 2.00pre3-8 from Rawhide
132 - added Japanese summary and description
133
134* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
135- rebuilt
136
137* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
138- rebuild on all arches
139
140
141* Fri Sep 6 2002 Philip Copeland <bryce@redhat.com> 3.06-5
142- added --with-ext2direct=no to fix #73244
143  without this users with UID's > 65535 will not
144  be able to exist on a quota enabled FS
145
146* Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 3.06-4
147- Man page change. #60108
148
149* Tue Aug 6 2002 Philip Copeland <bryce@redhat.com> 3.06-3
150- Bah, I'd dropped epoch from the spec file but seems
151  we need this if you want to upgrade as the epoch
152  number has precedence over the version/release
153  numbers.
154
155* Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 3.06-2
156- Lets stop the makefile from stripping the
157  binaries as thats rpms job (apparently)
158
159* Mon Jul 01 2002 Philip Copeland <bryce@redhat.com> 3.06-1
160- Ditched the 3.01-pre9 src base for 3.06
161  Rebuilt without any patchs
162
163============================================================
164
165* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
166- automated rebuild
167
168* Thu May 23 2002 Tim Powers <timp@redhat.com>
169- automated rebuild
170
171* Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com>
172- IfArch the badkernelinclude patch for ppc-only.
173- Update to 3.03
174
175* Wed Dec 12 2001 Guy Streeter <streeter@redhat.com>
176- Make #include of kernel header file work on non-x86
177
178* Wed Sep  5 2001 Preston Brown <pbrown@redhat.com>
179- require new initscripts
180
181* Thu Aug 30 2001 Preston Brown <pbrown@redhat.com>
182- fixed bug #52075 (problem with ext2 labels)
183- backup data files off by default in quotacheck, optional backup flag added
184- fix bug where giving a bad directory or device would cause
185  quotaon/quotacheck to simulate "-a" behaviour
186- if a device name (i.e /dev/hda1) is passed, look up the corresponding mount
187  point
188
189* Wed Aug 29 2001 Preston Brown <pbrown@redhat.com>
190- return an error code in more cases in convertquota
191
192* Tue Aug 28 2001 Preston Brown <pbrown@redhat.com>
193- 3.01pre9
194
195* Fri Jul 20 2001 Preston Brown <pbrown@redhat.com>
196- more cleanups on 3.01pre8
197
198* Mon Jul  2 2001 Preston Brown <pbrown@redhat.com>
199- 3.01 version, everything has changed again. :(
200
201* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
202- Bump release + rebuild.
203
204* Fri Mar 30 2001 Preston Brown <pbrown@redhat.com>
205- use rpc.rquotad from here again (#33738)
206
207* Thu Mar 15 2001 Preston Brown <pbrown@redhat.com>
208- enable ALT_FORMAT for edquota
209
210* Tue Mar 13 2001 Preston Brown <pbrown@redhat.com>
211- I broke passing devices on the cmd line.  Fixed.
212
213* Fri Mar 09 2001 Preston Brown <pbrown@redhat.com>
214- quota 3.00 is required by recent kernel 2.4 changes
215- no warnquota included this time, not yet ported
216- quite a bit of work on quotacheck to make is backwards compatible
217- we will likely go back to "quota 2.00" as these projects merge...
218
219* Fri Feb 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
220- use "rm -f" instead of only "rm"
221
222* Wed Feb  7 2001 Preston Brown <pbrown@redhat.com>
223- fix quotacheck man page for -a option (#26380)
224
225* Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
226- 2.00 final, rolls in pretty much all our patches. :)
227- fix reporting of in use dquot entries from quotastats
228- change repquota man page to fix documentation of -v (#10330)
229- include warnquota.conf
230
231* Mon Nov 20 2000 Bill Nottingham <notting@redhat.com>
232- fix ia64 build
233
234* Mon Aug 21 2000 Jeff Johnson <jbj@redhat.com>
235- add LABEL=foo support (#16390).
236
237* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
238- remote NFS quotas with different blocksize converted incorrectly (#11932).
239
240* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
241- automatic rebuild
242
243* Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
244- FHS packaging.
245
246* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
247- apply patch5 (H.J. Lu)
248
249* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
250- fix description
251- man pages are compressed
252
253* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
254- quota 2.00 series
255- removed unnecessary patches
256
257* Thu Aug  5 1999 Jeff Johnson <jbj@redhat.com>
258- fix man page FUD (#4369).
259
260* Thu May 13 1999 Peter Hanecak <hanecak@megaloman.sk>
261- changes to allow non-root users to build too (Makefile patch, %attr)
262
263* Tue Apr 13 1999 Jeff Johnson <jbj@redhat.com>
264- fix for sparc64 quotas (#2147)
265
266* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
267- auto rebuild in the new build environment (release 5)
268
269* Mon Dec 28 1998 Cristian Gafton <gafton@redhat.com>
270- don't install rpc.rquotad - we will use the one from the knfsd package
271  instead
272
273* Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
274- merge ultrapenguin 1.1.9 changes.
275
276* Thu May 07 1998 Prospector System <bugs@redhat.com>
277- translations modified for de, fr, tr
278
279* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
280- removed patch for mntent
281
282* Fri Mar 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
283- updated to quota 1.66
284
285* Tue Jan 13 1998 Erik Troan <ewt@redhat.com>
286- builds rquotad
287- installs rpc.rquotad.8 symlink
288
289* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
290- removed /usr/include/rpcsvc/* from filelist
291- uses a buildroot and %attr
292
293* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
294- built against glibc
295
296* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
297- Moved /usr/sbin/quota to /usr/bin/quota
Note: See TracBrowser for help on using the repository browser.