source: projects/specs/trunk/q/quota/quota-vl.spec @ 5887

Revision 5887, 10.6 KB checked in by daisuke, 12 years ago (diff)

quota:

  • update to 4.00
  • add BR: tcp_wrappers, nss-devel, openldap-devel, openssl-devel, dbus-devel, libnl-devel
Line 
1Name: quota
2Summary: System administration tools for monitoring users' disk usage.
3Summary(ja): ユーザのディスク使用量をモニタするシステム管理ツール
4Version: 4.00
5Release: 1%{?_dist_release}
6License: BSD
7Group: System Environment/Base
8URL: http://sourceforge.net/projects/linuxquota/
9#Source0: http://downloads.sourceforge.net/linuxquota/quota-%{version}.tar.gz
10Source0: quota-%{version}.tar.gz
11Source1: quota_nld.init
12Source2: quota_nld.sysconfig
13Patch0: quota-4.00-warnquota.patch
14Patch1: quota-3.06-man-page.patch
15Patch2: quota-3.06-pie.patch
16Patch3: quota-3.13-wrong-ports.patch
17# Bug #667757, submitted to upstream (SF#3152423)
18Patch4: quota-4.00_pre1-Make-RPC-block-factor-dynamic.patch
19# Bug #668691, submitted to upstream (SF#3152423)
20Patch5: quota-4.00_pre1-Check-set-limits-fit-into-the-range-supported-by-RPC.patch
21# Bug #634137, submitted to upstream (SF#3171791)
22Patch6: quota-4.00_pre1-Store-PID-of-quota_nld.patch
23# In upstream after 4.00 (SF#3393151), bug #731622
24Patch7: quota-4.00-Do-not-report-missing-utmp-record-to-syslog.patch
25
26BuildRoot: %{_tmppath}/%{name}-root
27Requires: kernel >= 2.4, initscripts >= 6.38
28Requires(post): chkconfig
29Requires(preun): chkconfig
30Conflicts: nfs-utils < 1.0.1
31BuildRequires: e2fsprogs-devel, gettext
32BuildRequires: tcp_wrappers, nss-devel
33BuildRequires: openldap-devel, openssl-devel, dbus-devel, libnl-devel
34
35
36%description
37The quota package contains system administration tools for monitoring
38and limiting user and or group disk usage per filesystem.
39
40%description -l ja
41quota パッケージには,ユーザやグループのディスク使用量を監視したり
42制限したりできるシステム管理ツールが収録されています.これらの操作
43はファイルシステム単位で行うことが出来ます.
44ユーザやグループのディスク使用量を監視/制限した場合は quota をイン
45ストールして下さい.
46
47
48%prep
49%setup -q -n quota-tools
50%patch0 -p1
51%patch1 -p1
52%ifnarch ppc ppc64
53%patch2 -p1
54%endif
55%patch3 -p1
56%patch4 -p1 -b .rpc_block_factor_dynamic
57%patch5 -p1 -b .check_set_limits_rpc
58%patch6 -p1 -b .store_pid
59%patch7 -p1 -b .suppress_missing_utmp
60
61
62%build
63%configure \
64    --enable-ext2direct=yes \
65    --enable-ldapmail=yes \
66    --enable-netlink=yes \
67    --enable-rootsbin=yes \
68    --enable-rpcsetquota=yes \
69    --enable-strip-binaries=no
70make
71
72
73%install
74rm -fr %{buildroot}
75mkdir -p %{buildroot}/sbin
76mkdir -p %{buildroot}%{_sysconfdir}
77mkdir -p %{buildroot}%{_sbindir}
78mkdir -p %{buildroot}%{_bindir}
79mkdir -p %{buildroot}%{_mandir}/{man1,man3,man8}
80
81make install INSTALL='install -p' ROOTDIR=%{buildroot}
82
83install -m 644 warnquota.conf %{buildroot}%{_sysconfdir}
84
85
86# we don't support XFS yet
87#
88rm -f %{buildroot}%{_sbindir}/quot
89rm -f %{buildroot}%{_sbindir}/xqmstats
90rm -f %{buildroot}%{_mandir}/man8/quot.*
91rm -f %{buildroot}%{_mandir}/man8/xqmstats.*
92ln -s  quotaon.8.gz \
93  %{buildroot}%{_mandir}/man8/quotaoff.8
94ln -s rquotad.8.gz \
95  %{buildroot}%{_mandir}/man8/rpc.rquotad.8
96
97install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/quota_nld
98install -p -m644 -D %{SOURCE2} \
99    $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/quota_nld
100
101%find_lang %{name}
102
103
104%clean
105rm -rf %{buildroot}
106
107%post
108/sbin/chkconfig --add quota_nld
109
110%preun
111if [ $1 = 0 ] ; then
112    /sbin/service quota_nld stop >/dev/null 2>&1
113    /sbin/chkconfig --del quota_nld
114fi
115
116
117%files -f %{name}.lang
118%defattr(-,root,root)
119%doc Changelog doc/ README*
120%config(noreplace) %{_sysconfdir}/warnquota.conf
121%config(noreplace) %{_sysconfdir}/quotagrpadmins
122%config(noreplace) %{_sysconfdir}/quotatab
123%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/quota_nld
124%attr(0755,root,root) %{_initrddir}/quota_nld
125%attr(0755,root,root) /sbin/*
126%attr(0755,root,root) %{_bindir}/*
127%attr(0755,root,root) %{_sbindir}/*
128%{_includedir}/rpcsvc/*
129%attr(0644,root,root) %{_mandir}/man1/*
130%attr(0644,root,root) %{_mandir}/man3/*
131%attr(0644,root,root) %{_mandir}/man8/*
132
133
134%changelog
135* Mon Mar 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.00-1
136- new upstram release
137- add BR: tcp_wrappers, nss-devel, openldap-devel,
138  openssl-devel, dbus-devel, libnl-devel
139
140* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.15-2
141- rebuilt with rpm-4.8.1-3
142
143* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.15-1vl5
144- applied new versioning policy, spec in utf-8
145
146* Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 3.15-0vl1
147- updated quota to 3.15
148
149* Wed Apr 27 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl2
150- oops, removed unnecessary Patch3
151
152* Tue Apr 26 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl1
153- based on 3.12-5, being merged into 3.06-7vl1
154
155  - Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 3.12-5
156  - add URL (bz# 131862)
157
158  - Fri Sep 24 2004 Steve Dickson <SteveD@RedHat.com>
159  - Fixed typos in warnquota.conf patch
160    (bz# 82250 and bz# 83974)
161
162  - Mon Sep 13 2004 Steve Dickson <SteveD@RedHat.com>
163  - upgraded to 3.12
164
165  - Tue Jan 27 2004 Florian La Roche <Florian.LaRoche@redhat.de>
166  - add -pie support
167  - update to 3.10
168
169  - Sat Aug 16 2003  Steve Dickson <SteveD@RedHat.com>
170  - upgraded to 3.0.9
171  - added quota-3.09-root_sbindir.patch
172
173* Sun Feb  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.06-7vl1
174- merged with Vine Linux package (quota-2.00stable-0vl1)
175- based on rawhide release 3.06-7
176 * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
177 - 2.00stable-0vl1
178 - ver.up
179 * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
180 - 2.00pre3-8vl2
181 - added documents
182 * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
183 - 2.00pre3-8vl1
184 - based on 2.00pre3-8 from Rawhide
185 - added Japanese summary and description
186
187* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
188- rebuilt
189
190* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
191- rebuild on all arches
192
193
194* Fri Sep 6 2002 Philip Copeland <bryce@redhat.com> 3.06-5
195- added --with-ext2direct=no to fix #73244
196  without this users with UID's > 65535 will not
197  be able to exist on a quota enabled FS
198
199* Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 3.06-4
200- Man page change. #60108
201
202* Tue Aug 6 2002 Philip Copeland <bryce@redhat.com> 3.06-3
203- Bah, I'd dropped epoch from the spec file but seems
204  we need this if you want to upgrade as the epoch
205  number has precedence over the version/release
206  numbers.
207
208* Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 3.06-2
209- Lets stop the makefile from stripping the
210  binaries as thats rpms job (apparently)
211
212* Mon Jul 01 2002 Philip Copeland <bryce@redhat.com> 3.06-1
213- Ditched the 3.01-pre9 src base for 3.06
214  Rebuilt without any patchs
215
216============================================================
217
218* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
219- automated rebuild
220
221* Thu May 23 2002 Tim Powers <timp@redhat.com>
222- automated rebuild
223
224* Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com>
225- IfArch the badkernelinclude patch for ppc-only.
226- Update to 3.03
227
228* Wed Dec 12 2001 Guy Streeter <streeter@redhat.com>
229- Make #include of kernel header file work on non-x86
230
231* Wed Sep  5 2001 Preston Brown <pbrown@redhat.com>
232- require new initscripts
233
234* Thu Aug 30 2001 Preston Brown <pbrown@redhat.com>
235- fixed bug #52075 (problem with ext2 labels)
236- backup data files off by default in quotacheck, optional backup flag added
237- fix bug where giving a bad directory or device would cause
238  quotaon/quotacheck to simulate "-a" behaviour
239- if a device name (i.e /dev/hda1) is passed, look up the corresponding mount
240  point
241
242* Wed Aug 29 2001 Preston Brown <pbrown@redhat.com>
243- return an error code in more cases in convertquota
244
245* Tue Aug 28 2001 Preston Brown <pbrown@redhat.com>
246- 3.01pre9
247
248* Fri Jul 20 2001 Preston Brown <pbrown@redhat.com>
249- more cleanups on 3.01pre8
250
251* Mon Jul  2 2001 Preston Brown <pbrown@redhat.com>
252- 3.01 version, everything has changed again. :(
253
254* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
255- Bump release + rebuild.
256
257* Fri Mar 30 2001 Preston Brown <pbrown@redhat.com>
258- use rpc.rquotad from here again (#33738)
259
260* Thu Mar 15 2001 Preston Brown <pbrown@redhat.com>
261- enable ALT_FORMAT for edquota
262
263* Tue Mar 13 2001 Preston Brown <pbrown@redhat.com>
264- I broke passing devices on the cmd line.  Fixed.
265
266* Fri Mar 09 2001 Preston Brown <pbrown@redhat.com>
267- quota 3.00 is required by recent kernel 2.4 changes
268- no warnquota included this time, not yet ported
269- quite a bit of work on quotacheck to make is backwards compatible
270- we will likely go back to "quota 2.00" as these projects merge...
271
272* Fri Feb 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
273- use "rm -f" instead of only "rm"
274
275* Wed Feb  7 2001 Preston Brown <pbrown@redhat.com>
276- fix quotacheck man page for -a option (#26380)
277
278* Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
279- 2.00 final, rolls in pretty much all our patches. :)
280- fix reporting of in use dquot entries from quotastats
281- change repquota man page to fix documentation of -v (#10330)
282- include warnquota.conf
283
284* Mon Nov 20 2000 Bill Nottingham <notting@redhat.com>
285- fix ia64 build
286
287* Mon Aug 21 2000 Jeff Johnson <jbj@redhat.com>
288- add LABEL=foo support (#16390).
289
290* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
291- remote NFS quotas with different blocksize converted incorrectly (#11932).
292
293* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
294- automatic rebuild
295
296* Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
297- FHS packaging.
298
299* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
300- apply patch5 (H.J. Lu)
301
302* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
303- fix description
304- man pages are compressed
305
306* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
307- quota 2.00 series
308- removed unnecessary patches
309
310* Thu Aug  5 1999 Jeff Johnson <jbj@redhat.com>
311- fix man page FUD (#4369).
312
313* Thu May 13 1999 Peter Hanecak <hanecak@megaloman.sk>
314- changes to allow non-root users to build too (Makefile patch, %attr)
315
316* Tue Apr 13 1999 Jeff Johnson <jbj@redhat.com>
317- fix for sparc64 quotas (#2147)
318
319* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
320- auto rebuild in the new build environment (release 5)
321
322* Mon Dec 28 1998 Cristian Gafton <gafton@redhat.com>
323- don't install rpc.rquotad - we will use the one from the knfsd package
324  instead
325
326* Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
327- merge ultrapenguin 1.1.9 changes.
328
329* Thu May 07 1998 Prospector System <bugs@redhat.com>
330- translations modified for de, fr, tr
331
332* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
333- removed patch for mntent
334
335* Fri Mar 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
336- updated to quota 1.66
337
338* Tue Jan 13 1998 Erik Troan <ewt@redhat.com>
339- builds rquotad
340- installs rpc.rquotad.8 symlink
341
342* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
343- removed /usr/include/rpcsvc/* from filelist
344- uses a buildroot and %attr
345
346* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
347- built against glibc
348
349* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
350- Moved /usr/sbin/quota to /usr/bin/quota
Note: See TracBrowser for help on using the repository browser.