source: projects/specs/trunk/q/quota/quota-vl.spec @ 12465

Revision 12465, 14.3 KB checked in by tomop, 4 years ago (diff)

updated 4 packages

librsvg2-2.48.8-1

nfs-utils-2.5.1-1

quota-4.05-1

xl2tpd-1.3.15-1

Line 
1%bcond_with systemd
2%bcond_with quota_enables_tcpwrappers
3
4Name: quota
5Summary: System administration tools for monitoring users' disk usage.
6Summary(ja): ユーザのディスク使用量をモニタするシステム管理ツール
7Version: 4.05
8Release: 1%{?_dist_release}%{?with_systemd:.systemd}
9Group: system
10Vendor: Project Vine
11Distribution: Vine Linux
12
13License: BSD
14URL: https://sourceforge.net/projects/linuxquota/
15#Source0: http://downloads.sourceforge.net/linuxquota/quota-%{version}.tar.gz
16Source0: quota-%{version}.tar.gz
17Source1: quota_nld.init
18Source2: quota_nld.sysconfig
19
20Source101: quota_nld.service
21Source103: rpc-rquotad.service
22Source104: rpc-rquotad.sysconfig
23
24# Not accepted changes (378a64006bb1e818e84a1c77808563b802b028fa)
25Patch0: quota-4.04-warnquota-configuration-tunes.patch
26Patch1: quota-4.03-Validate-upper-bound-of-RPC-port.patch
27# Fix modifying CFLAGS and LDFLAGS by pkgconfig, in upstream after 4.05
28Patch2: quota-4.05-Revert-configure.ac-fix-pkg_check_modules-calls.patch
29# 1/6 Report an error if an RPC fails on an explicitly requested file system,
30# <https://sourceforge.net/p/linuxquota/bugs/134/>, in upstream after 4.05
31Patch3: quota-4.05-Make-messages-about-failures-for-NFS-consistent-with.patch
32# 2/6
33Patch4: quota-4.05-quotaops-Do-not-return-partial-list-from-getprivs.patch
34# 3/6
35Patch5: quota-4.05-quotaops-Do-not-leak-dquot-structures-on-failure.patch
36# 4/6
37Patch6: quota-4.05-setquota-Report-failure-to-obtain-quota-information.patch
38# 5/6
39Patch7: quota-4.05-rpc-Clarify-error-message-when-cannot-connect-to-rpc.patch
40# 6/6
41Patch8: quota-4.05-quotaops-Make-error-string-translatable.patch
42# Fix Free Software Foundation's postal address,
43# <https://sourceforge.net/p/linuxquota/bugs/133/>, in upstream after 4.05
44Patch9: quota-4.05-COPYING-Update-mailing-address.patch
45# Move quota_nld.pid file to /run,
46# <https://sourceforge.net/p/linuxquota/patches/49/>, in upstream after 4.05
47Patch10: quota-4.05-Make-a-directory-for-quota_nld-PID-file-configurable.patch
48# Optimize out useless checking of file systems with hidden quota files,
49# in upstream after 4.05
50Patch11: quota-4.05-quotacheck-Skip-checking-of-filesystems-with-hidded-.patch
51# Fix warnquota --help output, in upstream after 4.05
52Patch12: quota-4.05-warnquota-Fix-help-text.patch
53# Fix checking for the LDAP failures in the warnquota tool,
54# in upstream after 4.05
55Patch13: quota-4.05-warnquota-Properly-detect-LDAP-errors.patch
56# 1/2 Report detailed LDAP failures, in upstream after 4.05
57Patch14: quota-4.05-warnquota-Print-also-additional-error-info-for-LDAP-.patch
58# 2/2 Report detailed LDAP failures, in upstream after 4.05,
59# <https://sourceforge.net/p/linuxquota/patches/50/>
60Patch15: quota-4.05-warnquota-Free-LDAP-error-message.patch
61# Document CC_TO in warquota.conf is looked up with LDAP,
62# in upstream after 4.05
63Patch16: quota-4.05-warnquota-Clarify-that-CC_TO-gets-resolved-through-L.patch
64# Initialize all members of a configparams structure in warnquota,
65# in upstream after 4.05, <https://sourceforge.net/p/linuxquota/patches/51/>
66Patch17: quota-4.05-warnquota-Initialize-all-members-of-a-configparams-s.patch
67# Fix ignoring disabled quotas, bug #1805110, in upstream after 4.05,
68# <https://sourceforge.net/p/linuxquota/bugs/136/>
69Patch18: quota-4.05-Fix-ignoring-disabled-quotas.patch
70# Pass quota type for Q_XFS_GETQSTAT, in upstream after 4.05
71Patch19: quota-4.05-quota-tools-pass-quota-type-to-QCMD-for-Q_XFS_GETQST.patch
72# Set kernel option when setting XFS grace times, posted to upstream
73Patch20: quota-4.05-quota-tools-Set-FS_DQ_TIMER_MASK-for-individual-xfs-grace-times.patch
74
75BuildRoot: %{_tmppath}/%{name}-root
76BuildRequires: e2fsprogs-devel, gettext
77BuildRequires: nss-devel
78BuildRequires: openldap-devel, openssl-devel, dbus-devel, libnl3-devel
79BuildRequires: rpcgen
80BuildRequires: pkgconfig(libtirpc)
81%if %{with quota_enables_tcpwrappers}
82BuildRequires: tcp_wrappers
83Requires: tcp_wrappers
84%endif
85Conflicts: nfs-utils < 1.0.1
86%if %{with systemd}
87BuildRequires:  systemd
88Requires: kernel >= 4.0
89%{?systemd_requires}
90%else
91Requires: kernel >= 4.0, initscripts >= 6.38
92Requires(post): chkconfig
93Requires(preun): chkconfig
94%endif
95
96%description
97The quota package contains system administration tools for monitoring
98and limiting user and or group disk usage per filesystem.
99
100%description -l ja
101quota パッケージには,ユーザやグループのディスク使用量を監視したり
102制限したりできるシステム管理ツールが収録されています.これらの操作
103はファイルシステム単位で行うことが出来ます.
104ユーザやグループのディスク使用量を監視/制限した場合は quota をイン
105ストールして下さい.
106
107
108%prep
109%setup -q
110%autopatch -p1
111# Regenerate build scripts
112autoreconf -f -i
113
114
115%build
116%configure \
117    --enable-bsd-behaviour \
118    --enable-ext2direct=yes \
119    --enable-ldapmail=yes \
120%if %{with quota_enables_tcpwrappers}
121    --enable-libwrap=yes \
122%else
123    --disable-libwrap \
124%endif
125    --enable-netlink=yes \
126    --enable-nls \
127    --with-pid-dir=/run \
128    --disable-rpath \
129    --enable-rpc=yes \
130    --enable-rpcsetquota=yes \
131    --disable-silent-rules \
132    --disable-xfs-roothack \
133    --enable-rootsbin=yes \
134    --enable-strip-binaries=no
135make %{?_smp_mflags}
136
137
138%install
139rm -fr %{buildroot}
140mkdir -p %{buildroot}/sbin
141mkdir -p %{buildroot}%{_sysconfdir}
142mkdir -p %{buildroot}%{_sbindir}
143mkdir -p %{buildroot}%{_bindir}
144mkdir -p %{buildroot}%{_mandir}/{man1,man3,man8}
145
146make install DESTDIR=%{buildroot}
147rm -rf %{buildroot}%{_datadir}/doc/%{name}
148
149install -p -m644 -D %{SOURCE2} \
150    $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/quota_nld
151install -m 644 warnquota.conf %{buildroot}%{_sysconfdir}
152%if %{with systemd}
153install -p -m644 -D %{SOURCE101} $RPM_BUILD_ROOT%{_unitdir}/quota_nld.service
154install -p -m644 -D %{SOURCE103} $RPM_BUILD_ROOT%{_unitdir}/rpc-rquotad.service
155install -p -m644 -D %{SOURCE104} \
156    $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rpc-rquotad
157%else
158install -p -m755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/quota_nld
159%endif
160
161mv %{buildroot}%{_sbindir}/quota{check,off,on} %{buildroot}/sbin/
162
163%find_lang %{name}
164
165
166%check
167make check
168
169
170%clean
171rm -rf %{buildroot}
172
173
174%post
175%if %{with systemd}
176%systemd_post quota_nld.service
177%systemd_post rpc-rquotad.service
178%else
179/sbin/chkconfig --add quota_nld
180%endif
181
182%preun
183%if %{with systemd}
184%systemd_preun quota_nld.service
185%systemd_preun rpc-rquotad.service
186%else
187if [ $1 = 0 -o -x /bin/systemctl ] ; then
188    /sbin/service quota_nld stop >/dev/null 2>&1
189    /sbin/chkconfig --del quota_nld
190fi
191%endif
192
193%if %{with systemd}
194%postun
195%systemd_postun_with_restart quota_nld.service
196%systemd_postun_with_restart rpc-rquotad.service
197%endif
198
199
200%files -f %{name}.lang
201%defattr(-,root,root)
202%license COPYING
203%doc Changelog doc/ README*
204%config(noreplace) %{_sysconfdir}/warnquota.conf
205%config(noreplace) %{_sysconfdir}/quotagrpadmins
206%config(noreplace) %{_sysconfdir}/quotatab
207/sbin/*
208%{_bindir}/*
209%{_sbindir}/*
210%{_includedir}/rpcsvc/*
211%{_mandir}/man1/*
212%{_mandir}/man3/*
213%{_mandir}/man5/*
214%{_mandir}/man8/*
215%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/quota_nld
216%if %{with systemd}
217%{_unitdir}/quota_nld.service
218%{_unitdir}/rpc-rquotad.service
219%config(noreplace) %{_sysconfdir}/sysconfig/rpc-rquotad
220%else
221%{_initrddir}/quota_nld
222%endif
223
224
225%changelog
226* Thu Aug 13 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.05-1
227- new upstram release.
228- updated all patches.
229- disabled tcp_wrappers as default.
230- added systemd support (disabled as default).
231
232* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.04-1
233- new upstram release.
234- dropped BR:libnl-devel.
235- added BR:libnl3-devel.
236- dropped all patches.
237- imported patched from rawhide.
238
239* Mon Mar 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.00-1
240- new upstram release
241- add BR: tcp_wrappers, nss-devel, openldap-devel,
242  openssl-devel, dbus-devel, libnl-devel
243
244* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.15-2
245- rebuilt with rpm-4.8.1-3
246
247* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.15-1vl5
248- applied new versioning policy, spec in utf-8
249
250* Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 3.15-0vl1
251- updated quota to 3.15
252
253* Wed Apr 27 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl2
254- oops, removed unnecessary Patch3
255
256* Tue Apr 26 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12-5vl1
257- based on 3.12-5, being merged into 3.06-7vl1
258
259  - Sun Sep 26 2004 Rik van Riel <riel@redhat.com> 3.12-5
260  - add URL (bz# 131862)
261
262  - Fri Sep 24 2004 Steve Dickson <SteveD@RedHat.com>
263  - Fixed typos in warnquota.conf patch
264    (bz# 82250 and bz# 83974)
265
266  - Mon Sep 13 2004 Steve Dickson <SteveD@RedHat.com>
267  - upgraded to 3.12
268
269  - Tue Jan 27 2004 Florian La Roche <Florian.LaRoche@redhat.de>
270  - add -pie support
271  - update to 3.10
272
273  - Sat Aug 16 2003  Steve Dickson <SteveD@RedHat.com>
274  - upgraded to 3.0.9
275  - added quota-3.09-root_sbindir.patch
276
277* Sun Feb  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.06-7vl1
278- merged with Vine Linux package (quota-2.00stable-0vl1)
279- based on rawhide release 3.06-7
280 * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
281 - 2.00stable-0vl1
282 - ver.up
283 * Wed May 30 2001 Jun Nishii <jun@vinelinux.org>
284 - 2.00pre3-8vl2
285 - added documents
286 * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
287 - 2.00pre3-8vl1
288 - based on 2.00pre3-8 from Rawhide
289 - added Japanese summary and description
290
291* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
292- rebuilt
293
294* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
295- rebuild on all arches
296
297
298* Fri Sep 6 2002 Philip Copeland <bryce@redhat.com> 3.06-5
299- added --with-ext2direct=no to fix #73244
300  without this users with UID's > 65535 will not
301  be able to exist on a quota enabled FS
302
303* Wed Aug 7 2002 Philip Copeland <bryce@redhat.com> 3.06-4
304- Man page change. #60108
305
306* Tue Aug 6 2002 Philip Copeland <bryce@redhat.com> 3.06-3
307- Bah, I'd dropped epoch from the spec file but seems
308  we need this if you want to upgrade as the epoch
309  number has precedence over the version/release
310  numbers.
311
312* Wed Jul 17 2002 Philip Copeland <bryce@redhat.com> 3.06-2
313- Lets stop the makefile from stripping the
314  binaries as thats rpms job (apparently)
315
316* Mon Jul 01 2002 Philip Copeland <bryce@redhat.com> 3.06-1
317- Ditched the 3.01-pre9 src base for 3.06
318  Rebuilt without any patchs
319
320============================================================
321
322* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
323- automated rebuild
324
325* Thu May 23 2002 Tim Powers <timp@redhat.com>
326- automated rebuild
327
328* Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com>
329- IfArch the badkernelinclude patch for ppc-only.
330- Update to 3.03
331
332* Wed Dec 12 2001 Guy Streeter <streeter@redhat.com>
333- Make #include of kernel header file work on non-x86
334
335* Wed Sep  5 2001 Preston Brown <pbrown@redhat.com>
336- require new initscripts
337
338* Thu Aug 30 2001 Preston Brown <pbrown@redhat.com>
339- fixed bug #52075 (problem with ext2 labels)
340- backup data files off by default in quotacheck, optional backup flag added
341- fix bug where giving a bad directory or device would cause
342  quotaon/quotacheck to simulate "-a" behaviour
343- if a device name (i.e /dev/hda1) is passed, look up the corresponding mount
344  point
345
346* Wed Aug 29 2001 Preston Brown <pbrown@redhat.com>
347- return an error code in more cases in convertquota
348
349* Tue Aug 28 2001 Preston Brown <pbrown@redhat.com>
350- 3.01pre9
351
352* Fri Jul 20 2001 Preston Brown <pbrown@redhat.com>
353- more cleanups on 3.01pre8
354
355* Mon Jul  2 2001 Preston Brown <pbrown@redhat.com>
356- 3.01 version, everything has changed again. :(
357
358* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
359- Bump release + rebuild.
360
361* Fri Mar 30 2001 Preston Brown <pbrown@redhat.com>
362- use rpc.rquotad from here again (#33738)
363
364* Thu Mar 15 2001 Preston Brown <pbrown@redhat.com>
365- enable ALT_FORMAT for edquota
366
367* Tue Mar 13 2001 Preston Brown <pbrown@redhat.com>
368- I broke passing devices on the cmd line.  Fixed.
369
370* Fri Mar 09 2001 Preston Brown <pbrown@redhat.com>
371- quota 3.00 is required by recent kernel 2.4 changes
372- no warnquota included this time, not yet ported
373- quite a bit of work on quotacheck to make is backwards compatible
374- we will likely go back to "quota 2.00" as these projects merge...
375
376* Fri Feb 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
377- use "rm -f" instead of only "rm"
378
379* Wed Feb  7 2001 Preston Brown <pbrown@redhat.com>
380- fix quotacheck man page for -a option (#26380)
381
382* Thu Feb  1 2001 Preston Brown <pbrown@redhat.com>
383- 2.00 final, rolls in pretty much all our patches. :)
384- fix reporting of in use dquot entries from quotastats
385- change repquota man page to fix documentation of -v (#10330)
386- include warnquota.conf
387
388* Mon Nov 20 2000 Bill Nottingham <notting@redhat.com>
389- fix ia64 build
390
391* Mon Aug 21 2000 Jeff Johnson <jbj@redhat.com>
392- add LABEL=foo support (#16390).
393
394* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
395- remote NFS quotas with different blocksize converted incorrectly (#11932).
396
397* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
398- automatic rebuild
399
400* Thu Jun 15 2000 Jeff Johnson <jbj@redhat.com>
401- FHS packaging.
402
403* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
404- apply patch5 (H.J. Lu)
405
406* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
407- fix description
408- man pages are compressed
409
410* Tue Jan 18 2000 Preston Brown <pbrown@redhat.com>
411- quota 2.00 series
412- removed unnecessary patches
413
414* Thu Aug  5 1999 Jeff Johnson <jbj@redhat.com>
415- fix man page FUD (#4369).
416
417* Thu May 13 1999 Peter Hanecak <hanecak@megaloman.sk>
418- changes to allow non-root users to build too (Makefile patch, %attr)
419
420* Tue Apr 13 1999 Jeff Johnson <jbj@redhat.com>
421- fix for sparc64 quotas (#2147)
422
423* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
424- auto rebuild in the new build environment (release 5)
425
426* Mon Dec 28 1998 Cristian Gafton <gafton@redhat.com>
427- don't install rpc.rquotad - we will use the one from the knfsd package
428  instead
429
430* Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
431- merge ultrapenguin 1.1.9 changes.
432
433* Thu May 07 1998 Prospector System <bugs@redhat.com>
434- translations modified for de, fr, tr
435
436* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
437- removed patch for mntent
438
439* Fri Mar 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
440- updated to quota 1.66
441
442* Tue Jan 13 1998 Erik Troan <ewt@redhat.com>
443- builds rquotad
444- installs rpc.rquotad.8 symlink
445
446* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
447- removed /usr/include/rpcsvc/* from filelist
448- uses a buildroot and %attr
449
450* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
451- built against glibc
452
453* Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
454- Moved /usr/sbin/quota to /usr/bin/quota
Note: See TracBrowser for help on using the repository browser.