source: projects/specs/trunk/q/qtsoap/qtsoap-vl.spec @ 9346

Revision 9346, 2.9 KB checked in by inagaki, 9 years ago (diff)

2015-02-09 Ryoichi INAGAKI <ryo1@…>

  • qca-ossl, qimageblitz, qoauth, qt-assistant-adp, qtsoap: rebuilt
  • qca2: added patch


RevLine 
[9346]1%define _qt4_ver 4.8.6
[4445]2%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
[5383]3%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
[4445]4%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
5
6Name:           qtsoap
7Summary:        The Simple Object Access Protocol Qt-based client side library
[9346]8Summary(ja):    Qt ベースの SOAP クライアントライブラリ
[4445]9Version:        2.7
[9346]10Release:        5%{?_dist_release}
[4445]11
12Group:          System Environment/Libraries
13License:        LGPLv2 with exceptions or GPLv3
14URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsoap/
15
16Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/qtsoap-%{version}_1-opensource.tar.gz
17Patch0:         qtsoap-2.7_1-opensource-install-pub-headers.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildRequires:  qt4-devel
21
22%description
23The SOAP (Simple Object Access Protocol) library uses the XML standard
24for describing how to exchange messages. Its primary usage is to invoke web
25services and get responses from Qt-based applications.
26
27%package        devel
28Summary:        Development files for %{name}
[5383]29Summary(ja):    %{name} の開発用ファイル
[4445]30Group:          Development/Libraries
31Requires:       %{name} = %{version}-%{release}
[5383]32Requires:       qt4-devel >= %{_qt4_version}
[4445]33
34%description    devel
35Development files for %{name}.
36
37%prep
38%setup -q -n qtsoap-%{version}_1-opensource
39
40# headers are not installed for shared library
41%patch0 -p1 -b .install-pub-headers
42
43sed -i 's:$$DESTDIR:%{_libdir}:g' buildlib/buildlib.pro
44
45%build
46# we want shared library
47echo "SOLUTIONS_LIBRARY = yes" > config.pri
48
49echo "QTSOAP_LIBNAME = \$\$qtLibraryTarget(qtsoap)" >> common.pri
50echo "VERSION=%{version}" >> common.pri
51
52qmake PREFIX=%{_prefix}
53make %{?_smp_mflags}
54
55
56%install
57rm -rf %{buildroot}
58make INSTALL_ROOT=%{buildroot} install
59
60
61%clean
62rm -rf %{buildroot}
63
64
65%post -p /sbin/ldconfig
66
67%postun -p /sbin/ldconfig
68
69
70%files
71%defattr(-,root,root,-)
72%doc README.TXT LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
73%{_libdir}/libqtsoap.so.*
74
75%files devel
76%defattr(-,root,root,-)
77%doc LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
78%{_libdir}/libqtsoap.so
79%{_qt4_headerdir}/QtSoap/
80
81%changelog
[9346]82* Mon Feb  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7-5
83- rebuilt on current VineSeed
84- added Japanese summary
85
[5383]86* Sun Jan  8 2012 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 2.7-4
87- rebuilt with qt-4.8.0
88
[4445]89* Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.7-3
90- Initial build for Vine Linux
91
92* Thu Jul 14 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-2
93- libqtsoap library name
94
95* Thu May 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-1
96- fix version
97
98* Tue Oct 26 2010 Jaroslav Reznik <jreznik@redhat.com> - 1.7-1
[5383]99- Initial spec file
Note: See TracBrowser for help on using the repository browser.