source: projects/specs/trunk/q/qtsingleapplication/qtsingleapplication-vl.spec @ 10570

Revision 10570, 7.0 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1# Upstream uses weird versioning convention
2%global upstreamver 2.6_1-opensource
3
4Summary:        Qt library to start applications only once per user
5Name:           qtsingleapplication
6Version:        2.6.1
7Release:        10%{?_dist_release}
8Group:          System Environment/Libraries
9License:        GPLv3 or LGPLv2 with exceptions
10URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsingleapplication
11Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/qtsingleapplication-%{upstreamver}.tar.gz
12# The following source and 2 patches are sent upstream:
13# http://bugreports.qt.nokia.com/browse/QTSOLBUG-119
14# To add qmake support for convenience for packages using this library:
15Source1:        qtsingleapplication.prf
16Source2:        qtsinglecoreapplication.prf
17# Don't build examples, Include qtsinglecoreapplication library in the build:
18Patch0:         qtsingleapplication-build.diff
19# The library includes a duplicate of qtlockedfile. We link to it dynamically instead:
20Patch1:         qtsingleapplication-dont-bundle-external-libs.patch
21# Additional API for building clementine
22# http://bugreports.qt.nokia.com/browse/QTSOLBUG-133
23Patch2:         qtsingleapplication-add-api.patch
24# gcc-4.7 compilation fix
25Patch3:         qtsingleapplication-gcc47.patch
26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
27BuildRequires:  qt4-devel
28BuildRequires:  qtlockedfile-devel
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: shaolin
33
34%{?_qt4_version:Requires: qt4%{?_isa} >= %{_qt4_version}}
35
36%description
37For some applications it is useful or even critical that they are started
38only once by any user. Future attempts to start the application should
39activate any already running instance, and possibly perform requested
40actions, e.g. loading a file, in that instance.
41
42The QtSingleApplication class provides an interface to detect a running
43instance, and to send command strings to that instance.
44
45%package        devel
46Summary:        Development files for %{name}
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49Requires:       qt4-devel
50
51%description    devel
52This package contains libraries and header files for developing applications
53that use QtSingleApplication.
54
55%package -n qtsinglecoreapplication
56Summary:        Qt library to start applications only once per user
57Group:          System Environment/Libraries
58Obsoletes:      %{name} < 2.6.1-3
59
60%description -n qtsinglecoreapplication
61For some applications it is useful or even critical that they are started
62only once by any user. Future attempts to start the application should
63activate any already running instance, and possibly perform requested
64actions, e.g. loading a file, in that instance.
65
66For console (non-GUI) applications, the QtSingleCoreApplication variant
67is provided, which avoids dependency on QtGui.
68
69%package -n qtsinglecoreapplication-devel
70Summary:        Development files for qtsinglecoreapplication
71Group:          Development/Libraries
72Obsoletes:      %{name}-devel < 2.6.1-3
73Requires:       qtsinglecoreapplication = %{version}-%{release}
74Requires:       qt4-devel
75
76%description -n qtsinglecoreapplication-devel
77This package contains libraries and header files for developing applications
78that use QtSingleCoreApplication.
79
80%prep
81%setup -q -n %{name}-%{upstreamver}
82%patch0 -p1
83%patch1 -p1
84%patch2 -p1
85%patch3 -p1
86
87# We already disabled bundling this extrenal library.
88# But just to make sure:
89rm src/{QtLocked,qtlocked}*
90
91
92%build
93touch .licenseAccepted
94# Does not use GNU configure
95./configure -library
96%{_qt4_qmake}
97make %{?_smp_mflags}
98
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
103# libraries
104mkdir -p $RPM_BUILD_ROOT%{_qt4_libdir}
105cp -a lib/* $RPM_BUILD_ROOT%{_qt4_libdir}
106chmod 755 $RPM_BUILD_ROOT%{_qt4_libdir}/*.so.*.*.*
107
108# headers
109mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}/QtSolutions
110cp -a \
111    src/qtsingleapplication.h \
112    src/QtSingleApplication \
113    src/qtsinglecoreapplication.h \
114    src/QtSingleCoreApplication \
115    $RPM_BUILD_ROOT%{_qt4_headerdir}/QtSolutions
116
117mkdir -p $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
118cp -a %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127%post -n qtsinglecoreapplication -p /sbin/ldconfig
128
129%postun -n qtsinglecoreapplication -p /sbin/ldconfig
130
131%files
132%defattr(-,root,root,-)
133%doc LGPL_EXCEPTION.txt LICENSE.* README.TXT
134%{_qt4_libdir}/lib*SingleApplication*.so.*
135
136%files devel
137%defattr(-,root,root,-)
138%doc doc examples
139%{_qt4_libdir}/lib*SingleApplication*.so
140%dir %{_qt4_headerdir}/QtSolutions/
141%{_qt4_headerdir}/QtSolutions/QtSingleApplication
142%{_qt4_headerdir}/QtSolutions/%{name}.h
143%{_qt4_datadir}/mkspecs/features/%{name}.prf
144
145%files -n qtsinglecoreapplication
146%defattr(-,root,root,-)
147%doc LGPL_EXCEPTION.txt LICENSE.*
148%{_qt4_libdir}/lib*SingleCoreApplication*.so.*
149
150%files -n qtsinglecoreapplication-devel
151%defattr(-,root,root,-)
152%{_qt4_libdir}/lib*SingleCoreApplication*.so
153%dir %{_qt4_headerdir}/QtSolutions/
154%{_qt4_headerdir}/QtSolutions/QtSingleCoreApplication
155%{_qt4_headerdir}/QtSolutions/qtsinglecoreapplication.h
156%{_qt4_datadir}/mkspecs/features/qtsinglecoreapplication.prf
157
158%changelog
159* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.6.1-10
160- rebuild with gcc-5.4.0
161
162* Thu Jan  9 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.1-9
163- initial build for Vine Linux
164
165* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-9
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
167
168* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-8
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
170
171* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-7
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
173
174* Wed Jan 11 2012 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-6
175- gcc-4.7 compilation fix
176
177* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.1-5
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
179
180* Wed Aug 11 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-4
181- Make the additional API patch backwards compatible
182
183* Wed Jul 21 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-3
184- Split the qtsinglecoreapplication bits into their own subpackages
185
186* Fri Jul 16 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-2
187- Add additional API to support clementine.
188
189* Sun Jun 06 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6.1-1
190- Change version to 2.6.1. Upstream uses weird version convention 2.6_1
191- Own the directory %%{_qt4_headerdir}/QtSolutions/
192
193* Sat May 01 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6-3
194- Add comments to the extra source and patches
195- Add a chmod 755 to make sure that the library gets the right permission
196
197* Thu Apr 15 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6-2
198- Include .prf file
199- Don't bundle external qtlockedfile library
200- Fix typo in the description
201
202* Sun Apr 11 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.6-1
203- Initial Fedora package. Specfile partly borrowed from opensuse
204
205* Thu Dec  3 2009 Todor Prokopov <koprok@nand.bg>
206- Initial package.
Note: See TracBrowser for help on using the repository browser.