source: projects/specs/trunk/q/qtlockedfile/qtlockedfile-vl.spec @ 10570

Revision 10570, 3.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Summary:        QFile extension with advisory locking functions
2Name:           qtlockedfile
3Version:        2.4
4Release:        8%{?_dist_release}
5Group:          System Environment/Libraries
6License:        GPLv3 or LGPLv2 with exceptions
7URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtlockedfile
8Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/%{name}-%{version}_1-opensource.tar.gz
9Source1:        qtlockedfile.prf
10Patch0:         qtlockedfile-dont-build-example.patch
11# Remove unnecessary linkage to libQtGui
12Patch1:         qtlockedfile-dont-link-qtgui.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14BuildRequires:  qt4-devel
15%{?_qt4_version:Requires: qt4%{?_isa} >= %{_qt4_version}}
16
17Vendor: Project Vine
18Distribution: Vine Linux
19Packager: shaolin
20
21%description
22This class extends the QFile class with inter-process file locking capabilities.
23If an application requires that several processes should access the same file,
24QtLockedFile can be used to easily ensure that only one process at a time is
25writing to the file, and that no process is writing to it while others are
26reading it.
27
28%package        devel
29Summary:        Development files for %{name}
30Group:          Development/Libraries
31Requires:       %{name} = %{version}-%{release}
32Requires:       qt4-devel
33
34%description    devel
35This package contains libraries and header files for developing applications
36that use QtLockedFile.
37
38%prep
39%setup -q -n %{name}-%{version}_1-opensource
40%patch0 -p1 -b .no-example
41%patch1 -p1 -b .dont-link-qtgui
42
43
44%build
45touch .licenseAccepted
46# Does not use GNU configure
47./configure -library
48%{_qt4_qmake}
49make %{?_smp_mflags}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54# libraries
55mkdir -p $RPM_BUILD_ROOT%{_qt4_libdir}
56cp -a lib/* $RPM_BUILD_ROOT%{_qt4_libdir}
57
58# headers
59mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}/QtSolutions
60cp -a \
61    src/qtlockedfile.h \
62    src/QtLockedFile \
63    $RPM_BUILD_ROOT%{_qt4_headerdir}/QtSolutions
64
65mkdir -p $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features
66cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72
73%postun -p /sbin/ldconfig
74
75
76%files
77%defattr(-,root,root,-)
78%doc LGPL_EXCEPTION.txt LICENSE.* README.TXT
79%{_qt4_libdir}/lib*.so.*
80
81%files devel
82%defattr(-,root,root,-)
83%doc doc example
84%{_qt4_libdir}/lib*.so
85%{_qt4_headerdir}/QtSolutions/
86%{_qt4_datadir}/mkspecs/features/%{name}.prf
87
88%changelog
89* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4-8
90- rebuild with gcc-5.4.0
91
92* Thu Jan  9 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-7
93- initial build for Vine Linux
94
95* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-7
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
97
98* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-6
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
100
101* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-5
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
103
104* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-4
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
106
107* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-3
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Fri Apr 16 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.4-2
111- Remove unnecessary linkage to libQtGui
112
113* Thu Apr 15 2010 Orcan Ogetbil <oget[dot]fedora[at]gmail[dot]com> 2.4-1
114- Initial Fedora package.
Note: See TracBrowser for help on using the repository browser.