source: projects/specs/trunk/q/qt5-qtwebkit/qt5-qtwebkit-vl.spec @ 11435

Revision 11435, 14.0 KB checked in by tomop, 6 years ago (diff)

updated Qt5

Line 
1
2%global qt_module qtwebkit
3
4%global _hardened_build 1
5
6#global bootstrap 1
7
8%define _unpackaged_files_terminate_build 1
9
10# define to build docs, need to undef this for bootstrapping
11# where qt5-qttools builds are not yet available
12# only primary archs (for now), allow secondary to bootstrap
13%if ! 0%{?bootstrap}
14%ifarch %{arm} %{ix86} x86_64
15%define docs 1
16%endif
17%endif
18
19#global commit0 b889f460280ad98c89ede179bd3b9ce9cb02002b
20#global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
21
22Summary: Qt5 - QtWebKit components
23Name:    qt5-qtwebkit
24Version: 5.6.3
25Release: 1%{?shortcommit0:.%{shortcommit0}git}%{?_dist_release}
26
27# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
28# See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
29License: LGPLv2 with exceptions or GPLv3 with exceptions
30Url: http://www.qt.io
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%if 0%{?commit0:1}
36# The source for this package was pulled from upstream's vcs.  Use the
37# following commands to generate the tarball:
38# git clone git@github.com:qtproject/qtqebkit.git && cd qtwebkit
39# git archive --prefix=qtwebkit-opensource-src-5.6.1/ origin/5.6.1 | tar -x -C ..
40# cd ../qtwebkit-opensource-src-5.6.1 && syncqt.pl -version 5.6.1 Source/sync.profile && cd ..
41# tar cfJ qt5-webkit-opensource-src-5.6.1.tar.xz qtwebkit-opensource-src-5.6.1/
42Source0: %{qt_module}-opensource-src-%{version}-%{shortcommit0}.tar.xz
43%else
44Source0: http://download.qt.io/community_releases/5.6/%{version}/qtwebkit-opensource-src-%{version}.tar.xz
45%endif
46
47## downstream patches
48# Search /usr/lib{,64}/mozilla/plugins-wrapped for browser plugins too
49Patch1: qtwebkit-opensource-src-5.2.0-pluginpath.patch
50
51# smaller debuginfo s/-g/-g1/ (debian uses -gstabs) to avoid 4gb size limit
52Patch3: qtwebkit-opensource-src-5.0.1-debuginfo.patch
53
54# tweak linker flags to minimize memory usage on "small" platforms
55Patch4: qtwebkit-opensource-src-5.2.0-save_memory.patch
56
57# Add AArch64 support
58Patch7: 0001-Add-ARM-64-support.patch
59
60# truly madly deeply no rpath please, kthxbye
61Patch8: qtwebkit-opensource-src-5.2.1-no_rpath.patch
62
63## upstream patches
64
65
66# to build with icu >= 59
67Patch1000: qtwebkit-5.9.0-icu_59-1.patch
68
69BuildRequires: cmake
70BuildRequires: qt5-qtbase-devel >= %{version}
71BuildRequires: qt5-qtdeclarative-devel >= %{version}
72%if ! 0%{?bootstrap}
73BuildRequires: qt5-qtsensors-devel
74BuildRequires: qt5-qtlocation-devel
75BuildRequires: qt5-qtwebchannel-devel
76%endif
77BuildRequires: bison
78BuildRequires: flex
79BuildRequires: gperf
80BuildRequires: libicu-devel
81BuildRequires: libjpeg-devel
82BuildRequires: pkgconfig(gio-2.0) pkgconfig(glib-2.0)
83BuildRequires: pkgconfig(fontconfig)
84BuildRequires: pkgconfig(gl)
85# gstreamer media support
86BuildRequires: pkgconfig(gstreamer-1.0) pkgconfig(gstreamer-app-1.0)
87BuildRequires: pkgconfig(libpng)
88BuildRequires: pkgconfig(libpcre)
89BuildRequires: pkgconfig(libudev)
90BuildRequires: pkgconfig(libwebp)
91BuildRequires: pkgconfig(libxslt)
92BuildRequires: pkgconfig(sqlite3)
93BuildRequires: pkgconfig(xcomposite) pkgconfig(xrender)
94BuildRequires: perl perl(version)
95BuildRequires: perl(Digest::MD5) perl(Text::ParseWords) perl(Getopt::Long)
96BuildRequires: ruby ruby-rubygems
97BuildRequires: zlib-devel
98
99BuildRequires:  qt5-qtbase-private-devel
100%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
101BuildRequires:  qt5-qtdeclarative-private-devel
102%{?_qt5:Requires: qt5-qtdeclarative%{?_isa} = %{_qt5_version}}
103
104
105%description
106%{summary}
107
108%package devel
109Summary: Development files for %{name}
110Requires: %{name}%{?_isa} = %{version}-%{release}
111Requires: qt5-qtbase-devel%{?_isa}
112Requires: qt5-qtdeclarative-devel%{?_isa}
113%description devel
114%{summary}.
115
116%if 0%{?docs}
117%package doc
118Summary: API documentation for %{name}
119BuildRequires: qt5-qdoc
120BuildRequires: qt5-qhelpgenerator
121BuildArch: noarch
122%description doc
123%{summary}.
124%endif
125
126
127%prep
128%setup -q -n %{qt_module}-opensource-src-%{version}
129
130%patch1 -p1 -b .pluginpath
131%patch3 -p1 -b .debuginfo
132%patch4 -p1 -b .save_memory
133%patch7 -p1 -b .aarch64
134%patch8 -p1 -b .no_rpath
135
136%patch1000 -p1 -b .icu59
137
138echo "nuke bundled code..."
139# nuke bundled code
140mkdir Source/ThirdParty/orig
141mv Source/ThirdParty/{gtest/,qunit/} \
142   Source/ThirdParty/orig/
143
144if [ ! -d include ]; then
145syncqt.pl -version %{version} Source/sync.profile
146fi
147
148
149%build
150mkdir %{_target_platform}
151pushd %{_target_platform}
152
153%{qmake_qt5} .. \
154%ifnarch %{arm} %{ix86} x86_64
155        DEFINES+=ENABLE_JIT=0 DEFINES+=ENABLE_YARR_JIT=0
156%endif
157
158# workaround, disable parallel compilation as it fails to compile in brew
159#make -j3
160make %{?_smp_mflags}
161
162%if 0%{?docs}
163make %{?_smp_mflags} docs
164%endif
165popd
166
167
168%install
169make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
170
171%if 0%{?docs}
172make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
173%endif
174
175## .prl/.la file love
176# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
177pushd %{buildroot}%{_qt5_libdir}
178for prl_file in libQt5*.prl ; do
179  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
180  if [ -f "$(basename ${prl_file} .prl).so" ]; then
181    rm -fv "$(basename ${prl_file} .prl).la"
182    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
183  fi
184done
185popd
186
187%post
188/sbin/ldconfig
189
190%postun
191/sbin/ldconfig
192
193%files
194%license Source/WebCore/LICENSE*
195%doc ChangeLog* VERSION
196%{_qt5_libdir}/libQt5WebKit.so.5*
197%{_qt5_libdir}/libQt5WebKitWidgets.so.5*
198%{_qt5_libexecdir}/QtWebPluginProcess
199%{_qt5_libexecdir}/QtWebProcess
200%{_qt5_archdatadir}/qml/QtWebKit/
201
202%files devel
203%{_qt5_headerdir}/Qt*/
204%{_qt5_libdir}/libQt5*.so
205%{_qt5_libdir}/libQt5*.prl
206%{_qt5_libdir}/cmake/Qt5*/
207%{_qt5_libdir}/pkgconfig/Qt5*.pc
208%{_qt5_archdatadir}/mkspecs/modules/*.pri
209
210%if 0%{?docs}
211%files doc
212%{_qt5_docdir}/qtwebkit.qch
213%{_qt5_docdir}/qtwebkit/
214%endif
215
216
217%changelog
218* Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
219- new upstream release.
220
221* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1-4.b889f46git
222- initial build for Vine Linux.
223
224* Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3.b889f46git
225- drop pkgconfig-style deps
226
227* Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2.b889f46git
228- rebuild (glibc)
229
230* Thu Jun 09 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-1.b889f46git
231- 5.6.1 branch snapshot, plus a couple post-5.6.1 5.6 branch fixes
232
233* Thu Jun 09 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-9
234- rebuild (qtbase)
235
236* Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
237- use pristine upstream (community) sources
238
239* Wed Apr 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
240- rebuild (icu)
241
242* Sun Apr 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-6
243- BR: qt5-qtbase-private-devel qt5-qtdeclarative-private-devel
244
245* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
246- rebuild for ICU 57.1
247
248* Wed Apr  6 2016 Peter Robinson <pbrobinson@fedoraproject.org> 5.6.0-4
249- Update ruby deps to ensure all bits are present
250
251* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
252- rebuild
253
254* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
255- rebuild
256
257* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
258- 5.6.0 final release
259
260* Mon Feb 29 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.12.rc
261- fix sources
262
263* Wed Feb 24 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.11.rc
264- Fix the trap caused by rpmdev-bumpspec
265
266* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10.rc
267- Update to final RC
268
269* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.9
270- Update RC release
271
272* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.8
273- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
274
275* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.7
276- BR: cmake, use %%license
277
278* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 5.6.0-0.6
279- Rebuilt for libwebp soname bump
280
281* Sun Dec 13 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
282- Update beta code
283
284* Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.4
285- restore bootstrap macro, omit more optional BR's/features in bootstrap mode
286- drop (unused) system_angle support
287- include -qdoc builddep only in -doc subpkg
288
289* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
290- Official beta release
291
292* Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
293- (re)add bootstrap macro support
294
295* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
296- Start to implement 5.6.0 beta
297
298* Wed Oct 28 2015 David Tardon <dtardon@redhat.com> - 5.5.1-4
299- rebuild for ICU 56.1
300
301* Fri Oct 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-3
302- drop (unused) system_angle support/patches
303
304* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
305- Update to final release 5.5.1
306
307* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
308- Update to Qt 5.5.1 RC1
309
310* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-4
311- -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
312
313* Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
314- tighten deps (#1233829)
315
316* Mon Jul 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.5.0-2
317- add 5.5.0-1 changelog
318- BR: qt5-qtwebchannel-devel
319- (re)enable docs
320
321* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
322- New final upstream release Qt 5.5.0
323
324* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
325- Update for official RC1 released packages
326
327* Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
328- 5.4.2
329
330* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-6
331- Rebuilt for GCC 5 C++11 ABI change
332
333* Fri Apr 03 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-5
334- -doc: drop dep on main pkg, not strictly required
335
336* Mon Mar 23 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-4
337- QtWebKit logs visited URLs to WebpageIcons.db in private browsing mode (#1204795,#1204798)
338
339* Wed Mar 18 2015 Than Ngo <than@redhat.com> - 5.4.1-3
340- fix build failure with new gcc5
341
342* Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
343- rebuild (gcc5)
344
345* Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
346- 5.4.1
347
348* Tue Feb 17 2015 Than Ngo <than@redhat.com> 5.4.0-4
349- fix GMutexLocker build problem
350
351* Tue Feb 17 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-3
352- rebuild (gcc5)
353
354* Mon Jan 26 2015 David Tardon <dtardon@redhat.com> - 5.4.0-2
355- rebuild for ICU 54.1
356
357* Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
358- 5.4.0 (final)
359
360* Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.5.rc
361- 5.4.0-rc
362
363* Tue Nov 18 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.4.beta
364- use gst1 only fc21+ (and el8+) only
365
366* Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.beta
367- fix hardening, use new %%qmake_qt5 macro
368
369* Sat Nov 01 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
370- enable hardened build, out-of-src tree build
371
372* Sat Oct 18 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
373- 5.4.0-beta
374
375* Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
376- 5.3.2
377
378* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 5.3.1-3
379- rebuild for ICU 53.1
380
381* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
382- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
383
384* Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
385- 5.3.1
386
387* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
388- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
389
390* Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
391- 5.3.0
392
393* Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-4
394- use standard (same as qtbase) .prl sanitation
395
396* Fri May 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-3
397- no rpath, drop chrpath hacks
398- BR: qt5-qtlocation qt5-qtsensors
399
400* Wed Feb 12 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
401- rebuild (libicu)
402
403* Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
404- 5.2.1
405
406* Sun Feb 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
407- Add AArch64 support to qtwebkit (#1056160)
408
409* Wed Jan 01 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
410- rebuild (libwebp)
411
412* Thu Dec 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
413- 5.2.0
414
415* Mon Dec 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.10.rc1
416- 5.2.0-rc1
417
418* Thu Nov 28 2013 Dan Horák <dan[at]danny.cz> 5.2.0-0.6.beta1
419- disable JIT on secondary arches, fix build with JIT disabled (#1034940)
420
421* Mon Nov 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.5.beta1
422- enable -doc only on primary archs (allow secondary bootstrap)
423
424* Sat Nov 09 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.4.beta1
425- rebuild (arm/qreal)
426
427* Thu Oct 24 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.3.beta1
428- 5.2.0-beta1
429
430* Wed Oct 16 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.2.alpha
431- bootstrap ppc
432
433* Wed Oct 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.1.alpha
434- 5.2.0-alpha
435- -doc subpkg
436- use gstreamer1 (where available)
437
438* Wed Aug 28 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-1
439- 5.1.1
440
441* Tue Aug 20 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-8
442- qt5-qtjsbackend only supports ix86, x86_64 and arm
443
444* Fri Aug 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-7
445- use bundled angleproject (until system version passes review)
446
447* Fri Jun 21 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-6
448- %%doc ChangeLog VERSION
449- %%doc Source/WebCore/LICENSE*
450- squash more rpaths
451
452* Fri May 17 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-5
453- unbundle angleproject code
454
455* Wed May 15 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-4
456- BR: perl(version) perl(Digest::MD5) pkgconfig(xslt)
457- deal with bundled code
458- add (commented) upstream link http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
459  to clarify licensing
460
461* Thu May 09 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-3
462- -devel: Requires: qt5-qtdeclarative-devel
463
464* Fri Apr 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
465- BR: qt5-qtdeclarative-devel
466
467* Thu Apr 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-1
468- 5.0.2
469
470* Mon Feb 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-2
471- .prl love
472- BR: pkgconfig(gl)
473
474* Sat Feb 23 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-1
475- first try
476
Note: See TracBrowser for help on using the repository browser.