source: projects/specs/trunk/q/qt5-qtwebengine/qt5-qtwebengine-vl.spec @ 11904

Revision 11904, 25.2 KB checked in by ara_t, 5 years ago (diff)

qt5-qtwebengine: rebuild with libevent-2.1.8

Line 
1
2%global qt_module qtwebengine
3
4%global _hardened_build 1
5
6# define to build docs, need to undef this for bootstrapping
7# where qt5-qttools builds are not yet available
8# only primary archs (for now), allow secondary to bootstrap
9%ifarch %{arm} %{ix86} x86_64
10%global docs 1
11%endif
12
13%if 0
14# need libvpx >= 1.4.0
15%global use_system_libvpx 1
16%endif
17%if 0%{?fedora} || 0%{?rhel} > 6
18# need libwebp >= 0.4.3
19%global use_system_libwebp 1
20%endif
21
22#global prerelease rc
23
24# exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
25# else)
26%global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
27# exclude libv8.so (i686, it's static everywhere else)
28%global __requires_exclude ^libv8\\.so$
29
30%global qt5_minorver 5.6
31%global qt5_version 5.6.3
32#global qt5_patchlevel 1
33
34Summary: Qt5 - QtWebEngine components
35Name:    qt5-qtwebengine
36Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
37Release: 2%{?_dist_release}
38
39# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
40# See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
41# The other licenses are from Chromium and the code it bundles
42License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
43URL:     http://www.qt.io
44
45Vendor: Project Vine
46Distribution: Vine Linux
47
48# cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
49# wget http://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-opensource-src-5.6.1-1.tar.xz
50# ./clean_qtwebengine.sh 5.6.1-1
51Source0: %{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
52
53# cleanup scripts used above
54Source1: clean_qtwebengine.sh
55Source2: clean_ffmpeg.sh
56Source3: get_free_ffmpeg_source_files.py
57
58# some tweaks to linux.pri (system libs, link libpci, run unbundling script)
59Patch1:  qtwebengine-opensource-src-5.6.3-linux-pri.patch
60# quick hack to avoid checking for the nonexistent icudtl.dat and silence the
61# resulting warnings - not upstreamable as is because it removes the fallback
62# mechanism for the ICU data directory (which is not used in our builds because
63# we use the system ICU, which embeds the data statically) completely
64Patch2:  qtwebengine-opensource-src-5.6.0-no-icudtl-dat.patch
65# fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
66# ARM flags with our %%qmake_qt5 macro, including for the next patch
67Patch3:  qtwebengine-opensource-src-5.6.0-beta-fix-extractcflag.patch
68# use the system NSPR prtime (based on Debian patch)
69# We already depend on NSPR, so it is useless to copy these functions here.
70# Debian uses this just fine, and I don't see relevant modifications either.
71Patch5:  qtwebengine-opensource-src-5.6.3-system-nspr-prtime.patch
72# use the system ICU UTF functions
73# We already depend on ICU, so it is useless to copy these functions here.
74# I checked the history of that directory, and other than the renames I am
75# undoing, there were no modifications at all. Must be applied after Patch5.
76Patch6:  qtwebengine-opensource-src-5.7.0-system-icu-utf.patch
77# do not require SSE2 on i686
78# cumulative revert of upstream reviews 187423002, 308003004, 511773002 (parts
79# relevant to QtWebEngine only), 516543004, 1152053004 and 1161853008, along
80# with some custom fixes and improvements
81# also build V8 shared and twice on i686 (once for x87, once for SSE2)
82Patch7:  qtwebengine-opensource-src-5.7.0-no-sse2.patch
83
84
85# to build with icu > 59
86Patch1000: qtwebengine-5.7.1-icu-59.patch
87Patch1001: qtwebengine-5.6.3-icu60.patch
88
89# the architectures theoretically supported by the version of V8 used (#1298011)
90# You may need some minor patching to build on one of the secondary
91# architectures, e.g., to add to the Qt -> Chromium -> V8 arch translations.
92# If you cannot get this package to build on your secondary architecure, please:
93# * remove your architecture from this list AND
94# * put #1298011 onto your ExcludeArch tracker.
95ExclusiveArch: %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
96
97BuildRequires: qt5-qtbase-devel >= %{version}
98BuildRequires: qt5-qtbase-private-devel
99# TODO: check of = is really needed or if >= would be good enough -- rex
100%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
101BuildRequires: qt5-qtdeclarative-devel >= %{version}
102BuildRequires: qt5-qtxmlpatterns-devel >= %{version}
103BuildRequires: qt5-qtlocation-devel >= %{version}
104BuildRequires: qt5-qtsensors-devel >= %{version}
105BuildRequires: qt5-qtwebchannel-devel >= %{version}
106BuildRequires: qt5-qttools-static >= %{version}
107BuildRequires: ninja
108BuildRequires: bison
109BuildRequires: git
110BuildRequires: gperf
111BuildRequires: libicu-devel
112BuildRequires: libjpeg-devel
113#BuildRequires: re2-devel
114BuildRequires: snappy-devel
115%ifarch %{ix86} x86_64
116BuildRequires: yasm
117%endif
118BuildRequires: pkgconfig(expat)
119BuildRequires: pkgconfig(gobject-2.0)
120BuildRequires: pkgconfig(glib-2.0)
121BuildRequires: pkgconfig(fontconfig)
122BuildRequires: pkgconfig(freetype2)
123BuildRequires: pkgconfig(gl)
124BuildRequires: pkgconfig(egl)
125BuildRequires: pkgconfig(libpng)
126BuildRequires: pkgconfig(libudev)
127%if 0%{?use_system_libwebp}
128BuildRequires: pkgconfig(libwebp) >= 0.4.3
129%endif
130BuildRequires: pkgconfig(harfbuzz)
131BuildRequires: pkgconfig(jsoncpp)
132BuildRequires: pkgconfig(protobuf)
133BuildRequires: pkgconfig(libdrm)
134BuildRequires: pkgconfig(opus)
135BuildRequires: pkgconfig(libevent)
136BuildRequires: pkgconfig(zlib)
137#BuildRequires: pkgconfig(minizip)
138BuildRequires: pkgconfig(libxml-2.0)
139BuildRequires: pkgconfig(libxslt)
140BuildRequires: pkgconfig(x11)
141BuildRequires: pkgconfig(xi)
142BuildRequires: libXcursor-devel
143BuildRequires: pkgconfig(xext)
144BuildRequires: pkgconfig(xfixes)
145BuildRequires: pkgconfig(xrender)
146BuildRequires: pkgconfig(xdamage)
147BuildRequires: pkgconfig(xcomposite)
148BuildRequires: pkgconfig(xtst)
149BuildRequires: pkgconfig(xrandr)
150BuildRequires: pkgconfig(xscrnsaver)
151BuildRequires: pkgconfig(libcap)
152BuildRequires: pkgconfig(libpulse)
153BuildRequires: pkgconfig(alsa)
154BuildRequires: pciutils-devel
155BuildRequires: pkgconfig(dbus-1)
156BuildRequires: pkgconfig(nss)
157BuildRequires: pkgconfig(libsrtp)
158BuildRequires: perl
159BuildRequires: python
160%if 0%{?use_system_libvpx}
161BuildRequires: pkgconfig(vpx) >= 1.4.0
162%endif
163
164# extra (non-upstream) functions needed, see
165# src/3rdparty/chromium/third_party/sqlite/README.chromium for details
166#BuildRequires: pkgconfig(sqlite3)
167
168## Various bundled libraries that Chromium does not support unbundling :-(
169## Only the parts actually built are listed.
170## Query for candidates:
171## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
172## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
173## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
174## some false positives where only shim headers are generated for some reason
175## some false positives with dummy placeholder dirs (swiftshader, widevine)
176## some false negatives where a header-only library is bundled (e.g. x86inc)
177## Spot's chromium.spec also has a list that I checked.
178
179# Of course, Chromium itself is bundled. It cannot be unbundled because it is
180# not a library, but forked (modified) application code.
181# Some security fixes are backported, see:
182# http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
183Provides: bundled(chromium) = 45
184
185# Bundled in src/3rdparty/chromium/third_party:
186# Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
187# except where specified otherwise.
188Provides: bundled(angle) = 2422
189# Google's fork of OpenSSL
190# We cannot build against NSS instead because it no longer works with NSS 3.21:
191# HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
192# completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
193# http://kaosx.us/phpBB3/viewtopic.php?t=1235
194# https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
195# So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
196# use the BoringSSL code and the system NSS certificates.
197Provides: bundled(boringssl)
198Provides: bundled(brotli)
199# Don't get too excited. MPEG and other legally problematic stuff is stripped
200# out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
201# see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
202Provides: bundled(ffmpeg) = 2.7
203Provides: bundled(iccjpeg)
204# bundled as "khronos", headers only
205Provides: bundled(khronos_headers)
206# bundled as "leveldatabase"
207Provides: bundled(leveldb) = r80
208Provides: bundled(libjingle) = 9564
209%if !0%{?use_system_libvpx}
210Provides: bundled(libvpx) = 1.4.0
211%endif
212%if !0%{?use_system_libwebp}
213Provides: bundled(libwebp) = 0.4.3
214%endif
215Provides: bundled(libXNVCtrl) = 302.17
216Provides: bundled(libyuv) = 1444
217Provides: bundled(modp_b64)
218Provides: bundled(mojo)
219# headers only
220Provides: bundled(npapi)
221Provides: bundled(openmax_dl) = 1.0.2
222Provides: bundled(ots)
223Provides: bundled(qcms) = 4
224Provides: bundled(sfntly) = 0-0.1.svn111
225Provides: bundled(skia)
226# bundled as "smhasher"
227Provides: bundled(SMHasher) = 0-0.1.svn147
228Provides: bundled(sqlite) = 3.8.7.4
229Provides: bundled(usrsctp) = 0-0.1.svn9045
230Provides: bundled(webrtc) = 90
231%ifarch %{ix86} x86_64
232# header (for assembly) only
233Provides: bundled(x86inc) = 0
234%endif
235
236# Bundled in src/3rdparty/chromium/base/third_party:
237# Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
238# numbers, except where specified otherwise.
239Provides: bundled(dmg_fp)
240Provides: bundled(dynamic_annotations) = 4384
241Provides: bundled(superfasthash) = 0
242Provides: bundled(symbolize)
243# bundled as "valgrind", headers only
244Provides: bundled(valgrind.h)
245# bundled as "xdg_mime"
246Provides: bundled(xdg-mime)
247# bundled as "xdg_user_dirs"
248Provides: bundled(xdg-user-dirs) = 0.10
249
250# Bundled in src/3rdparty/chromium/net/third_party:
251# Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
252# numbers, except where specified otherwise.
253Provides: bundled(mozilla_security_manager) = 1.9.2
254
255# Bundled in src/3rdparty/chromium/url/third_party:
256# Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
257# numbers, except where specified otherwise.
258# bundled as "mozilla", file renamed and modified
259Provides: bundled(nsURLParsers)
260
261# Bundled outside of third_party, apparently not considered as such by Chromium:
262# see src/3rdparty/chromium/v8/include/v8_version.h for the version number
263Provides: bundled(v8) = 4.5.103.35
264# bundled by v8 (src/3rdparty/chromium/v8/src/third_party/fdlibm)
265# see src/3rdparty/chromium/v8/src/third_party/fdlibm/README.v8 for the version
266Provides: bundled(fdlibm) = 5.3
267
268%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
269
270
271%description
272%{summary}.
273
274%package devel
275Summary: Development files for %{name}
276Requires: %{name}%{?_isa} = %{version}-%{release}
277Requires: qt5-qtbase-devel%{?_isa}
278Requires: qt5-qtdeclarative-devel%{?_isa}
279%description devel
280%{summary}.
281
282%package examples
283Summary: Example files for %{name}
284
285%description examples
286%{summary}.
287
288
289%if 0%{?docs}
290%package doc
291Summary: API documentation for %{name}
292BuildRequires: qt5-qhelpgenerator
293BuildRequires: qt5-qdoc
294BuildArch: noarch
295%description doc
296%{summary}.
297%endif
298
299
300%prep
301%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
302
303%patch1 -p1 -b .linux-pri
304%patch2 -p1 -b .no-icudtl-dat
305%patch3 -p1 -b .fix-extractcflag
306%patch5 -p1 -b .system-nspr-prtime
307%patch6 -p1 -b .system-icu-utf
308%patch7 -p1 -b .no-sse2
309
310%patch1000 -p1 -b .icu59
311%patch1001 -p1 -b .icu60
312
313# fix // in #include in content/renderer/gpu to avoid debugedit failure
314sed -i -e 's!gpu//!gpu/!g' \
315  src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
316# remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
317sed -i -e 's!\./!!g' \
318  src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
319  src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
320
321# http://bugzilla.redhat.com/1337585
322# can't just delete, but we'll overwrite with system headers to be on the safe side
323#cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/re2/
324
325#ifnarch x86_64
326# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
327sed -i -e 's/=-g$/=-g1/g' src/core/gyp_run.pro
328#endif
329
330%build
331export STRIP=strip
332export NINJAFLAGS="-v %{_smp_mflags}"
333export NINJA_PATH=%{_bindir}/ninja-build
334export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
335export CFLAGS="%{optflags}"
336#ifnarch x86_64
337# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
338export CFLAGS=`echo "$CFLAGS" | sed -e 's/ -g / -g1 /g'`
339#endif
340export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks"
341#ifnarch x86_64
342# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
343export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
344#endif
345
346
347mkdir %{_target_platform}
348pushd %{_target_platform}
349
350%{qmake_qt5} CONFIG+="webcore_debug v8base_debug force_debug_info" WEBENGINE_CONFIG+="use_system_icu use_system_protobuf" ..
351
352# if we keep these set here, gyp picks up duplicate flags
353unset CFLAGS
354export CFLAGS
355unset CXXFLAGS
356export CXXFLAGS
357
358# workaround, disable parallel compilation as it fails to compile in brew
359make %{?_smp_mflags}
360
361%if 0%{?docs}
362make %{?_smp_mflags} docs
363%endif
364popd
365
366%install
367make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
368
369%if 0%{?docs}
370make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
371%endif
372
373## .prl/.la file love
374# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
375pushd %{buildroot}%{_qt5_libdir}
376for prl_file in libQt5*.prl ; do
377  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
378  if [ -f "$(basename ${prl_file} .prl).so" ]; then
379    rm -fv "$(basename ${prl_file} .prl).la"
380    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
381  fi
382done
383popd
384
385%post -p /sbin/ldconfig
386%postun -p /sbin/ldconfig
387
388%files
389%{_qt5_libdir}/libQt5*.so.*
390%{_qt5_libdir}/qt5/qml/*
391%{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
392%ifarch %{ix86}
393# shared V8 library and its SSE2 version
394%{_qt5_libdir}/qtwebengine/
395%endif
396%{_qt5_plugindir}/designer/libqwebengineview.so
397%{_qt5_datadir}/resources/
398%dir %{_qt5_translationdir}/qtwebengine_locales
399%lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
400%lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
401%lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
402%lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
403%lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
404%lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
405%lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
406%lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
407%lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
408%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
409%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
410%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
411%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
412%lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
413%lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
414%lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
415%lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
416%lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
417%lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
418%lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
419%lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
420%lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
421%lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
422%lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
423%lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
424%lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
425%lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
426%lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
427%lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
428%lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
429%lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
430%lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
431%lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
432%lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
433%lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
434%lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
435%lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
436%lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
437%lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
438%lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
439%lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
440%lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
441%lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
442%lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
443%lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
444%lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
445%lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
446%lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
447%lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
448%lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
449%lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
450%lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
451%lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
452
453%files devel
454%{_qt5_headerdir}/Qt*/
455%{_qt5_libdir}/libQt5*.so
456%{_qt5_libdir}/libQt5*.prl
457%{_qt5_libdir}/cmake/Qt5*/
458%{_qt5_libdir}/pkgconfig/Qt5*.pc
459%{_qt5_archdatadir}/mkspecs/modules/*.pri
460
461%files examples
462%{_qt5_examplesdir}/
463
464%if 0%{?docs}
465%files doc
466%{_qt5_docdir}/*
467%endif
468
469
470%changelog
471* Fri Nov 16 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-2
472- rebuild with libevent-2.1.8
473
474* Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
475- new upstream release.
476
477* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
478- new upstream release.
479- initial build for Vine Linux.
480- updated Source1.
481
482* Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
483- rebuild (glibc)
484
485* Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
486- add versioned qt5-qtbase runtime dep
487
488* Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
489- Update to 5.6.1
490- Rebase linux-pri patch (drop the parts already fixed upstream)
491- Drop backported chimera-nss-init patch, already applied upstream
492- Rebase no-sse2 patch (the core_module.pro change)
493- Add the new designer/libqwebengineview.so plugin to the file list
494
495* Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
496- workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
497
498* Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
499- rebuild (pciutuils)
500
501* Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
502- BR: git-core
503
504* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
505- rebuild for ICU 57.1
506
507* Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
508- drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
509
510* Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
511- Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
512- Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
513- Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
514- Work around debugedit failure by removing "./" from #line commands and
515  changing "//" to "/" in an #include command
516
517* Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
518- Avoid checking for the nonexistent icudtl.dat and silence the warnings
519
520* Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
521- Update to 5.6.0 (final)
522- Drop system-icu54 patch, fixed upstream
523
524* Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
525- Update to 5.6.0 RC
526- Rebase linux-pri and no-sse2 patches
527- Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
528- Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
529- Tag translations with correct %%lang tags
530
531* Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
532- no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
533
534* Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
535- Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
536
537* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
538- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
539
540* Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
541- Build V8 as a shared library on i686 to allow for swappable backends
542- Build both the x87 version and the SSE2 version of V8 on i686
543- Add the private library directory to the file list on i686
544- Add Provides/Requires filtering for libv8.so (i686) and for plugins
545
546* Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
547- Do not require SSE2 on i686
548
549* Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
550- Drop nss321 backport (and the related nss-headers patch), it did not help
551- Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
552- Update License accordingly (add "OpenSSL")
553- Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
554
555* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
556- Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
557
558* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
559- Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
560
561* Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
562- Unbundle prtime.cc, use the system NSPR instead (which is already required)
563- Unbundle icu_utf.cc, use the system ICU instead (which is already required)
564
565* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
566- linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
567
568* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
569- Build against the system libvpx also on F23 (1.4.0), worked in Copr
570
571* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
572- Use the system libvpx on F24+ (1.5.0)
573- Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
574
575* Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
576- Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
577- Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
578
579* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
580- Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
581- Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
582
583* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
584- Use more specific BuildRequires for docs (thanks to rdieter)
585- Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
586
587* Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
588- Fix License tag
589- Use %%_qt5_examplesdir macro
590- Add Provides: bundled(*) for all the bundled libraries that I found
591
592* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
593- linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
594
595* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
596- linux-pri patch: Add missing newline at the end of the log line
597- Use export for NINJA_PATH (fixes system ninja-build use)
598
599* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
600- Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
601- BR yasm only on x86 (i686, x86_64)
602- Add dot at the end of %%description
603- Rebase no-format patch
604- Replace unbundle-gyp.patch with new linux-pri.patch
605- Use system ninja-build instead of the bundled one
606- Run the unbundling script replace_gyp_files.py in linux.pri rather than here
607- Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
608
609* Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
610- Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
611  pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
612  pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
613  pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
614  perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
615- Add missing explicit BRs on pkgconfig(x11),  pkgconfig(xext),
616  pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
617- Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
618- Fix BR python-devel to python
619- Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
620- Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
621
622* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
623- Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
624
625* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
626- Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
627- Remove unused BR v8-devel (cannot currently be unbundled)
628
629* Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
630- Update to 5.5.1
631- Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
632
633* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
634- Update with unbundle flags. Adapted from original 5.4 Suse package
635- Disable vpx and sqlite as unbundle due some compilation issues
636- Enable verbose build
637
638* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
639- Initial spec
640
641* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
642- Update for official RC1 released packages
Note: See TracBrowser for help on using the repository browser.