source: projects/specs/trunk/q/qt5-qtwebengine/qt5-qtwebengine-vl.spec @ 10599

Revision 10599, 24.9 KB checked in by tomop, 8 years ago (diff)

qt5-qtwebengine-5.6.1.1-1

Line 
1
2%global qt_module qtwebengine
3
4%global _hardened_build 1
5
6# define to build docs, need to undef this for bootstrapping
7# where qt5-qttools builds are not yet available
8# only primary archs (for now), allow secondary to bootstrap
9%ifarch %{arm} %{ix86} x86_64
10%global docs 1
11%endif
12
13%if 0
14# need libvpx >= 1.4.0
15%global use_system_libvpx 1
16%endif
17%if 0%{?fedora} || 0%{?rhel} > 6
18# need libwebp >= 0.4.3
19%global use_system_libwebp 1
20%endif
21
22#global prerelease rc
23
24# exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
25# else)
26%global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
27# exclude libv8.so (i686, it's static everywhere else)
28%global __requires_exclude ^libv8\\.so$
29
30%global qt5_minorver 5.6
31%global qt5_version 5.6.1
32%global qt5_patchlevel 1
33
34Summary: Qt5 - QtWebEngine components
35Name:    qt5-qtwebengine
36Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
37Release: 1%{?_dist_release}
38
39# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
40# See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
41# The other licenses are from Chromium and the code it bundles
42License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
43URL:     http://www.qt.io
44
45Vendor: Project Vine
46Distribution: Vine Linux
47
48# cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
49# wget http://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-opensource-src-5.6.1-1.tar.xz
50# ./clean_qtwebengine.sh 5.6.1-1
51Source0: %{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
52
53# cleanup scripts used above
54Source1: clean_qtwebengine.sh
55Source2: clean_ffmpeg.sh
56Source3: process_ffmpeg_gyp.py
57# do not compile with -Wno-format, which also bypasses -Werror-format-security
58Patch0:  qtwebengine-opensource-src-5.6.0-beta-no-format.patch
59# some tweaks to linux.pri (system libs, link libpci, run unbundling script)
60Patch1:  qtwebengine-opensource-src-5.6.1-linux-pri.patch
61# quick hack to avoid checking for the nonexistent icudtl.dat and silence the
62# resulting warnings - not upstreamable as is because it removes the fallback
63# mechanism for the ICU data directory (which is not used in our builds because
64# we use the system ICU, which embeds the data statically) completely
65Patch2:  qtwebengine-opensource-src-5.6.0-no-icudtl-dat.patch
66# fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
67# ARM flags with our %%qmake_qt5 macro, including for the next patch
68Patch3:  qtwebengine-opensource-src-5.6.0-beta-fix-extractcflag.patch
69# disable NEON vector instructions on ARM for now, the NEON code FTBFS due to
70# GCC bug https://bugzilla.redhat.com/show_bug.cgi?id=1282495
71Patch4:  qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
72# use the system NSPR prtime (based on Debian patch)
73# We already depend on NSPR, so it is useless to copy these functions here.
74# Debian uses this just fine, and I don't see relevant modifications either.
75Patch5:  qtwebengine-opensource-src-5.6.0-beta-system-nspr-prtime.patch
76# use the system ICU UTF functions
77# We already depend on ICU, so it is useless to copy these functions here.
78# I checked the history of that directory, and other than the renames I am
79# undoing, there were no modifications at all. Must be applied after Patch5.
80Patch6:  qtwebengine-opensource-src-5.6.0-beta-system-icu-utf.patch
81# do not require SSE2 on i686
82# cumulative revert of upstream reviews 187423002, 308003004, 511773002 (parts
83# relevant to QtWebEngine only), 516543004, 1152053004 and 1161853008, along
84# with some custom fixes and improvements
85# also build V8 shared and twice on i686 (once for x87, once for SSE2)
86Patch7:  qtwebengine-opensource-src-5.6.1-no-sse2.patch
87
88# the architectures theoretically supported by the version of V8 used (#1298011)
89# You may need some minor patching to build on one of the secondary
90# architectures, e.g., to add to the Qt -> Chromium -> V8 arch translations.
91# If you cannot get this package to build on your secondary architecure, please:
92# * remove your architecture from this list AND
93# * put #1298011 onto your ExcludeArch tracker.
94ExclusiveArch: %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
95
96BuildRequires: qt5-qtbase-devel >= %{version}
97BuildRequires: qt5-qtbase-private-devel
98# TODO: check of = is really needed or if >= would be good enough -- rex
99%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
100BuildRequires: qt5-qtdeclarative-devel >= %{version}
101BuildRequires: qt5-qtxmlpatterns-devel >= %{version}
102BuildRequires: qt5-qtlocation-devel >= %{version}
103BuildRequires: qt5-qtsensors-devel >= %{version}
104BuildRequires: qt5-qtwebchannel-devel >= %{version}
105BuildRequires: qt5-qttools-static >= %{version}
106BuildRequires: ninja
107BuildRequires: bison
108BuildRequires: git
109BuildRequires: gperf
110BuildRequires: libicu-devel
111BuildRequires: libjpeg-devel
112#BuildRequires: re2-devel
113BuildRequires: snappy-devel
114%ifarch %{ix86} x86_64
115BuildRequires: yasm
116%endif
117BuildRequires: pkgconfig(expat)
118BuildRequires: pkgconfig(gobject-2.0)
119BuildRequires: pkgconfig(glib-2.0)
120BuildRequires: pkgconfig(fontconfig)
121BuildRequires: pkgconfig(freetype2)
122BuildRequires: pkgconfig(gl)
123BuildRequires: pkgconfig(egl)
124BuildRequires: pkgconfig(libpng)
125BuildRequires: pkgconfig(libudev)
126%if 0%{?use_system_libwebp}
127BuildRequires: pkgconfig(libwebp) >= 0.4.3
128%endif
129BuildRequires: pkgconfig(harfbuzz)
130BuildRequires: pkgconfig(jsoncpp)
131BuildRequires: pkgconfig(protobuf)
132BuildRequires: pkgconfig(libdrm)
133BuildRequires: pkgconfig(opus)
134BuildRequires: pkgconfig(libevent)
135BuildRequires: pkgconfig(zlib)
136#BuildRequires: pkgconfig(minizip)
137BuildRequires: pkgconfig(libxml-2.0)
138BuildRequires: pkgconfig(libxslt)
139BuildRequires: pkgconfig(x11)
140BuildRequires: pkgconfig(xi)
141BuildRequires: libXcursor-devel
142BuildRequires: pkgconfig(xext)
143BuildRequires: pkgconfig(xfixes)
144BuildRequires: pkgconfig(xrender)
145BuildRequires: pkgconfig(xdamage)
146BuildRequires: pkgconfig(xcomposite)
147BuildRequires: pkgconfig(xtst)
148BuildRequires: pkgconfig(xrandr)
149BuildRequires: pkgconfig(xscrnsaver)
150BuildRequires: pkgconfig(libcap)
151BuildRequires: pkgconfig(libpulse)
152BuildRequires: pkgconfig(alsa)
153BuildRequires: pciutils-devel
154BuildRequires: pkgconfig(dbus-1)
155BuildRequires: pkgconfig(nss)
156BuildRequires: pkgconfig(libsrtp)
157BuildRequires: perl
158BuildRequires: python
159%if 0%{?use_system_libvpx}
160BuildRequires: pkgconfig(vpx) >= 1.4.0
161%endif
162
163# extra (non-upstream) functions needed, see
164# src/3rdparty/chromium/third_party/sqlite/README.chromium for details
165#BuildRequires: pkgconfig(sqlite3)
166
167## Various bundled libraries that Chromium does not support unbundling :-(
168## Only the parts actually built are listed.
169## Query for candidates:
170## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
171## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
172## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
173## some false positives where only shim headers are generated for some reason
174## some false positives with dummy placeholder dirs (swiftshader, widevine)
175## some false negatives where a header-only library is bundled (e.g. x86inc)
176## Spot's chromium.spec also has a list that I checked.
177
178# Of course, Chromium itself is bundled. It cannot be unbundled because it is
179# not a library, but forked (modified) application code.
180# Some security fixes are backported, see:
181# http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
182Provides: bundled(chromium) = 45
183
184# Bundled in src/3rdparty/chromium/third_party:
185# Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
186# except where specified otherwise.
187Provides: bundled(angle) = 2422
188# Google's fork of OpenSSL
189# We cannot build against NSS instead because it no longer works with NSS 3.21:
190# HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
191# completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
192# http://kaosx.us/phpBB3/viewtopic.php?t=1235
193# https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
194# So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
195# use the BoringSSL code and the system NSS certificates.
196Provides: bundled(boringssl)
197Provides: bundled(brotli)
198# Don't get too excited. MPEG and other legally problematic stuff is stripped
199# out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
200# see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
201Provides: bundled(ffmpeg) = 2.7
202Provides: bundled(iccjpeg)
203# bundled as "khronos", headers only
204Provides: bundled(khronos_headers)
205# bundled as "leveldatabase"
206Provides: bundled(leveldb) = r80
207Provides: bundled(libjingle) = 9564
208%if !0%{?use_system_libvpx}
209Provides: bundled(libvpx) = 1.4.0
210%endif
211%if !0%{?use_system_libwebp}
212Provides: bundled(libwebp) = 0.4.3
213%endif
214Provides: bundled(libXNVCtrl) = 302.17
215Provides: bundled(libyuv) = 1444
216Provides: bundled(modp_b64)
217Provides: bundled(mojo)
218# headers only
219Provides: bundled(npapi)
220Provides: bundled(openmax_dl) = 1.0.2
221Provides: bundled(ots)
222Provides: bundled(qcms) = 4
223Provides: bundled(sfntly) = 0-0.1.svn111
224Provides: bundled(skia)
225# bundled as "smhasher"
226Provides: bundled(SMHasher) = 0-0.1.svn147
227Provides: bundled(sqlite) = 3.8.7.4
228Provides: bundled(usrsctp) = 0-0.1.svn9045
229Provides: bundled(webrtc) = 90
230%ifarch %{ix86} x86_64
231# header (for assembly) only
232Provides: bundled(x86inc) = 0
233%endif
234
235# Bundled in src/3rdparty/chromium/base/third_party:
236# Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
237# numbers, except where specified otherwise.
238Provides: bundled(dmg_fp)
239Provides: bundled(dynamic_annotations) = 4384
240Provides: bundled(superfasthash) = 0
241Provides: bundled(symbolize)
242# bundled as "valgrind", headers only
243Provides: bundled(valgrind.h)
244# bundled as "xdg_mime"
245Provides: bundled(xdg-mime)
246# bundled as "xdg_user_dirs"
247Provides: bundled(xdg-user-dirs) = 0.10
248
249# Bundled in src/3rdparty/chromium/net/third_party:
250# Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
251# numbers, except where specified otherwise.
252Provides: bundled(mozilla_security_manager) = 1.9.2
253
254# Bundled in src/3rdparty/chromium/url/third_party:
255# Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
256# numbers, except where specified otherwise.
257# bundled as "mozilla", file renamed and modified
258Provides: bundled(nsURLParsers)
259
260# Bundled outside of third_party, apparently not considered as such by Chromium:
261# see src/3rdparty/chromium/v8/include/v8_version.h for the version number
262Provides: bundled(v8) = 4.5.103.35
263# bundled by v8 (src/3rdparty/chromium/v8/src/third_party/fdlibm)
264# see src/3rdparty/chromium/v8/src/third_party/fdlibm/README.v8 for the version
265Provides: bundled(fdlibm) = 5.3
266
267%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
268
269
270%description
271%{summary}.
272
273%package devel
274Summary: Development files for %{name}
275Requires: %{name}%{?_isa} = %{version}-%{release}
276Requires: qt5-qtbase-devel%{?_isa}
277Requires: qt5-qtdeclarative-devel%{?_isa}
278%description devel
279%{summary}.
280
281%package examples
282Summary: Example files for %{name}
283
284%description examples
285%{summary}.
286
287
288%if 0%{?docs}
289%package doc
290Summary: API documentation for %{name}
291BuildRequires: qt5-qhelpgenerator
292BuildRequires: qt5-qdoc
293BuildArch: noarch
294%description doc
295%{summary}.
296%endif
297
298
299%prep
300%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
301%patch0 -p1 -b .no-format
302%patch1 -p1 -b .linux-pri
303%patch2 -p1 -b .no-icudtl-dat
304%patch3 -p1 -b .fix-extractcflag
305%patch4 -p1 -b .no-neon
306%patch5 -p1 -b .system-nspr-prtime
307%patch6 -p1 -b .system-icu-utf
308%patch7 -p1 -b .no-sse2
309# fix // in #include in content/renderer/gpu to avoid debugedit failure
310sed -i -e 's!gpu//!gpu/!g' \
311  src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
312# remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
313sed -i -e 's!\./!!g' \
314  src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
315  src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
316
317# http://bugzilla.redhat.com/1337585
318# can't just delete, but we'll overwrite with system headers to be on the safe side
319#cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/re2/
320
321#ifnarch x86_64
322# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
323sed -i -e 's/=-g$/=-g1/g' src/core/gyp_run.pro
324#endif
325
326%build
327export STRIP=strip
328export NINJAFLAGS="-v %{_smp_mflags}"
329export NINJA_PATH=%{_bindir}/ninja-build
330export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
331export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks -I$RE2_INCLUDE"
332#ifnarch x86_64
333# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
334export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
335#endif
336
337mkdir %{_target_platform}
338pushd %{_target_platform}
339
340%{qmake_qt5} CONFIG+="webcore_debug v8base_debug force_debug_info" WEBENGINE_CONFIG+="use_system_icu" ..
341
342# workaround, disable parallel compilation as it fails to compile in brew
343make %{?_smp_mflags}
344
345%if 0%{?docs}
346make %{?_smp_mflags} docs
347%endif
348popd
349
350%install
351make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
352
353%if 0%{?docs}
354make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
355%endif
356
357## .prl/.la file love
358# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
359pushd %{buildroot}%{_qt5_libdir}
360for prl_file in libQt5*.prl ; do
361  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
362  if [ -f "$(basename ${prl_file} .prl).so" ]; then
363    rm -fv "$(basename ${prl_file} .prl).la"
364    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
365  fi
366done
367popd
368
369%post -p /sbin/ldconfig
370%postun -p /sbin/ldconfig
371
372%files
373%{_qt5_libdir}/libQt5*.so.*
374%{_qt5_libdir}/qt5/qml/*
375%{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
376%ifarch %{ix86}
377# shared V8 library and its SSE2 version
378%{_qt5_libdir}/qtwebengine/
379%endif
380%{_qt5_plugindir}/designer/libqwebengineview.so
381%{_qt5_datadir}/resources/
382%dir %{_qt5_translationdir}/qtwebengine_locales
383%lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
384%lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
385%lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
386%lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
387%lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
388%lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
389%lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
390%lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
391%lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
392%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
393%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
394%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
395%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
396%lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
397%lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
398%lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
399%lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
400%lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
401%lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
402%lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
403%lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
404%lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
405%lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
406%lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
407%lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
408%lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
409%lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
410%lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
411%lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
412%lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
413%lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
414%lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
415%lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
416%lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
417%lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
418%lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
419%lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
420%lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
421%lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
422%lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
423%lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
424%lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
425%lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
426%lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
427%lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
428%lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
429%lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
430%lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
431%lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
432%lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
433%lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
434%lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
435%lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
436
437%files devel
438%{_qt5_headerdir}/Qt*/
439%{_qt5_libdir}/libQt5*.so
440%{_qt5_libdir}/libQt5*.prl
441%{_qt5_libdir}/cmake/Qt5*/
442%{_qt5_libdir}/pkgconfig/Qt5*.pc
443%{_qt5_archdatadir}/mkspecs/modules/*.pri
444
445%files examples
446%{_qt5_examplesdir}/
447
448%if 0%{?docs}
449%files doc
450%{_qt5_docdir}/*
451%endif
452
453
454%changelog
455* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
456- new upstream release.
457- initial build for Vine Linux.
458- updated Source1.
459
460* Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
461- rebuild (glibc)
462
463* Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
464- add versioned qt5-qtbase runtime dep
465
466* Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
467- Update to 5.6.1
468- Rebase linux-pri patch (drop the parts already fixed upstream)
469- Drop backported chimera-nss-init patch, already applied upstream
470- Rebase no-sse2 patch (the core_module.pro change)
471- Add the new designer/libqwebengineview.so plugin to the file list
472
473* Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
474- workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
475
476* Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
477- rebuild (pciutuils)
478
479* Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
480- BR: git-core
481
482* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
483- rebuild for ICU 57.1
484
485* Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
486- drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
487
488* Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
489- Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
490- Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
491- Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
492- Work around debugedit failure by removing "./" from #line commands and
493  changing "//" to "/" in an #include command
494
495* Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
496- Avoid checking for the nonexistent icudtl.dat and silence the warnings
497
498* Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
499- Update to 5.6.0 (final)
500- Drop system-icu54 patch, fixed upstream
501
502* Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
503- Update to 5.6.0 RC
504- Rebase linux-pri and no-sse2 patches
505- Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
506- Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
507- Tag translations with correct %%lang tags
508
509* Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
510- no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
511
512* Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
513- Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
514
515* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
516- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
517
518* Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
519- Build V8 as a shared library on i686 to allow for swappable backends
520- Build both the x87 version and the SSE2 version of V8 on i686
521- Add the private library directory to the file list on i686
522- Add Provides/Requires filtering for libv8.so (i686) and for plugins
523
524* Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
525- Do not require SSE2 on i686
526
527* Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
528- Drop nss321 backport (and the related nss-headers patch), it did not help
529- Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
530- Update License accordingly (add "OpenSSL")
531- Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
532
533* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
534- Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
535
536* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
537- Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
538
539* Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
540- Unbundle prtime.cc, use the system NSPR instead (which is already required)
541- Unbundle icu_utf.cc, use the system ICU instead (which is already required)
542
543* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
544- linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
545
546* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
547- Build against the system libvpx also on F23 (1.4.0), worked in Copr
548
549* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
550- Use the system libvpx on F24+ (1.5.0)
551- Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
552
553* Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
554- Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
555- Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
556
557* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
558- Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
559- Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
560
561* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
562- Use more specific BuildRequires for docs (thanks to rdieter)
563- Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
564
565* Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
566- Fix License tag
567- Use %%_qt5_examplesdir macro
568- Add Provides: bundled(*) for all the bundled libraries that I found
569
570* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
571- linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
572
573* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
574- linux-pri patch: Add missing newline at the end of the log line
575- Use export for NINJA_PATH (fixes system ninja-build use)
576
577* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
578- Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
579- BR yasm only on x86 (i686, x86_64)
580- Add dot at the end of %%description
581- Rebase no-format patch
582- Replace unbundle-gyp.patch with new linux-pri.patch
583- Use system ninja-build instead of the bundled one
584- Run the unbundling script replace_gyp_files.py in linux.pri rather than here
585- Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
586
587* Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
588- Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
589  pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
590  pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
591  pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
592  perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
593- Add missing explicit BRs on pkgconfig(x11),  pkgconfig(xext),
594  pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
595- Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
596- Fix BR python-devel to python
597- Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
598- Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
599
600* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
601- Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
602
603* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
604- Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
605- Remove unused BR v8-devel (cannot currently be unbundled)
606
607* Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
608- Update to 5.5.1
609- Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
610
611* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
612- Update with unbundle flags. Adapted from original 5.4 Suse package
613- Disable vpx and sqlite as unbundle due some compilation issues
614- Enable verbose build
615
616* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
617- Initial spec
618
619* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
620- Update for official RC1 released packages
Note: See TracBrowser for help on using the repository browser.