source: projects/specs/trunk/q/qt5-qtwebchannel/qt5-qtwebchannel-vl.spec @ 11435

Revision 11435, 5.7 KB checked in by tomop, 6 years ago (diff)

updated Qt5

Line 
1%global qt_module qtwebchannel
2
3%define docs 1
4
5#define prerelease
6
7%global qt5_minorver 5.6
8%global qt5_version 5.6.3
9#global qt5_patchlevel 1
10
11Summary: Qt5 - WebChannel component
12Name:    qt5-%{qt_module}
13Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
14Release: 1%{?_dist_release}
15
16# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
17# See also http://doc.qt.io/qt-5/licensing.html
18License: LGPLv2 with exceptions or GPLv3 with exceptions
19Url: http://qt.io
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
25
26BuildRequires: cmake
27BuildRequires: qt5-qtbase-devel >= %{version}
28BuildRequires: qt5-qtdeclarative-devel >= %{version}
29# Qt5WebSockets package is optional and only needed for some examples
30BuildRequires: qt5-qtwebsockets-devel
31
32BuildRequires: qt5-qtbase-private-devel
33%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
34
35%description
36The Qt WebChannel module provides a library for seamless integration of C++
37and QML applications with HTML/JavaScript clients. Any QObject can be
38published to remote clients, where its public API becomes available.
39
40%package devel
41Summary: Development files for %{name}
42Requires: %{name}%{?_isa} = %{version}-%{release}
43Requires: qt5-qtbase-devel%{?_isa}
44%description devel
45%{summary}.
46
47%if 0%{?docs}
48%package doc
49Summary: API documentation for %{name}
50License: GFDL
51Requires: %{name} = %{version}-%{release}
52BuildRequires: qt5-qdoc
53BuildRequires: qt5-qhelpgenerator
54BuildArch: noarch
55%description doc
56%{summary}.
57%endif
58
59%package examples
60Summary: Programming examples for %{name}
61Requires: %{name}%{?_isa} = %{version}-%{release}
62%description examples
63%{summary}.
64
65
66%prep
67%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
68
69
70%build
71mkdir %{_target_platform}
72pushd %{_target_platform}
73%{qmake_qt5} ..
74
75make %{?_smp_mflags}
76
77%if 0%{?docs}
78# HACK to avoid multilib conflicts in noarch content
79# see also https://bugreports.qt.io/browse/QTBUG-42071
80QT_HASH_SEED=0; export QT_HASH_SEED
81make %{?_smp_mflags} docs
82%endif
83popd
84
85
86%install
87make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
88
89%if 0%{?docs}
90make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
91%endif
92
93## .prl/.la file love
94# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
95pushd %{buildroot}%{_qt5_libdir}
96for prl_file in libQt5*.prl ; do
97  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
98  if [ -f "$(basename ${prl_file} .prl).so" ]; then
99    rm -fv "$(basename ${prl_file} .prl).la"
100    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
101  fi
102done
103popd
104
105
106%post -p /sbin/ldconfig
107%postun -p /sbin/ldconfig
108
109%files
110%license LICENSE.GPL* LICENSE.LGPL*
111%{_qt5_libdir}/libQt5WebChannel.so.5*
112%{_qt5_archdatadir}/qml/QtWebChannel/
113
114%files devel
115%{_qt5_headerdir}/QtWebChannel/
116%{_qt5_libdir}/libQt5WebChannel.so
117%{_qt5_libdir}/libQt5WebChannel.prl
118%dir %{_qt5_libdir}/cmake/Qt5WebChannel/
119%{_qt5_libdir}/cmake/Qt5WebChannel/Qt5WebChannelConfig*.cmake
120%{_qt5_libdir}/pkgconfig/Qt5WebChannel.pc
121%{_qt5_archdatadir}/mkspecs/modules/qt_lib_webchannel*.pri
122
123%if 0%{?docs}
124%files doc
125%license LICENSE.FDL
126%{_qt5_docdir}/%{qt_module}.qch
127%{_qt5_docdir}/%{qt_module}/
128%endif
129
130%if 0%{?_qt5_examplesdir:1}
131%files examples
132%{_qt5_examplesdir}/
133%endif
134
135
136%changelog
137* Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
138- new upstream release.
139
140* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
141- initial build for Vine Linux.
142- new upstream release.
143
144* Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
145- drop pkg-config-style deps, BR: qt5-qtbase-private-devel
146
147* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
148- Update to 5.6.1
149
150* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
151- rebuild
152
153* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
154- rebuild
155
156* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
157- 5.6.0 final release
158
159* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8.rc
160- Update to final RC
161
162* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.7
163- Update RC release
164
165* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.6.rc
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
167
168* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.5.rc
169- update source URL, use %%license, BR: cmake
170
171* Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4
172- Update to final rc release
173
174* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
175- Official rc release
176
177* Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
178- restore bootstrap macro support
179
180* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
181- Start to implement 5.6.0 rc
182
183* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
184- Update for final qt 5.5.1
185
186* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
187- Update to Qt 5.5.1 RC1
188
189* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
190- -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
191
192* Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
193- tighten qtbase dep (#1233829)
194
195* Thu Jul 09 2015 Jan Grulich <jgrulich@redhat.com> - 5.5.0-1
196- 5.5.0
197
198* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
200
201* Sun Jun 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
202- 5.4.2
203
204* Tue Dec 23 2014 Taylor Braun-Jones <taylor.braun-jones@ge.com> - 5.4.0-1
205- Initial release.
Note: See TracBrowser for help on using the repository browser.