source: projects/specs/trunk/q/qt5-qtquick1/qt5-qtquick1-vl.spec @ 10595

Revision 10595, 9.0 KB checked in by tomop, 8 years ago (diff)

qt5-qtquick1-5.6.1-2

Line 
1
2%global qt_module qtquick1
3
4%global commit0 92c847e56d94c9032f3fa83922742e455233e4f3
5%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
6
7Summary: A declarative language for describing user interfaces in Qt5
8Name:    qt5-%{qt_module}
9Version: 5.6.1
10Release: 2.%{shortcommit0}git%{?dist}
11
12# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
13License: LGPLv2 with exceptions or GPLv3 with exceptions
14Url:     http://www.qt.io
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19# The source for this package was pulled from upstream's vcs.  Use the
20# following commands to generate the tarball:
21# git clone git@github.com:qtproject/qtquick1.git && cd qtquick1
22# git archive --prefix=qtquick1-opensource-src-5.6.1/ origin/5.6.1 | tar -x -C ..
23# cd ../qtquick1-opensource-src-5.6.1 && syncqt.pl -version 5.6.1 && cd ..
24# tar cfJ qt5-qtquick1-opensource-src-5.6.1.tar.xz qtquick1-opensource-src-5.6.1/
25Source0: %{qt_module}-opensource-src-%{version}-%{shortcommit0}.tar.xz
26
27BuildRequires: cmake
28BuildRequires: qt5-qtbase-devel >= %{version}
29BuildRequires: qt5-qtscript-devel >= %{version}
30BuildRequires: qt5-qttools-devel
31BuildRequires: qt5-qtwebkit-devel
32BuildRequires: qt5-qtxmlpatterns-devel
33
34BuildRequires: qt5-qtbase-private-devel
35%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
36BuildRequires: qt5-qtscript-private-devel
37%{?_qt5:Requires: qt5-qtscript%{?_isa} = %{_qt5_version}}
38
39%description
40Qt Quick is a collection of technologies that are designed to help
41developers create the kind of intuitive, modern, fluid user interfaces
42that are increasingly used on mobile phones, media players, set-top
43boxes and other portable devices.
44
45Qt Quick consists of a rich set of user interface elements, a declarative
46language for describing user interfaces and a language runtime. A
47collection of C++ APIs is used to integrate these high level features
48with classic Qt applications.
49
50%package devel
51Summary: Development files for %{name}
52Requires: %{name}%{?_isa} = %{version}-%{release}
53Requires: qt5-qtbase-devel%{?_isa}
54%description devel
55%{summary}.
56
57%package examples
58Summary: Programming examples for %{name}
59Requires: %{name}%{?_isa} = %{version}-%{release}
60%description examples
61%{summary}.
62
63
64%prep
65%autosetup -n %{qt_module}-opensource-src-%{version}
66
67
68%build
69mkdir %{_target_platform}
70pushd %{_target_platform}
71%{qmake_qt5} ..
72
73make %{?_smp_mflags}
74
75
76%install
77make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
78
79# hardlink files to %{_bindir}, add -qt5 postfix to not conflict
80mkdir %{buildroot}%{_bindir}
81pushd %{buildroot}%{_qt5_bindir}
82for i in * ; do
83  case "${i}" in
84    # qt4 conflicts
85    qmlviewer)
86      ln -v  ${i} %{buildroot}%{_bindir}/${i}-qt5
87      ln -sv ${i} ${i}-qt5
88      ;;
89    # stuff handled by qtchooser
90    qml1plugindump)
91      ln -v  ${i} %{buildroot}%{_bindir}/${i}
92      ln -v  ${i} %{buildroot}%{_bindir}/${i}-qt5
93      ln -sv ${i} ${i}-qt5
94      ;;
95    *)
96      ln -v  ${i} %{buildroot}%{_bindir}/${i}
97      ;;
98  esac
99done
100popd
101
102## .prl/.la file love
103# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
104pushd %{buildroot}%{_qt5_libdir}
105for prl_file in libQt5*.prl ; do
106  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
107  if [ -f "$(basename ${prl_file} .prl).so" ]; then
108    rm -fv "$(basename ${prl_file} .prl).la"
109    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
110  fi
111done
112popd
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files
118%license LICENSE.LGPL* LGPL_EXCEPTION.txt
119%{_qt5_libdir}/libQt5Declarative.so.5*
120%{_qt5_importdir}/Qt/
121%{_qt5_importdir}/QtWebKit/
122%{_qt5_importdir}/builtins.qmltypes
123%{_qt5_plugindir}/designer/*.so
124%{_qt5_plugindir}/qml1tooling/
125%dir %{_qt5_libdir}/cmake/Qt5Declarative/
126%{_qt5_libdir}/cmake/Qt5Declarative/Qt5Declarative_QTcpServerConnection.cmake
127%{_qt5_libdir}/cmake/Qt5Declarative/Qt5Declarative_QtQuick1Plugin.cmake
128%dir %{_qt5_libdir}/cmake/Qt5Designer/
129%{_qt5_libdir}/cmake/Qt5Designer/Qt5Designer_QDeclarativeViewPlugin.cmake
130
131%files devel
132%{_qt5_bindir}/qml1plugindump*
133%{_qt5_bindir}/qmlviewer*
134%{_bindir}/qml1plugindump*
135%{_bindir}/qmlviewer*
136%{_qt5_headerdir}/QtDeclarative/
137%{_qt5_libdir}/libQt5Declarative.so
138%{_qt5_libdir}/libQt5Declarative.prl
139%{_qt5_libdir}/cmake/Qt5Declarative/Qt5DeclarativeConfig*.cmake
140%{_qt5_libdir}/pkgconfig/Qt5Declarative.pc
141%{_qt5_archdatadir}/mkspecs/modules/qt_lib_declarative*.pri
142
143%if 0%{?_qt5_examplesdir:1}
144%files examples
145%{_qt5_examplesdir}/declarative/
146%endif
147
148
149%changelog
150* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1-2.92c847egit
151- initial build for Vine Linux.
152
153* Fri Jun 10 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-1.92c847egit
154- 5.6.1 branch snapshot
155
156* Fri Jun 10 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.0-5
157- Rebuild (qt5-qtbase)
158
159* Sun Apr 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
160- BR: qt5-qtbase-private-devel qt5-qtscript-private-devel
161
162* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
163- rebuild
164
165* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
166- rebuild
167
168* Wed Mar 16 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8.rc
169- 5.6.0 final release
170
171* Sun Feb 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.7.rc
172- rebuild
173
174* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6
175- Update RC release
176
177* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.5.beta1
178- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
179
180* Thu Jan 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.4.beta1
181- fix Sources
182
183* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.3.beta
184- use %%license, clarify no -docs, BR: cmake
185
186* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
187- Official beta release
188
189* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
190- Start to implement 5.6.0 beta
191
192* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
193- Update to final release 5.5.1
194
195* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
196- Update to Qt 5.5.1 RC1
197
198* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
199- -docs: BuildRequires: qt5-qhelpgenerator
200
201* Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
202- tighten deps (#1233829)
203
204* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
205- New final upstream release Qt 5.5.0
206
207* Wed Jun 17 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
208- Qt 5.5.0 RC1
209
210* Thu Jun 04 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
211- 5.4.2
212
213* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
214- Rebuilt for GCC 5 C++11 ABI change
215
216* Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
217- rebuild (gcc5)
218
219* Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
220- 5.4.1
221
222* Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
223- 5.4.0 (final)
224
225* Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
226- 5.4.0-rc
227
228* Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
229- out-of-tree build, use %%qmake_qt5
230
231* Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
232- 5.4.0-beta
233
234* Wed Sep 17 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-1
235- 5.3.2
236
237* Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org>
238- 5.3.1-3
239- move qml1plugindump, qmlviewer to -devel
240- qml1plugindump-qt5 wrapper (since qtchooser can handle it)
241
242* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
244
245* Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
246- 5.3.1
247
248* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
250
251* Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
252- 5.3.0
253
254* Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
255- use standard (same as qtbase) .prl sanitation
256
257* Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
258- 5.2.1
259
260* Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
261- -examples subpkg
262
263* Thu Dec 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
264- 5.2.0
265
266* Mon Dec 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.10.rc1
267- 5.2.0-rc1
268
269* Sun Nov 10 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.5.beta1
270- rebuild (arm/qreal)
271
272* Thu Oct 24 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.4.beta1
273- 5.2.0-beta1
274
275* Wed Oct 16 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.3.alpha
276- ppc bootstrap
277
278* Wed Oct 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.2.alpha
279- nix -doc (no content)
280
281* Wed Oct 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.1.alpha
282- 5.2.0-alpha
283- -doc subpkg
284
285* Mon Sep 16 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-2
286- %%doc LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt
287- escape macros in comments
288- better %%description/%%summary
289
290* Tue Sep 03 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-1
291- 5.1.1
292
293* Thu May 09 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
294- fix qmlviewer conflict with qt4
295
296* Thu Apr 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-1
297- 5.0.2
298
299* Sat Feb 23 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-1
300- first try
301
Note: See TracBrowser for help on using the repository browser.