source: projects/specs/trunk/q/qt5-qtgraphicaleffects/qt5-qtgraphicaleffects-vl.spec @ 11388

Revision 11388, 6.0 KB checked in by ara_t, 6 years ago (diff)

qt5-*: update to 5.6.3

Line 
1
2%global qt_module qtgraphicaleffects
3
4%define docs 1
5
6#define prerelease
7
8%global qt5_minorver 5.6
9%global qt5_version 5.6.3
10#global qt5_patchlevel 1
11
12Summary: Qt5 - QtGraphicalEffects component
13Name:    qt5-%{qt_module}
14Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
15Release: 1%{?_dist_release}
16
17# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively from qt5-qtbase for details
18License: LGPLv2 with exceptions or GPLv3 with exceptions
19Url:     http://www.qt.io
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
25
26# debuginfo.list ends up empty/blank anyway, since the included qml is *basically* noarch
27# todo: look into making this pkg proper noarch instead
28%global debug_package %{nil}
29
30BuildRequires: qt5-qtbase-devel >= %{version}
31BuildRequires: pkgconfig(Qt5Quick)
32BuildRequires: libmng-devel
33BuildRequires: libtiff-devel
34
35%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
36
37%description
38The Qt Graphical Effects module provides a set of QML types for adding
39visually impressive and configurable effects to user interfaces. Effects
40are visual items that can be added to Qt Quick user interface as UI
41components.
42
43%if 0%{?docs}
44%package doc
45Summary: API documentation for %{name}
46License: GFDL
47Requires: %{name} = %{version}-%{release}
48BuildRequires: qt5-qdoc
49BuildRequires: qt5-qhelpgenerator
50BuildArch: noarch
51%description doc
52%{summary}.
53%endif
54
55
56%prep
57%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
58
59
60%build
61mkdir %{_target_platform}
62pushd %{_target_platform}
63%{qmake_qt5} ..
64
65make %{?_smp_mflags}
66
67%if 0%{?docs}
68make %{?_smp_mflags} docs
69%endif
70popd
71
72
73%install
74make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
75
76%if 0%{?docs}
77make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
78%endif
79
80%files
81%license LGPL_EXCEPTION.txt LICENSE.LGPL*
82%dir %{_qt5_archdatadir}/qml/
83%{_qt5_archdatadir}/qml/QtGraphicalEffects/
84
85%if 0%{?docs}
86%files doc
87%license LICENSE.FDL
88%{_qt5_docdir}/qtgraphicaleffects.qch
89%{_qt5_docdir}/qtgraphicaleffects/
90%endif
91
92
93%changelog
94* Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-1
95- update to 5.6.3
96
97* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
98- new upstream release.
99- initial build for Vine Linux.
100
101* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
102- Update to 5.6.1
103
104* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
105- rebuild
106
107* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
108- rebuild
109
110* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
111- 5.6.0 final release
112
113* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6.rc
114- Update to final RC
115
116* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
117- Update RC release
118
119* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.4.beta
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
121
122* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.3.beta
123- update source URL, use %%license, update source URL
124
125* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
126- Official beta release
127
128* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
129- Start to implement 5.6.0 beta
130
131* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
132- Update to final release 5.5.1
133
134* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
135- Update to Qt 5.5.1 RC1
136
137* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
138- -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
139
140* Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
141- Update for official RC1 released packages
142
143* Wed Jun 17 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
144- Qt 5.5.0 RC1
145
146* Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
147- 5.4.2
148
149* Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
150- rebuild (gcc5)
151
152* Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
153- 5.4.1
154
155* Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
156- 5.4.0 (final)
157
158* Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
159- 5.4.0-rc
160
161* Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
162- out-of-tree build, use %%qmake_qt5
163
164* Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
165- 5.4.0-beta
166
167* Wed Sep 17 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-1
168- 5.3.2
169
170* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
172
173* Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
174- 5.3.1
175
176* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
178
179* Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
180- 5.3.0
181
182* Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
183- 5.2.1
184
185* Thu Dec 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
186- 5.2.0
187
188* Mon Dec 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.10.rc1
189- 5.2.0-rc1
190
191* Sun Nov 10 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.4.beta1
192- rebuild (arm/qreal)
193
194* Thu Oct 24 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.3.beta1
195- 5.2.0-beta1
196
197* Thu Oct 24 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.2.alpha
198- ppc bootstrap
199
200* Wed Oct 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.1.alpha
201- 5.2.0-alpha
202- -doc subpkg
203
204* Thu Aug 29 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-1
205- 5.1.1
206
207* Wed Aug 28 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
208- improved description
209- update Source URL
210- clarify license comment
211- disable -debuginfo
212
213* Thu Apr 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-1
214- 5.0.2
215
216* Sat Feb 23 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-1
217- first try
218
Note: See TracBrowser for help on using the repository browser.