source: projects/specs/trunk/q/qt5-qtenginio/qt5-qtenginio-vl.spec @ 11388

Revision 11388, 4.8 KB checked in by ara_t, 6 years ago (diff)

qt5-*: update to 5.6.3

Line 
1%global qt_module qtenginio
2
3# define to build docs, need to undef this for bootstrapping
4%define docs 1
5
6#define prerelease
7
8Summary: Qt5 - Enginio component
9Name:    qt5-%{qt_module}
10Version: 1.6.3
11Release: 1%{?_dist_release}
12
13# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
14# See also http://doc.qt.io/qt-5/licensing.html
15License: LGPLv2 with exceptions or GPLv3 with exceptions
16Url:     http://www.qt.io
17Source0: http://download.qt.io/official_releases/qt/5.6/5.6.3/submodules/%{qt_module}-opensource-src-%{version}.tar.xz
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22BuildRequires:  qt5-qtbase-devel >= 5.6
23BuildRequires:  qt5-qtdeclarative-devel
24
25%description
26Client library for accessing Enginio service from Qt and QML code.
27
28%package devel
29Summary: Development files for %{name}
30Requires: %{name}%{?_isa} = %{version}-%{release}
31Requires: qt5-qtbase-devel%{?_isa}
32%description devel
33%{summary}.
34
35%if 0%{?docs}
36%package doc
37Summary: API documentation for %{name}
38License: GFDL
39#Requires: %{name} = %{version}-%{release}
40BuildRequires: qt5-qdoc
41BuildRequires: qt5-qhelpgenerator
42BuildArch: noarch
43%description doc
44%{summary}.
45%endif
46
47%package examples
48Summary: Programming examples for %{name}
49Requires: %{name}%{?_isa} = %{version}-%{release}
50%description examples
51%{summary}.
52
53
54%prep
55%setup -q -n %{qt_module}-opensource-src-%{version}
56
57
58%build
59mkdir %{_target_platform}
60pushd %{_target_platform}
61%{qmake_qt5} ..
62
63make %{?_smp_mflags}
64
65%if 0%{?docs}
66# HACK to avoid multilib conflicts in noarch content
67# see also https://bugreports.qt.io/browse/QTBUG-42071
68QT_HASH_SEED=0; export QT_HASH_SEED
69make %{?_smp_mflags} docs
70%endif
71popd
72
73
74%install
75make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
76
77%if 0%{?docs}
78make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
79%endif
80
81## .prl/.la file love
82# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
83pushd %{buildroot}%{_qt5_libdir}
84for prl_file in libEng*.prl ; do
85sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
86if [ -f "$(basename ${prl_file} .prl).so" ]; then
87rm -fv "$(basename ${prl_file} .prl).la"
88sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
89fi
90done
91popd
92
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files
98%license LICENSE* LGPL_EXCEPTION.txt
99%{_qt5_libdir}/libEnginio.so.1*
100%{_qt5_archdatadir}/qml/Enginio/
101
102%files devel
103%{_qt5_headerdir}/Enginio/
104%{_qt5_libdir}/libEnginio.so
105%{_qt5_libdir}/libEnginio.prl
106%dir %{_qt5_libdir}/cmake/Qt5Enginio/
107%{_qt5_libdir}/cmake/Qt5Enginio/Qt5EnginioConfig*.cmake
108%{_qt5_libdir}/pkgconfig/Enginio.pc
109%{_qt5_archdatadir}/mkspecs/modules/qt_lib_enginio*.pri
110
111%if 0%{?docs}
112%files doc
113%{_qt5_docdir}/qtenginio.qch
114%{_qt5_docdir}/qtenginio
115%{_qt5_docdir}/qtenginiooverview.qch
116%{_qt5_docdir}/qtenginiooverview
117%{_qt5_docdir}/qtenginioqml.qch
118%{_qt5_docdir}/qtenginioqml
119%endif
120
121%if 0%{?_qt5_examplesdir:1}
122%files examples
123%{_qt5_examplesdir}/
124%endif
125
126
127%changelog
128* Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 1.6.3-1
129- update to 1.6.3
130
131* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.6.1-3
132- initial build for Vine Linux.
133- dropped Epoch.
134
135* Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.1-2
136- drop pkgconfig-style Qt5 deps
137
138* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> -1:1.6.1-1
139- Update to 1.6.1
140
141* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.0-3
142- rebuild
143
144* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 1:1.6.0-2
145- rebuild
146
147* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 1.6.0-1
148- 1.6.0 final release
149- Epoch to adjust the version
150
151* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.7.rc
152- Update to final RC
153
154* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6
155- Update RC release
156
157* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.5.beta1
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
159
160* Thu Jan 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.4.beta1
161- Fix Release, Fix sources, -docs: fix deps
162
163* Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
164- Update to final beta release
165
166* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
167- Official beta release
168
169* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
170- Start to implement 5.6.0 beta
171
172* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
173- Update to final release 5.5.1
174
175* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
176- Update to Qt 5.5.1 RC1
177
178* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
179- New final upstream release Qt 5.5.0
180
181* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
182- Update for official RC1 released packages
183
184* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.1.rc
185- First release
Note: See TracBrowser for help on using the repository browser.