source: projects/specs/trunk/q/qt5-qtdeclarative/qt5-qtdeclarative-vl.spec @ 10586

Revision 10586, 16.1 KB checked in by tomop, 8 years ago (diff)

new: qt5-5.6.1.1-1

Line 
1
2%global qt_module qtdeclarative
3
4# define to build docs, need to undef this for bootstrapping
5# where qt5-qttools builds are not yet available
6# only primary archs (for now), allow secondary to bootstrap
7#global bootstrap 1
8
9%if ! 0%{?bootstrap}
10%ifarch %{arm} %{ix86} x86_64
11%global docs 1
12#global tests 1
13%endif
14%endif
15
16%global nosse2_hack 1
17## TODO:
18# * consider debian's approach of runtime detection instead:
19#   https://codereview.qt-project.org/#/c/127354/
20
21#define prerelease
22
23%global qt5_minorver 5.6
24%global qt5_version 5.6.1
25%global qt5_patchlevel 1
26
27Summary: Qt5 - QtDeclarative component
28Name:    qt5-%{qt_module}
29Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
30Release: 1%{?_dist_release}
31
32# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
33License: LGPLv2 with exceptions or GPLv3 with exceptions
34Url:     http://www.qt.io
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
40
41# support no_sse2 CONFIG (fedora i686 builds cannot assume -march=pentium4 -msse2 -mfpmath=sse flags, or the JIT that needs them)
42# https://codereview.qt-project.org/#change,73710
43Patch1: qtdeclarative-opensource-src-5.5.0-no_sse2.patch
44
45# workaround for possible deadlock condition in QQuickShaderEffectSource
46# https://bugzilla.redhat.com/show_bug.cgi?id=1237269
47# https://bugs.kde.org/show_bug.cgi?id=348385
48Patch2: qtdeclarative-QQuickShaderEffectSource_deadlock.patch
49
50## upstream patches
51Patch7: 0007-Revert-Remove-this-piece-of-code.patch
52Patch10: 0010-Fix-crash-for-unknown-QQmlListModel-roles-in-debug-b.patch
53Patch11: 0011-Avoid-Canvas-crashes-with-qtquickcompiler.patch
54Patch16: 0016-Fix-crash-with-SignalTransition.patch
55Patch24: 0024-Revert-removal-of-Fixed-MouseArea-threshold-with-pre.patch
56Patch27: 0027-Fix-crash-when-using-with-statement-with-an-expressi.patch
57
58## upstreamable patches
59# use system double-conversation
60%if 0%{?fedora} || 0%{?rhel} > 6
61%global system_doubleconv 1
62BuildRequires: double-conversion-devel
63%endif
64Patch200: qtdeclarative-system_doubleconv.patch
65# https://bugs.kde.org/show_bug.cgi?id=346118#c108
66Patch201: qtdeclarative-kdebug346118.patch
67# additional i686/qml workaround (on top of existing patch135),  https://bugzilla.redhat.com/1331593
68Patch235: qtdeclarative-opensource-src-5.6.0-qml_no-lifetime-dse.patch
69
70## upstream patches under review
71# Check-for-NULL-from-glGetStrin
72Patch500: Check-for-NULL-from-glGetString.patch
73
74Obsoletes: qt5-qtjsbackend < 5.2.0
75
76BuildRequires: cmake
77BuildRequires: qt5-qtbase-devel >= %{version}
78BuildRequires: qt5-qtbase-private-devel
79%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
80%if ! 0%{?bootstrap}
81BuildRequires: qt5-qtxmlpatterns-devel
82%endif
83BuildRequires: python
84
85%if 0%{?tests}
86BuildRequires: dbus-x11
87BuildRequires: mesa-dri-drivers
88BuildRequires: time
89BuildRequires: xorg-x11-server-Xvfb
90%endif
91
92
93%description
94%{summary}.
95
96%package devel
97Summary: Development files for %{name}
98Obsoletes: qt5-qtjsbackend-devel < 5.2.0
99Provides:  %{name}-private-devel = %{version}-%{release}
100Requires: %{name}%{?_isa} = %{version}-%{release}
101Requires: qt5-qtbase-devel%{?_isa}
102%description devel
103%{summary}.
104
105%package static
106Summary: Static library files for %{name}
107Requires: %{name}-devel%{?_isa} = %{version}-%{release}
108%description static
109%{summary}.
110
111%if 0%{?docs}
112%package doc
113Summary: API documentation for %{name}
114License: GFDL
115Requires: %{name} = %{version}-%{release}
116BuildRequires: qt5-qdoc
117BuildRequires: qt5-qhelpgenerator
118BuildArch: noarch
119%description doc
120%{summary}.
121%endif
122
123%package examples
124Summary: Programming examples for %{name}
125Requires: %{name}%{?_isa} = %{version}-%{release}
126%description examples
127%{summary}.
128
129
130%prep
131%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
132%if 0%{?nosse2_hack}
133%patch1 -p1 -b .no_sse2
134%endif
135%patch2 -p1 -b .QQuickShaderEffectSource_deadlock
136
137%patch7 -p1 -b .0007
138%patch10 -p1 -b .0010
139%patch11 -p1 -b .0011
140%patch16 -p1 -b .0016
141%patch24 -p1 -b .0024
142%patch27 -p1 -b .0027
143
144%if 0%{?system_doubleconv}
145%patch200 -p1 -b .system_doubleconv
146rm -rfv src/3rdparty/double-conversion
147%endif
148%patch201 -p0 -b .kdebug346118
149%patch235 -p1 -b .qml_no-lifetime-dse
150
151%patch500 -p1 -b .Check-for-NULL-from-glGetString
152
153
154%build
155mkdir %{_target_platform}
156pushd %{_target_platform}
157%{qmake_qt5} ..
158popd
159
160make %{?_smp_mflags} -C %{_target_platform}
161
162%if 0%{?nosse2_hack}
163# build libQt5Qml with no_sse2
164mkdir -p %{_target_platform}-no_sse2
165pushd    %{_target_platform}-no_sse2
166%{qmake_qt5} -config no_sse2 ..
167make sub-src-clean
168make %{?_smp_mflags} -C src/qml
169popd
170%endif
171
172%if 0%{?docs}
173make %{?_smp_mflags} docs -C %{_target_platform}
174%endif
175
176
177%install
178rm -rf %{buildroot}
179make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
180
181%if 0%{?nosse2_hack}
182mkdir -p %{buildroot}%{_qt5_libdir}/sse2
183mv %{buildroot}%{_qt5_libdir}/libQt5Qml.so.5* %{buildroot}%{_qt5_libdir}/sse2/
184make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}-no_sse2/src/qml
185%endif
186
187%if 0%{?docs}
188make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
189%endif
190
191# hardlink files to %{_bindir}, add -qt5 postfix to not conflict
192mkdir %{buildroot}%{_bindir}
193pushd %{buildroot}%{_qt5_bindir}
194for i in * ; do
195  case "${i}" in
196    # qt4 conflicts
197    qmlplugindump|qmlprofiler)
198      ln -v  ${i} %{buildroot}%{_bindir}/${i}-qt5
199      ln -sv ${i} ${i}-qt5
200      ;;
201    # qtchooser stuff
202    qml|qmlbundle|qmlmin|qmlscene)
203      ln -v  ${i} %{buildroot}%{_bindir}/${i}
204      ln -v  ${i} %{buildroot}%{_bindir}/${i}-qt5
205      ln -sv ${i} ${i}-qt5
206      ;;
207    *)
208      ln -v  ${i} %{buildroot}%{_bindir}/${i}
209      ;;
210  esac
211done
212popd
213
214## .prl/.la file love
215# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
216pushd %{buildroot}%{_qt5_libdir}
217for prl_file in libQt5*.prl ; do
218  sed -i \
219    -e "/^QMAKE_PRL_BUILD_DIR/d" \
220    -e "/-ldouble-conversion/d" \
221    ${prl_file}
222  if [ -f "$(basename ${prl_file} .prl).so" ]; then
223    rm -fv "$(basename ${prl_file} .prl).la"
224  else
225    sed -i \
226       -e "/^QMAKE_PRL_LIBS/d" \
227       -e "/-ldouble-conversion/d" \
228       $(basename ${prl_file} .prl).la
229  fi
230done
231popd
232
233
234%check
235test -z "$(grep double-conversion %{buildroot}%{_qt5_libdir}/*.{la,prl})"
236%if 0%{?tests}
237export CTEST_OUTPUT_ON_FAILURE=1
238export PATH=%{buildroot}%{_qt5_bindir}:$PATH
239export LD_LIBRARY_PATH=%{buildroot}%{_qt5_libdir}
240make sub-tests-all %{?_smp_mflags} -C %{_target_platform}
241xvfb-run -a \
242dbus-launch --exit-with-session \
243time \
244make check -k -C %{_target_platform}/tests ||:
245%endif
246
247
248%post -p /sbin/ldconfig
249%postun -p /sbin/ldconfig
250
251%files
252%{!?_licensedir:%global license %%doc}
253%license LICENSE.LGPL* LGPL_EXCEPTION.txt
254%{_qt5_libdir}/libQt5Qml.so.5*
255%if 0%{?nosse2_hack}
256%{_qt5_libdir}/sse2/libQt5Qml.so.5*
257%endif
258%{_qt5_libdir}/libQt5Quick.so.5*
259%{_qt5_libdir}/libQt5QuickWidgets.so.5*
260%{_qt5_libdir}/libQt5QuickParticles.so.5*
261%{_qt5_libdir}/libQt5QuickTest.so.5*
262%{_qt5_plugindir}/qmltooling/
263%{_qt5_archdatadir}/qml/
264%dir %{_qt5_libdir}/cmake/Qt5Qml/
265%{_qt5_libdir}/cmake/Qt5Qml/Qt5Qml_*Factory.cmake
266
267%files devel
268%{_bindir}/qml*
269%{_qt5_bindir}/qml*
270%{_qt5_headerdir}/Qt*/
271%{_qt5_libdir}/libQt5Qml.so
272%{_qt5_libdir}/libQt5Qml.prl
273%{_qt5_libdir}/libQt5Quick*.so
274%{_qt5_libdir}/libQt5Quick*.prl
275%dir %{_qt5_libdir}/cmake/Qt5Quick*/
276%{_qt5_libdir}/cmake/Qt5*/Qt5*Config*.cmake
277%{_qt5_libdir}/pkgconfig/Qt5*.pc
278%{_qt5_archdatadir}/mkspecs/modules/*.pri
279
280%files static
281%{_qt5_libdir}/libQt5QmlDevTools.*a
282%{_qt5_libdir}/libQt5QmlDevTools.prl
283
284%if 0%{?docs}
285%files doc
286%license LICENSE.FDL
287%{_qt5_docdir}/qtqml.qch
288%{_qt5_docdir}/qtqml/
289%{_qt5_docdir}/qtquick.qch
290%{_qt5_docdir}/qtquick/
291%endif
292
293%files examples
294%{_qt5_examplesdir}/
295
296
297%changelog
298* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
299- new upstream release.
300- initial build for Vine Linux.
301
302* Thu Jun 16 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.1-5
303- backport 5.6 branch fixes
304
305* Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-4
306- drop pkgconfig-style Qt5 deps
307
308* Wed Jun 15 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-3
309- Apply no_sse2 hack to all architecturs to make qt5-qtdeclarative-devel multilib-clean
310
311* Fri Jun 10 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
312- strip double-conversion references from .la/.prl files
313
314* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
315- Update to 5.6.1
316
317* Thu Jun 02 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-12
318- pull in upstream qml/jsruntime workaround (ie, apply compiler workarounds only for src/qml/)
319
320* Tue May 31 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-11
321- include crasher workaround (#1259472,kde#346118)
322
323* Sat May 28 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-10
324- macro'ize no_sse2 hack (to make it easier to enable/disable)
325- re-introduce -fno-delete-null-pointer-checks here (following upstream)
326- add -fno-lifetime-dse too, helps fix i686/qml crasher (#1331593)
327- disable tests (for now, not useful yet)
328
329* Fri May 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-9
330- Use system double-conversion (#1078524)
331
332* Thu May 19 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
333- -devel: don't own libQt5QuickWidgets.so.5 (#1337621)
334
335* Thu May 05 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
336- BR: mesa-dri-drivers (tests)
337
338* Thu May 05 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-6
339- drop local -fno-delete-null-pointer-checks hack, used in all Qt5 builds now
340- add %%check
341
342* Sun Apr 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-5
343- BR: qt5-qtbase-private-devel, -devel: Provides: -private-devel
344
345* Fri Mar 25 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
346- backport upstream fixes
347- drop -fno-delete-null-pointer-checks hack (included in qt5-rpm-macros as needed now)
348
349* Sat Mar 19 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
350- BR: cmake (cmake autoprovides)
351
352* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
353- rebuild
354
355* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
356- 5.6.0 final release
357
358* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.11.rc
359- Update to final RC
360
361* Mon Feb 22 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10
362- Update RC tarball from git
363
364* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.9
365- Update RC release
366
367* Tue Feb 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.8.beta
368- build with -fno-delete-null-pointer-checks to workaround gcc6-related runtime crashes (#1303643)
369
370* Thu Jan 28 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.7.beta
371- backport fix for older compilers (aka rhel6)
372
373* Sun Jan 17 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
374- use %%license
375
376* Mon Dec 21 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.5.beta
377- fix Source URL, Release: tag
378
379* Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4
380- Update to final beta release
381
382* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
383- Official beta release
384
385* Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
386- de-bootstrap
387
388* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
389- Start to implement 5.6.0 beta, bootstrap
390
391* Sat Oct 24 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-3
392- workaround QQuickShaderEffectSource::updatePaintNode deadlock (#1237269, kde#348385)
393
394* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
395- Update to final release 5.5.1
396
397* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
398- Update to Qt 5.5.1 RC1
399
400* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
401- -docs: BuildRequires: qt5-qhelpgenerator
402
403* Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
404- tighten qtbase dep (#1233829), .spec cosmetics
405
406* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
407- New final upstream release Qt 5.5.0
408
409* Mon Jun 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.4.rc
410- Second round of builds now with bootstrap enabled due new qttools
411
412* Sat Jun 27 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.3.rc
413- Disable bootstrap
414
415* Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
416- Update for official RC1 released packages
417
418* Mon Jun 08 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-2
419- restore fix for QTBUG-45753/kde-345544 lost in 5.4.2 rebase
420
421* Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> 5.4.2-1
422- 5.4.2
423
424* Sat May 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-4
425- pull in some upstream fixes, for QTBUG-45753/kde-345544 in particular
426
427* Wed Apr 22 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.4.1-3
428- fix non-sse2 support (kde#346244) and optimize sse2 binaries
429
430* Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
431- rebuild (gcc5)
432
433* Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
434- 5.4.1
435
436* Mon Feb 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-3
437- rebuild (gcc)
438
439* Sat Feb 14 2015 Ville Skyttä <ville.skytta@iki.fi> - 5.4.0-2
440- Fix cmake dir ownerhips
441
442* Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
443- 5.4.0 (final)
444
445* Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
446- 5.4.0-rc
447
448* Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
449- use new %%qmake_qt5 macro
450
451* Sat Oct 18 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4.0-0.1.beta
452- 5.4.0-beta
453- %%ix84: drop sse2-optimized bits, need to rethink if/how to support it now
454
455* Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
456- 5.3.2
457
458* Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.1-3
459- -qt5 wrappers for qml qmlbundle qmlmin qmlscene
460
461* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
462- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
463
464* Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
465- 5.3.1
466
467* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
468- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
469
470* Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
471- 5.3.0
472
473* Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
474- 5.2.1
475
476* Sun Feb 02 2014 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> 5.2.0-6
477- Add AArch64 support (RHBUG: 1040452, QTBUG-35528)
478
479* Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-5
480- build -examples only if supported
481
482* Sun Jan 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-4
483- -examples subpkg
484
485* Tue Jan 14 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
486- epel7 bootstrapped
487
488* Mon Jan 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
489- BR: qt5-qtxmlpatterns-devel (#1048558)
490
491* Thu Dec 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
492- 5.2.0
493
494* Tue Dec 10 2013 Rex Dieter <rdieter@fedoraproject.org> - 5.2.0-0.12.rc1
495- support out-of-src-tree builds
496- %%ix86: install sse2/jit version to %%_qt5_libdir/sse2/
497
498* Thu Dec 05 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.11.rc1
499- %%ix86: cannot assume sse2 (and related support) or the JIT that requires it...  disable.
500
501* Mon Dec 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.10.rc1
502- 5.2.0-rc1
503
504* Mon Nov 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.5.beta1
505- enable -doc only on primary archs (allow secondary bootstrap)
506
507* Sat Nov 09 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.4.beta1
508- rebuild (arm/qreal)
509
510* Thu Oct 24 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.3.beta1
511- 5.2.0-beta1
512
513* Wed Oct 16 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.2.alpha
514- bootstrap ppc
515
516* Tue Oct 01 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.1.alpha
517- 5.2.0-alpha
518- Obsoletes: qt5-qtjsbackend
519- -doc subpkg
520
521* Wed Aug 28 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-1
522- 5.1.1
523
524* Tue Aug 20 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-4
525- qt5-qtjsbackend only supports ix86, x86_64 and arm
526
527* Tue May 14 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-3
528- fix qmlprofiler conflict with qt-creator
529
530* Fri Apr 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
531- fix qmlplugindump conflict with qt4-devel
532- include license files, dist/changes*
533
534* Thu Apr 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-1
535- 5.0.2
536
537* Sat Feb 23 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-1
538- first try
539
Note: See TracBrowser for help on using the repository browser.