source: projects/specs/trunk/q/qt5-qtconnectivity/qt5-qtconnectivity-vl.spec @ 10586

Revision 10586, 7.3 KB checked in by tomop, 8 years ago (diff)

new: qt5-5.6.1.1-1

Line 
1
2%global qt_module qtconnectivity
3
4%define docs 1
5
6#define prerelease
7
8%global qt5_minorver 5.6
9%global qt5_version 5.6.1
10%global qt5_patchlevel 1
11
12Summary: Qt5 - Connectivity components
13Name:    qt5-%{qt_module}
14Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
15Release: 1%{?_dist_release}
16
17# See LICENSE.GPL3, respectively, for exception details
18License: LGPLv2 with exceptions or GPLv3 with exceptions
19Url:     http://qt.io
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
25
26## upstreamable patches
27# bswap_16 apparently missing on el6/ppc64
28Patch50: qtconnectivity-opensource-src-5.4.0-bswap_16.patch
29
30BuildRequires: cmake
31BuildRequires: qt5-qtbase-devel >= %{version}
32BuildRequires: qt5-qtdeclarative-devel
33BuildRequires: pkgconfig(bluez)
34
35%{?_qt5:Requires: %{_qt5}%{?_isa} >= %{_qt5_version}}
36
37%description
38%{summary}.
39
40%package devel
41Summary: Development files for %{name}
42Requires: %{name}%{?_isa} = %{version}-%{release}
43Requires: qt5-qtbase-devel%{?_isa}
44%description devel
45%{summary}.
46
47%if 0%{?docs}
48%package doc
49Summary: API documentation for %{name}
50Requires: %{name} = %{version}-%{release}
51BuildRequires: qt5-qdoc
52BuildRequires: qt5-qhelpgenerator
53BuildArch: noarch
54%description doc
55%{summary}.
56%endif
57
58%package examples
59Summary: Programming examples for %{name}
60Requires: %{name}%{?_isa} = %{version}-%{release}
61%description examples
62%{summary}.
63
64
65%prep
66%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
67%patch50 -p1 -b .bswap_16
68
69
70%build
71mkdir %{_target_platform}
72pushd %{_target_platform}
73%{qmake_qt5} ..
74
75make %{?_smp_mflags}
76
77%if 0%{?docs}
78make %{?_smp_mflags} docs
79%endif
80popd
81
82
83%install
84make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
85
86%if 0%{?docs}
87make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
88%endif
89
90# hardlink files to %{_bindir}, add -qt5 postfix to not conflict
91mkdir %{buildroot}%{_bindir}
92pushd %{buildroot}%{_qt5_bindir}
93for i in * ; do
94  case "${i}" in
95    *)
96      ln -v  ${i} %{buildroot}%{_bindir}/${i}
97      ;;
98  esac
99done
100popd
101
102## .prl/.la file love
103# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
104pushd %{buildroot}%{_qt5_libdir}
105for prl_file in libQt5*.prl ; do
106  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
107  if [ -f "$(basename ${prl_file} .prl).so" ]; then
108    rm -fv "$(basename ${prl_file} .prl).la"
109    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
110  fi
111done
112popd
113
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%files
119%license LICENSE.GPL* LICENSE.LGPL*
120%{_bindir}/sdpscanner
121%{_qt5_bindir}/sdpscanner
122%{_qt5_libdir}/libQt5Bluetooth.so.5*
123%{_qt5_archdatadir}/qml/QtBluetooth/
124%{_qt5_libdir}/libQt5Nfc.so.5*
125%{_qt5_archdatadir}/qml/QtNfc/
126
127%files devel
128%{_qt5_headerdir}/QtBluetooth/
129%{_qt5_libdir}/libQt5Bluetooth.so
130%{_qt5_libdir}/libQt5Bluetooth.prl
131%dir %{_qt5_libdir}/cmake/Qt5Bluetooth/
132%{_qt5_libdir}/cmake/Qt5Bluetooth/Qt5BluetoothConfig*.cmake
133%{_qt5_libdir}/pkgconfig/Qt5Bluetooth.pc
134%{_qt5_archdatadir}/mkspecs/modules/qt_lib_bluetooth*.pri
135%{_qt5_headerdir}/QtNfc/
136%{_qt5_libdir}/libQt5Nfc.so
137%{_qt5_libdir}/libQt5Nfc.prl
138%dir %{_qt5_libdir}/cmake/Qt5Nfc/
139%{_qt5_libdir}/cmake/Qt5Nfc/Qt5NfcConfig*.cmake
140%{_qt5_libdir}/pkgconfig/Qt5Nfc.pc
141%{_qt5_archdatadir}/mkspecs/modules/qt_lib_nfc*.pri
142
143%if 0%{?docs}
144%files doc
145%license LICENSE.FDL
146%{_qt5_docdir}/qtbluetooth.qch
147%{_qt5_docdir}/qtbluetooth/
148%{_qt5_docdir}/qtnfc.qch
149%{_qt5_docdir}/qtnfc/
150%endif
151
152%if 0%{?_qt5_examplesdir:1}
153%files examples
154%{_qt5_examplesdir}/
155%endif
156
157
158%changelog
159* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
160- new upstream release.
161- initial build for Vine Linux.
162
163* Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
164- drop pkgconfig-style deps
165
166* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
167- Update to 5.6.1
168
169* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
170- rebuild
171
172* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
173- rebuild
174
175* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
176- rebuild
177
178* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
179- 5.6.0 final release
180
181* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.7.rc
182- Update to final RC
183
184* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6
185- Update RC release
186
187* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.5.beta
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
189
190* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.4.beta
191- BR: cmake, use %%license, update Source URL
192
193* Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
194- Update to final beta release
195
196* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
197- Official beta release
198
199* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
200- Start to implement 5.6.0 beta
201
202* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
203- Update to final release 5.5.1
204
205* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
206- Update to Qt 5.5.1 RC1
207
208* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-4
209- -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping macros
210
211* Sun Jul 26 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-3
212- Enabled docs
213
214* Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
215- cleaner qtbase dep, .spec cosmetics
216
217* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
218- New final upstream release Qt 5.5.0
219
220* Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
221- Update for official RC1 released packages
222
223* Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
224- Qt 5.5.0 RC1
225
226* Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> -5.4.2-1
227- 5.4.2
228
229* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
230- Rebuilt for GCC 5 C++11 ABI change
231
232* Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
233- rebuild (gcc5)
234
235* Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
236- 5.4.1
237
238* Fri Jan 02 2015 Dan Horák <dan[at]danny.cz> 5.4.0-2
239- include the bswap patch in F-20 and F-21 builds too
240
241* Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
242- 5.4.0 (final)
243
244* Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
245- 5.4.0-rc
246
247* Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
248- out-of-tree build, use %%qmake_qt5
249
250* Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
251- 5.4.0-beta
252
253* Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
254- 5.3.2
255
256* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
258
259* Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
260- 5.3.1
261
262* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
264
265* Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
266- 5.3.0
267
268* Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
269- sanitize .prl files
270
271* Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
272- 5.2.1
273
274* Thu Jan 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
275- first try
Note: See TracBrowser for help on using the repository browser.