source: projects/specs/trunk/q/qt5-qtcanvas3d/qt5-qtcanvas3d-vl.spec @ 11388

Revision 11388, 3.9 KB checked in by ara_t, 6 years ago (diff)

qt5-*: update to 5.6.3

Line 
1%global qt_module qtcanvas3d
2
3%define docs 1
4
5#define prerelease
6
7%global qt5_minorver 5.6
8%global qt5_version 5.6.3
9#global qt5_patchlevel 1
10
11Summary: Qt5 - Canvas3d component
12Name:    qt5-%{qt_module}
13Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
14Release: 1%{?_dist_release}
15
16License: LGPLv2 with exceptions or GPLv3 with exceptions
17Url:     http://www.qt.io
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
23
24BuildRequires:  qt5-qtbase-devel >= %{version}
25BuildRequires:  qt5-qtbase-static >= %{version}
26BuildRequires:  pkgconfig(Qt5Quick)
27BuildRequires:  pkgconfig(Qt5Qml)
28
29%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
30
31%description
32Qt5 Canvas3D component
33
34%if 0%{?docs}
35%package doc
36Summary: API documentation for %{name}
37License: GFDL
38Requires: %{name} = %{version}-%{release}
39BuildRequires: qt5-qdoc
40BuildRequires: qt5-qhelpgenerator
41BuildArch: noarch
42%description doc
43%{summary}.
44%endif
45
46%package examples
47Summary: Programming examples for %{name}
48Requires: %{name}%{?_isa} = %{version}-%{release}
49%description examples
50%{summary}.
51
52
53%prep
54%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
55
56
57%build
58mkdir %{_target_platform}
59pushd %{_target_platform}
60%{qmake_qt5} ..
61
62make %{?_smp_mflags}
63
64%if 0%{?docs}
65# HACK to avoid multilib conflicts in noarch content
66# see also https://bugreports.qt-project.org/browse/QTBUG-42071
67QT_HASH_SEED=0; export QT_HASH_SEED
68make %{?_smp_mflags} docs
69%endif
70popd
71
72%install
73make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
74
75%if 0%{?docs}
76make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
77%endif
78
79
80%files
81%license LICENSE.*
82%{_qt5_archdatadir}/qml/QtCanvas3D/
83
84%if 0%{?docs}
85%files doc
86%{_qt5_docdir}/%{qt_module}.qch
87%{_qt5_docdir}/%{qt_module}/
88%endif
89
90%if 0%{?_qt5_examplesdir:1}
91%files examples
92%{_qt5_examplesdir}/canvas3d/
93%endif
94
95
96%changelog
97* Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-1
98- update to 5.6.3
99
100* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
101- new upstream release.
102- initial build for Vine Linux.
103
104* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
105- Update to 5.6.1
106
107* Wed Jun 01 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
108- restore -doc pkg (#1341457)
109
110* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
111- rebuild
112
113* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
114- rebuild
115
116* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
117- 5.6.0 final release
118
119* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6.rc
120- Update to final RC
121
122* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
123- Update RC release
124
125* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.4.beta
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
127
128* Wed Jan 27 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.3.beta
129- respin sources, use %%license, update URLs, fix -doc BR's, drop unneeded scriptlets
130
131* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
132- Official beta release
133
134* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
135- Start to implement 5.6.0 beta
136
137* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
138- Start to implement 5.6.0 beta
139
140* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
141- Update to final release 5.5.1
142
143* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
144- Update to Qt 5.5.1 RC1
145
146* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
147- New final upstream release Qt 5.5.0
148
149* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
150- Update for official RC1 released packages
151
152* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.1.rc
153- Initial release
Note: See TracBrowser for help on using the repository browser.