source: projects/specs/trunk/q/qt5-qt3d/qt5-qt3d-vl.spec @ 11388

Revision 11388, 6.8 KB checked in by ara_t, 6 years ago (diff)

qt5-*: update to 5.6.3

Line 
1%global qt_module qt3d
2
3%define docs 1
4
5#define prerelease
6
7%global qt5_minorver 5.6
8%global qt5_version 5.6.3
9#global qt5_patchlevel 1
10
11Summary: Qt5 - Qt3D QML bindings and C++ APIs
12Name:    qt5-%{qt_module}
13Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
14Release: 1%{?_dist_release}
15
16# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
17# See also http://doc.qt.io/qt-5/licensing.html
18License: LGPLv2 with exceptions or GPLv3 with exceptions
19Url:     http://www.qt.io
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
25
26BuildRequires:  cmake
27BuildRequires:  qt5-qtbase-static >= %{version}
28BuildRequires:  pkgconfig(Qt5Quick)
29BuildRequires:  pkgconfig(Qt5XmlPatterns)
30BuildRequires:  pkgconfig(Qt5Qml)
31BuildRequires:  pkgconfig(Qt5Network)
32BuildRequires:  pkgconfig(Qt5Core)
33BuildRequires:  pkgconfig(Qt5XmlPatterns)
34BuildRequires:  pkgconfig(Qt5OpenGL)
35BuildRequires:  pkgconfig(assimp)
36
37Requires:       qt5-qtimageformats%{?_isa} >= %{version}
38
39%{?_qt5:Requires: %{_qt5}%{?_isa} >= %{_qt5_version}}
40
41%description
42Qt 3D provides functionality for near-realtime simulation systems with
43support for 2D and 3D rendering in both Qt C++ and Qt Quick applications).
44
45%package devel
46Summary: Development files for %{name}
47Requires: %{name}%{?_isa} = %{version}-%{release}
48Requires: qt5-qtbase-devel%{?_isa}
49%description devel
50%{summary}.
51
52%if 0%{?docs}
53%package doc
54Summary: API documentation for %{name}
55License: GFDL
56Requires: %{name} = %{version}-%{release}
57BuildRequires: qt5-qdoc
58BuildRequires: qt5-qhelpgenerator
59BuildArch: noarch
60%description doc
61%{summary}.
62%endif
63
64%package examples
65Summary: Programming examples for %{name}
66Requires: %{name}%{?_isa} = %{version}-%{release}
67%description examples
68%{summary}.
69
70
71%prep
72%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
73
74
75%build
76mkdir %{_target_platform}
77pushd %{_target_platform}
78%{qmake_qt5} ..
79
80make %{?_smp_mflags}
81
82%if 0%{?docs}
83# HACK to avoid multilib conflicts in noarch content
84# see also https://bugreports.qt-project.org/browse/QTBUG-42071
85QT_HASH_SEED=0; export QT_HASH_SEED
86make %{?_smp_mflags} docs
87%endif
88popd
89
90%install
91make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
92
93%if 0%{?docs}
94make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
95%endif
96
97## .prl/.la file love
98# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
99pushd %{buildroot}%{_qt5_libdir}
100for prl_file in libQt5*.prl ; do
101  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
102  if [ -f "$(basename ${prl_file} .prl).so" ]; then
103    rm -fv "$(basename ${prl_file} .prl).la"
104    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
105  fi
106done
107popd
108
109%post -p /sbin/ldconfig
110%postun -p /sbin/ldconfig
111
112%files
113%license LICENSE.GPL* LICENSE.LGPL*
114%{_qt5_libdir}/libQt53DQuick.so.5*
115%{_qt5_libdir}/libQt53DInput.so.5*
116%{_qt5_libdir}/libQt53DQuickRender.so.5*
117%{_qt5_libdir}/libQt53DRender.so.5*
118%{_qt5_libdir}/libQt53DCore.so.5*
119%{_qt5_libdir}/libQt53DLogic.so.5*
120%{_qt5_libdir}/libQt53DQuickInput.so.5*
121%{_qt5_archdatadir}/qml/Qt3D/
122%{_qt5_archdatadir}/qml/QtQuick/Scene3D
123%{_qt5_plugindir}/sceneparsers/libassimpsceneparser.so
124%{_qt5_plugindir}/sceneparsers/libgltfsceneparser.so
125
126%files devel
127%{_qt5_bindir}/qgltf
128%{_qt5_libdir}/libQt53DQuick.so
129%{_qt5_libdir}/libQt53DQuick.prl
130%{_qt5_libdir}/cmake/Qt53DQuick
131%{_qt5_headerdir}/Qt3DQuick
132%{_qt5_libdir}/pkgconfig/Qt53DQuick.pc
133%{_qt5_libdir}/libQt53DInput.so
134%{_qt5_libdir}/libQt53DInput.prl
135%{_qt5_libdir}/cmake/Qt53DInput
136%{_qt5_headerdir}/Qt3DInput/
137%{_qt5_libdir}/pkgconfig/Qt53DInput.pc
138%{_qt5_libdir}/libQt53DCore.so
139%{_qt5_libdir}/libQt53DCore.prl
140%{_qt5_libdir}/cmake/Qt53DCore/
141%{_qt5_headerdir}/Qt3DCore/
142%{_qt5_libdir}/pkgconfig/Qt53DCore.pc
143%{_qt5_libdir}/libQt53DQuickRender.so
144%{_qt5_libdir}/libQt53DQuickRender.prl
145%{_qt5_libdir}/cmake/Qt53DQuickRender/
146%{_qt5_headerdir}/Qt3DQuickRender/
147%{_qt5_libdir}/pkgconfig/Qt53DQuickRender.pc
148%{_qt5_libdir}/libQt53DRender.so
149%{_qt5_libdir}/libQt53DRender.prl
150%{_qt5_libdir}/cmake/Qt53DRender/
151%{_qt5_headerdir}/Qt3DRender/
152%{_qt5_libdir}/pkgconfig/Qt53DRender.pc
153%{_qt5_archdatadir}/mkspecs/modules/*.pri
154%{_qt5_libdir}/libQt53DLogic.so
155%{_qt5_libdir}/libQt53DLogic.prl
156%{_qt5_headerdir}/Qt3DLogic/
157%{_qt5_libdir}/cmake/Qt53DLogic
158%{_qt5_libdir}/pkgconfig/Qt53DLogic.pc
159%{_qt5_libdir}/libQt53DQuickInput.so
160%{_qt5_libdir}/libQt53DQuickInput.prl
161%{_qt5_headerdir}/Qt3DQuickInput/
162%{_qt5_libdir}/cmake/Qt53DQuickInput
163%{_qt5_libdir}/pkgconfig/Qt53DQuickInput.pc
164
165%if 0%{?docs}
166%files doc
167%{_qt5_docdir}/*
168%endif
169
170%if 0%{?_qt5_examplesdir:1}
171%files examples
172%{_qt5_examplesdir}/
173%endif
174
175
176%changelog
177* Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-1
178- update to 5.6.3
179
180* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
181- new upstream release.
182- initial build for Vine Linux.
183
184* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
185- Update to 5.6.1
186
187* Wed May 25 2016 Rich Mattes <richmattes@gmail.com> - 5.6.0-3
188- Rebuild for assimp-3.2.0
189
190* Tue Mar 22 2016 Rex Dieter <rdieter@fedoraproject.org>  - 5.6.0-2
191- rebuild
192
193* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
194- 5.6.0 final release
195
196* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.9.rc
197- Update to final RC
198
199* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8
200- Update RC release
201
202* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.7.beta
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
204
205* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
206- use %%license, update Source URL, BR: cmake
207
208* Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
209- Update to final beta release
210
211* Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.4
212- -doc: BR: qt5-qdoc qt5-qhelpgenerator
213
214* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
215- Official beta release
216
217* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.2
218- Official beta release
219
220* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
221- Start to implement 5.6.0 beta
222
223* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
224- Start to implement 5.6.0 beta
225
226* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
227- Update to final release 5.5.1
228
229* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
230- Update to Qt 5.5.1 RC1
231
232* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
233- New final upstream release Qt 5.5.0
234
235* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
236- Update for official RC1 released packages
237
238* Wed Jun 17 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
239- Qt 5.5.0 RC1 (initial version)
240
Note: See TracBrowser for help on using the repository browser.