source: projects/specs/trunk/q/qt-assistant-adp/qt-assistant-adp-vl.spec @ 9346

Revision 9346, 5.4 KB checked in by inagaki, 9 years ago (diff)

2015-02-09 Ryoichi INAGAKI <ryo1@…>

  • qca-ossl, qimageblitz, qoauth, qt-assistant-adp, qtsoap: rebuilt
  • qca2: added patch


Line 
1Name:    qt-assistant-adp
2Version: 4.6.3
3Release: 6%{?_dist_release}
4Summary: Compatibility version of Qt Assistant
5Summary(ja): Qt Assistant の互換性を維持するためのライブラリ
6
7Group: System Environment/Libraries
8# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
9License: LGPLv2 with exceptions or GPLv3 with exceptions
10URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
11
12Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
13# missing header files from Debian (Fathi Boudra)
14Source1: QAssistantClient
15Source2: QtAssistant
16# build fixes from Debian (Fathi Boudra)
17Patch1: 01_build_system.diff
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
22
23%description
24The old version of Qt Assistant, based on Assistant Document Profile (.adp)
25files, and the associated QtAssistantClient library, for compatibility with
26applications providing help in that format.
27
28New applications should use the new version of Qt Assistant introduced in Qt
294.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
30
31%package devel
32Summary: Development files for the compatibility QAssistantClient
33Summary(ja): QAssistantClient 互換の開発用ファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: qt4-devel
37
38%description devel
39This package contains the files necessary to build applications using the
40deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
41which is used together with the legacy Assistant Document Profile (.adp) version
42of Qt Assistant.
43
44This class is obsolete. It is provided to keep old source code working. We
45strongly advise against using it in new code. New code should use the Qt Help
46Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
47(also introduced in Qt 4.4) instead.
48
49
50%prep
51%setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
52%patch1 -p1 -b .build_system
53mkdir include
54cp -p %{SOURCE1} %{SOURCE2} include/
55
56
57%build
58# build assistant_adp
59qmake QT_PRODUCT=OpenSource
60make %{?_smp_mflags}
61
62# build libQtAssistantClient
63cd lib
64qmake CONFIG=create_prl
65make %{?_smp_mflags}
66
67# build assistant_adp translations
68cd ../translations
69lrelease assistant_adp_*.ts
70cd ..
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76# install assistant_adp
77make install INSTALL_ROOT=$RPM_BUILD_ROOT
78
79# install libQtAssistantClient
80make install INSTALL_ROOT=$RPM_BUILD_ROOT -C lib
81
82# install assistant_adp translations
83mkdir -p $RPM_BUILD_ROOT%{_qt4_translationdir}
84install -p -m644 translations/assistant_adp_*.qm \
85                 $RPM_BUILD_ROOT%{_qt4_translationdir}/
86
87# install assistant.prf mkspec
88install -D -p -m644 features/assistant.prf \
89                    $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/assistant.prf
90
91# install missing headers (thanks to Fathi Boudra from Debian)
92install -p -m644 include/Q* $RPM_BUILD_ROOT%{_qt4_headerdir}/QtAssistant/
93
94# nuke dangling reference(s) to the buildroot
95sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" $RPM_BUILD_ROOT%{_qt4_libdir}/*.prl
96
97# let rpm handle binaries conflicts
98mkdir $RPM_BUILD_ROOT%{_bindir}
99pushd $RPM_BUILD_ROOT%{_qt4_bindir}
100mv assistant_adp ../../../bin/
101ln -s ../../../bin/assistant_adp .
102popd
103
104# _debug target (see bug #196513)
105pushd $RPM_BUILD_ROOT%{_qt4_libdir}
106echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
107popd
108
109# Note that we intentionally DO NOT install a .desktop file for assistant_adp
110# because it makes no sense to invoke it without a specific .adp file to open.
111# By default, it views the Qt documentation, for which we already have a menu
112# entry using the current version of the Qt Assistant, and there is no UI for
113# viewing anything different. The .adp file needs to be passed on the command
114# line, which is usually done by the application.
115
116%find_lang assistant_adp --with-qt --without-mo
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121
122%post -p /sbin/ldconfig
123
124%postun -p /sbin/ldconfig
125
126%files -f assistant_adp.lang
127%defattr(-,root,root,-)
128%doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
129%{_bindir}/assistant_adp
130%{_qt4_bindir}/assistant_adp
131%{_qt4_libdir}/libQtAssistantClient.so.4*
132
133%files devel
134%defattr(-,root,root,-)
135%{_qt4_headerdir}/QtAssistant/
136%{_qt4_libdir}/libQtAssistantClient.so
137%{_qt4_libdir}/libQtAssistantClient_debug.so
138%{_qt4_libdir}/libQtAssistantClient.prl
139%{_libdir}/pkgconfig/QtAssistantClient.pc
140%{_qt4_datadir}/mkspecs/features/assistant.prf
141
142
143%changelog
144* Mon Feb  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.6.3-6
145- rebuilt on current VineSeed
146- added Japanese summary
147
148* Sat Jan 07 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-5
149- rebuilt with qt-4.8.0
150
151* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
152- fixed BR
153
154* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
155- Initial build for Vine Linux
156
157* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
159
160* Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
161- new upstream tarball with only the compat assistant_adp and QAssistantClient
162- build fixes from Debian (Fathi Boudra)
163- use find_lang to package the qm files (#609749)
164
165* Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
166- use versioned BR/Requires to avoid Conflicts
167
168* Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
169- first Fedora package
Note: See TracBrowser for help on using the repository browser.