source: projects/specs/trunk/q/qt-assistant-adp/qt-assistant-adp-vl.spec @ 10531

Revision 10531, 5.5 KB checked in by tomop, 8 years ago (diff)

qt-assistant-adp-4.6.3-7

RevLine 
[3369]1Name:    qt-assistant-adp
[9346]2Version: 4.6.3
[10531]3Release: 7%{?_dist_release}
[3369]4Summary: Compatibility version of Qt Assistant
[9346]5Summary(ja): Qt Assistant の互換性を維持するためのライブラリ
[3369]6
7Group: System Environment/Libraries
8# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
9License: LGPLv2 with exceptions or GPLv3 with exceptions
10URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
11
[10531]12Vendor: Project Vine
13Distribution: Vine Linux
14
[3369]15Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
16# missing header files from Debian (Fathi Boudra)
17Source1: QAssistantClient
18Source2: QtAssistant
19# build fixes from Debian (Fathi Boudra)
20Patch1: 01_build_system.diff
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
[3377]24BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
[3369]25
26%description
27The old version of Qt Assistant, based on Assistant Document Profile (.adp)
28files, and the associated QtAssistantClient library, for compatibility with
29applications providing help in that format.
30
31New applications should use the new version of Qt Assistant introduced in Qt
324.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
33
34%package devel
35Summary: Development files for the compatibility QAssistantClient
[9346]36Summary(ja): QAssistantClient 互換の開発用ファイル
[3369]37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
[5383]39Requires: qt4-devel
[3369]40
41%description devel
42This package contains the files necessary to build applications using the
43deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
44which is used together with the legacy Assistant Document Profile (.adp) version
45of Qt Assistant.
46
47This class is obsolete. It is provided to keep old source code working. We
48strongly advise against using it in new code. New code should use the Qt Help
49Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
50(also introduced in Qt 4.4) instead.
51
52
53%prep
54%setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
55%patch1 -p1 -b .build_system
56mkdir include
57cp -p %{SOURCE1} %{SOURCE2} include/
58
59
60%build
61# build assistant_adp
62qmake QT_PRODUCT=OpenSource
63make %{?_smp_mflags}
64
65# build libQtAssistantClient
66cd lib
67qmake CONFIG=create_prl
68make %{?_smp_mflags}
69
70# build assistant_adp translations
71cd ../translations
72lrelease assistant_adp_*.ts
73cd ..
74
75
76%install
[5383]77rm -rf $RPM_BUILD_ROOT
[3369]78
79# install assistant_adp
[5383]80make install INSTALL_ROOT=$RPM_BUILD_ROOT
[3369]81
82# install libQtAssistantClient
[5383]83make install INSTALL_ROOT=$RPM_BUILD_ROOT -C lib
[3369]84
85# install assistant_adp translations
[5383]86mkdir -p $RPM_BUILD_ROOT%{_qt4_translationdir}
[3369]87install -p -m644 translations/assistant_adp_*.qm \
[5383]88                 $RPM_BUILD_ROOT%{_qt4_translationdir}/
[3369]89
90# install assistant.prf mkspec
91install -D -p -m644 features/assistant.prf \
[5383]92                    $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/assistant.prf
[3369]93
94# install missing headers (thanks to Fathi Boudra from Debian)
[5383]95install -p -m644 include/Q* $RPM_BUILD_ROOT%{_qt4_headerdir}/QtAssistant/
[3369]96
97# nuke dangling reference(s) to the buildroot
[5383]98sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" $RPM_BUILD_ROOT%{_qt4_libdir}/*.prl
[3369]99
100# let rpm handle binaries conflicts
[5383]101mkdir $RPM_BUILD_ROOT%{_bindir}
102pushd $RPM_BUILD_ROOT%{_qt4_bindir}
[3369]103mv assistant_adp ../../../bin/
104ln -s ../../../bin/assistant_adp .
105popd
106
107# _debug target (see bug #196513)
[5383]108pushd $RPM_BUILD_ROOT%{_qt4_libdir}
[3369]109echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
110popd
111
112# Note that we intentionally DO NOT install a .desktop file for assistant_adp
113# because it makes no sense to invoke it without a specific .adp file to open.
114# By default, it views the Qt documentation, for which we already have a menu
115# entry using the current version of the Qt Assistant, and there is no UI for
116# viewing anything different. The .adp file needs to be passed on the command
117# line, which is usually done by the application.
118
119%find_lang assistant_adp --with-qt --without-mo
120
121%clean
[5383]122rm -rf $RPM_BUILD_ROOT
[3369]123
124
125%post -p /sbin/ldconfig
126
127%postun -p /sbin/ldconfig
128
129%files -f assistant_adp.lang
130%defattr(-,root,root,-)
131%doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
132%{_bindir}/assistant_adp
133%{_qt4_bindir}/assistant_adp
134%{_qt4_libdir}/libQtAssistantClient.so.4*
135
136%files devel
137%defattr(-,root,root,-)
138%{_qt4_headerdir}/QtAssistant/
139%{_qt4_libdir}/libQtAssistantClient.so
140%{_qt4_libdir}/libQtAssistantClient_debug.so
141%{_qt4_libdir}/libQtAssistantClient.prl
142%{_libdir}/pkgconfig/QtAssistantClient.pc
143%{_qt4_datadir}/mkspecs/features/assistant.prf
144
145
146%changelog
[10531]147* Mon Jul  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.6.3-7
148- rebuilt with new toolchain.
149
[9346]150* Mon Feb  9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.6.3-6
151- rebuilt on current VineSeed
152- added Japanese summary
153
[5383]154* Sat Jan 07 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-5
155- rebuilt with qt-4.8.0
156
[3377]157* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
158- fixed BR
159
[3369]160* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
161- Initial build for Vine Linux
162
163* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
165
166* Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
167- new upstream tarball with only the compat assistant_adp and QAssistantClient
168- build fixes from Debian (Fathi Boudra)
169- use find_lang to package the qm files (#609749)
170
171* Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
172- use versioned BR/Requires to avoid Conflicts
173
174* Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
175- first Fedora package
Note: See TracBrowser for help on using the repository browser.