source: projects/specs/trunk/q/qscintilla/qscintilla-vl.spec @ 521

Revision 521, 4.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%global pyqt4_version 4.7
3
4%define ver 1.78
5
6%global qtdir   %(pkg-config --variable=prefix Qt)
7%global qtdata  %(pkg-config --variable=datadir Qt)
8%global qtinc   %{qtdir}/include
9%global qtlib   %{qtdir}/lib
10
11Summary:        A Scintilla port to Qt
12Name:           qscintilla
13Version:        2.4.2
14Release:        1%{?_dist_release}
15# matches up (pretty much) with qt4
16License:        GPLv3 or GPLv2 with exceptions
17Group:          Development/Tools
18URL:            http://www.riverbankcomputing.co.uk/qscintilla
19Source:         QScintilla-gpl-%{version}.tar.gz
20# TODO: upstream this
21Patch1:         QScintilla-2-gpl-Qt4-incpath.patch
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24BuildRequires:  qt4-devel
25BuildRequires:  PyQt4-devel >= %{pyqt4_version}
26
27%description
28QScintilla is a port of Scintilla to the Qt GUI toolkit.
29
30This version of QScintilla is based on Scintilla v%{ver}.
31
32%package designer
33Summary:  QScintilla designer plugin
34Group:    Development/Tools
35Requires: %{name} = %{version}-%{release}
36Requires: qt4-designer
37
38%description designer
39%{summary}.
40
41%package devel
42Summary: QScintilla Development Files
43Group: Development/Libraries
44Requires: %{name} = %{version}
45Requires: qt4-devel
46
47%description  devel
48This packages contains the libraries, include and other files
49you can use to develop applications with QScintilla.
50
51%package python
52Summary:  QScintilla PyQt4 bindings
53Group:    Development/Libraries
54Requires: %{name} = %{version}-%{release}
55Requires: PyQt4 >= %{pyqt4_version}
56
57%description python
58%{summary}.
59
60%package python-devel
61Summary:  Development files for QScintilla PyQt4 bindings
62Group:    Development/Libraries
63Requires: %{name}-python = %{version}-%{release}
64Requires: PyQt4-devel
65
66%description python-devel
67%{summary}.
68
69%prep
70%setup -q -n QScintilla-gpl-%{version}
71%patch1 -p1 -b .designer-incpath-qt4
72
73# fix permissions on doc files
74find doc example-Qt4  -type f -exec chmod 0644 {} ';'
75find src include -type f -exec chmod 0644 {} ';'
76
77# fix line endings in license file(s)
78sed -i 's/\r//' LICENSE.GPL2 GPL_EXCEPTION_ADDENDUM.TXT
79
80%build
81export QTDIR=`pkg-config --variable=prefix Qt`
82%ifarch x86_64
83export QMAKESPEC=$QTDIR/mkspecs/linux-g++-64/
84%else
85export QMAKESPEC=$QTDIR/mkspecs/linux-g++/
86%endif
87
88pushd Qt4
89$QTDIR/bin/qmake -o Makefile qscintilla.pro
90make %{?_smp_mflags}
91popd
92
93pushd designer-Qt4
94$QTDIR/bin/qmake -o Makefile designer.pro
95make %{?_smp_mflags}
96popd
97
98pushd Python
99%{__python} configure.py \
100            -c -j 3 \
101            -n ../Qt4 \
102            -o ../Qt4
103make %{?_smp_mflags}
104popd
105
106%install
107rm -rf $RPM_BUILD_ROOT
108
109make install INSTALL_ROOT=$RPM_BUILD_ROOT -C Qt4
110make install INSTALL_ROOT=$RPM_BUILD_ROOT -C designer-Qt4
111make install DESTDIR=$RPM_BUILD_ROOT -C Python
112
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post  -p /sbin/ldconfig
118
119%postun -p /sbin/ldconfig
120
121%files
122%defattr(-, root, root, 755)
123%doc ChangeLog NEWS README
124%doc LICENSE.GPL3
125%doc LICENSE.GPL2 GPL_EXCEPTION.TXT GPL_EXCEPTION_ADDENDUM.TXT
126%{qtlib}/lib*.so.*
127%{qtdir}/qsci/*
128## %{qtdir}/translations/*
129%{_datadir}/qt4/translations/*
130
131%files designer
132%defattr(-,root,root,-)
133%{qtdir}/plugins/designer/libqscintillaplugin.so
134
135%files devel
136%defattr(-, root, root, 755)
137%{qtinc}/*
138%{qtlib}/lib*.so
139
140%files python
141%defattr(-,root,root,-)
142%{python_sitearch}/PyQt4/Qsci.so
143
144%files python-devel
145%defattr(-,root,root,-)
146%{_datadir}/sip/PyQt4/Qsci
147
148%changelog
149* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-1
150- new upstream release
151
152* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-3
153- rebuilt with qt4-4.6.1, python-2.6
154- installed translation to %%{_datadir}/qt4/translations now
155
156* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
157- updated macro pyqt4_version to 4.6
158- fixed changelog year below (2008 -> 2009)
159
160* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
161- new upstream release
162- added designer, python and python-devel sub-packages
163
164* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-1
165- appiled new versioning policy
166
167* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 1.7.1-0vl2
168- updated macro QMAKESPEC to linux-g++-64 (if x86_64)
169
170* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-0vl1
171- new upstream release (1.71)
172
173* Mon Jun  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6-0vl1
174- new upstream release (1.65)
175- changed Group to System Environment/Libraries
176
177* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 1.4-0vl1
178- initial built for VineLinux
179
Note: See TracBrowser for help on using the repository browser.